[OBSOLETE] Rachio Manager

As some of you may have noticed things at SmartThings are kind of a mess while they transition to the new Mobile app. Basically any submissions to ST are taking many month’s to be processed. So the fixes that were sent to ST to address the Rachio API changes wouldn’t be reviewed for almost 4 month’s.

So I spoke with @franzgarsombke at Rachio and he gave me his blessing to release a community version of the Official Integration which I myself will maintain and be responsible for.

In it’s current state it’s code and functionally are the same as the official integration but I will eventually modify it to support multiple controllers. The only difference is how you authenticate, in this version you will obtain your API key from Rachio’s webapp instead of Signing in using Oauth. I’ve added the UI into the SmartApp to make this as seamless as possible.

Things to know

  • If you have the official Integration installed you will need to remove it.

Automated Installation:

I recommend using the Community Installer:

Manual Code Install


You rock @tonesto7!


This is exactly what I was hoping for, much applause!


I really can’t thank you enough, man. I spend a lot of time repairing our irrigation system, and the easiest way to check if things are working or if there are any leaks is to use Google assistant via smartthings.

Imagine having to fumble through the rachio app trying to turn things off and on repeatedly with your gloves on or hands covered in dirt vs. just saying “hey Google, turn the small plants on/off.”

Real helpful to have this, thank you!


Please, please on the multiple controllers.

Any plans to integrate the Spruce Moisture Sensors? I’d love to have several of them act like rain sensors and stop watering schedules until the moisture goes below a specific %. I don’t want to mess with IFTTT and increase the complexity and number of things that could go wrong.

Two questions:

  1. can you summarize what functionality is here (now) in this updated app vs the official one? , and

  2. I’d like to use my soil moisture sensors to trigger watering, any recommendations for how to best do this? Before I installed SmartThings I had an IFTTT trigger between WirelessTag.net and Rachio, but now that I have SmartThings I imagine there’s a better way.

Thank you very much! Rachio, SmartThings and WirelessTag.net (longer distance moister/temp sensing) have all been great individually, but I’d like to get them working together a little more.

@tonesto7 is there a description of what your app does compared to what ST offers? I’m just reading the posts here and it seems that it fixes some issues but I’m feeling as though there is more detail somewhere as to what the capabilities are.

Not sure what info I can provide, but I’m having trouble getting this to work. The native SmartThings Rachio integrations stopped working a few months ago. I first uninstalled the original Rachio devices and the Smart App. Then I installed the Rachio Manager above using the Community SmartApp Installer. I added my API key successfully and it added the Zones (Devices) in. However, these Devices are also not working, they just show as unavailable. Any thoughts on how I can troubleshoot further or fix this?

I would like to know the differences between this and the original integration. My original integration works fine. Thanks.

If things are working with the official then there is no reason to change over to the new version

1 Like

Hey tonesto7, is there any way to expose the photoId property of the Zone JSON object? I’d love to have the actual picture of the zone available in my SmartThings app.

Hi there,
I just got Rachio Gen 2 installed and it works really good by itself but not through SmartThings
I tried both methods the official ST app and the above github app and dh
It logs on to rachio servers and installs devices but although it says connected it has a red dot to each of the zones and nothing happens if you send a command through ST app.
are others having the same issue is there a work around ?? or am i doing something wrong.

Thank you for your help in advance

Where do I input the api key?

Just wanted give you guys a heads up. I’ve updated the Rachio Manager SmartApp to add support for multiple controllers.
It’s not live yet I just want to perform a bit more testing before I push it out tomorrow.

1 Like

Rachio Manager (v1.1.0)

  • This release adds support for multiple controllers.
  • Lot’s of bug fixes and cleanups

Upgrade Notice:

I tried my best to cover all scenarios in handling the upgrade migration process.


I just applied the update and I’m still not able to get this or the official install to work. It shows the Rachio device in the SmartApp and lists the Zones in the SmartApp. It then adds a device per zone (although it keeps the names I set for them from the original install of the Rachio interface last year). Each device/zone shows as unavailable and never updates nor can I control the zone with it. I’m at a loss on how to further troubleshoot. Thoughts?

I would remove everything and start over

Are you trying to install the official SmartThings integration or are you trying to install @tonesto7 community version?

Just in case people missed it, Anthony wrote the official integration for Rachio and ST, which ST published officially. Rachio made some updates to the API which required some changes to the official ST integration however, official integrations have to go through a stricter process of approval as opposed to unofficial community SmartApps and Device Type Handlers and right now that strict process is taking a LONG time SO… Rachio allowed Anthony to release what WOULD be the official integration as an “unofficial community integration” so that we can get the updated code now as opposed to waiting for the official integration to be updated.

I had to delete all of my official integration and then installed the version being discussed here through @tonesto7’s absolutely amazing Community Installer with basically one click and some credentials.

If you are not using Anthony’s Community Installer, you really really really really really REALLY should be:

[BETA] Community SmartApp Installer


You missed a “really” in there somewhere … maybe between the third and forth one :stuck_out_tongue_winking_eye:

Lastest upgrade (v1.1.0) working fine here :+1: