[OBSOLETE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

I’m looking at getting an Iris, but need some direction on what can/can’t be used together.

My current setup is SHM with a few local devices, and one simulated device (to allow for entry delays through WebCore). I’d like to keep using SHM as the “brains” due to local processing, but others have indicated that lock manager and SHM should not be used together.

If I don’t use lock manager, am I still able to create codes and use SHM for “monitoring” and WebCore for entry delays?

FYI, SHM doesn’t run completely locally.

The alerts you setup in SHM can run locally, assuming all the devices themselves are eligible for local execution (I think).

However, arming and disarming SHM requires that your hub has an active internet connection and the ST cloud is functioning too.

And any SHM monitoring rule that incorporates a simulated sensor wouldn’t run locally too.

At least that’s how it was working the last time I checked.

Provided the devices are all local, I believe that arm/disarm would also be local. And again, as long as devices are local, the alerts are also local.

I’m aware that using a simulated sensor and WebCore would make that component not run locally (and I accept that part of the system would be down in the case of an outage), but is there some way to integrate the keypad into SHM such that I can keep as much as possible running locally (ie, the non simulated devices), since we know that lock manager runs entirely in the cloud?

But how would you arm/disarm SHM if the cloud were down? Mobile app, routines, WebCoRE, none of them would be functional.

Iris keypad isn’t officially supported, so it requires a custom device handler. No custom device handlers are eligible to run locally, unfortunately.

Hi. I bought the IRIS keypad on ebay and am in the process of integrating it into my system. I installed the DTH, ULM and SM apps at the top of this post. When I followed the instructions, I was able to get the keypad to “Arm” (and disarm) the system; however, whenever motion was triggered, or a door was opened (past the delay time), SM fails to indicate/recognize that there is an intrusion. I am therefore not able to get a text notification if there is an intrusion while the system is armed.

To remedy this, I re-installed the ULM and SM app and configured as suggested. This did not make a difference. Reading through the previous posts, I noticed that SM could conflict with SHM, so I uninstalled SHM. This also did not make a difference.

I am intrigued by @arnb recommendation to use e Thayer’s lock manager and the delay for SHM. I however do not know how to re-install SHM.

Does anybody have a suggestion on how I can get the ULM/SM recognize/notify me of an intrusion?

Does anybody know how to re-install SHM?

I appreciate the support on these forums!

I’m not sure this will work but it’s worth a try.

  1. In your ST phone app, tap on bottom ‘Automation’
  2. tap ‘+ Add a SmartApp’
  3. tap ‘:heart: SmartThings Recommends’
  4. Tap ‘Smart Home Monitor Security’
  5. You are on your own. Let us know if it works

SM = smart alarm? Smart alarm is a pretty old smartapp at this point that’s not really actively developed/updated anymore. Smart home monitor, for all its flaws, is a better bet in my opinion. Especially with the delay smartapp from this thread.

If you uninstall SHM security in the IDE you should be able to reinstall it from the dashboard in the mobile app.

@arnb reinstallation of SHM worked as you indicated. Thanks for this and all of your efforts to help the community.

1 Like

Hey everyone, I’ve read through the majority of this thread, and am not able to find the specific problem I’m having. I apologize if it’s here and I just missed it, but man, this thread is long.

I am a new user (installing this week) and picked up an IRIS keypad model 3405_L because it seemed like the right thing to use for my security at my business. I want to have multiple users and track who uses it. So I have User Lock Manager (ULM) app installed as well as Smart Home Monitor (SHM). But I can’t make the Keypad arm or disarm the system.

On the ULM app I have the Iris keypad selected under “select locks” and under Keypad Info I have the Iris Keypad selected as well. For routines I have “Goodbye!” set for arm/away and “I’m Back!” set for disarm.

I have 1 user added with a code of 1234 to play with it. From what I understand (I saw conflicting info) I should be putting in the code 1234 then “on” or “partial” to set Arm/Away on SHM. And 1234 “Off” to disarm SHM. Neither does anything.

I’ve tried doing the code without the buttons. I’ve tried doing the code then on/off and have tried on/off then the code. No reaction.

When I look at the keypad in my things it says “Disarmed”. If I select the device from the list I see a control panel with a big green “disarmed” on it. There are 7 tiles below that. “motion” and “Off” are in color (blue and green respectively) there are 5 more that are “grey”: Tamper, Panic, a speaker, a reset/refresh symbol and “80% battery”. Recent activity shows changes whenever I’ve made changes in the ULM. So if I unlink the keypad and relink it. it will give updated status. They keypad beeps whenever I touch a button. and if I set the ULM to notify me if a bad code is used, as soon as I type in a 5th number it does a two tone beep. So it seems to know something is happening.

Help? Any ideas why it wouldn’t be sending a signal? Am I missing something?

Update: I just noticed it’s updating the temperature in the right now and recently tabs. So its definitely communicating at least for that…


ULM deprecated see following link

I just installed the Iris Keypad 3405-L1 and I am using ethayer’s Lock Manager and arnb’s SHM Delay. Everything is working as expected except for the exit/entry beeps. How do I enable those? A second but less pressing questions is how do I use/enable the panic button?


Thanks! I’ll give it a shot tomorrow am.

That is the keypad DTH I am using, but not the same lock manager app I have installed… And I assume the delay is just to give entry/exit delays. I saw a bunch about that but was worried about getting it actually functional before trying to get that running. Sweet to have it all here in 1 reply though! Thanks again. Here’s hoping!


Panic Button: no idea don’t have Panic on my Xfinity keypad

Sounds: in no particular order

When I manually test the keypad tone it works. Toggling #8 does not affect the manual tone test. Still can’t get entry or exit tones. Toggling #8 also does not affect entry or exit tones.

I have discovered a larger problem. The exit delay is not working…

Edit: I just figured out the exit delay only works when you arm from the keypad. I was testing from my phone at times. Still not exit or entry tones.

Second edit: Exit delay is only working with the keypad and only when set to Armed/Away. I would like the exit delay to work with Armed/stay. Is this possible?

Confused about why no tones on exit delay or entry delay, but tones from DTH screen. It’s failing in two independent SmartApps. Usually it’s the wrong DTH. Make sure it matches image below. You should also see the commands being sent to the device by tapping on DTH “Recently”

Please try following for exit tone.
In Lock Manager keypad profile settings set:
Act as SHM device : on / true
Arm Delay 30 or number of your choice
Then arm system from keypad in Away (xfinity/centralite) On (Iris)

For entry tones in SHM Keypad Profile
On settings page 1 Alarm elay time in seconds: 30 or number of your choice
Make sure the Keypad is specified in the SHM Delay profile (second settings screen, scroll down)
Tones should sound when armed in Away/On mode and associated contact sensor opens

Armed / Stay is generally “Night” mode. In the SHM Delay Global Settings set True Night Mode to Off/False

BTW are you using an Iris or Xfinity/Centralite Keypad?

OK. Installed all that stuff (Except the delay app, not messing with that right now). Same problem.

I see the keypad. It feeds back temperature just fine. When I install or change anything in the app I et a message saying the iris keypad is disarmed. I’ve taken a bunch of pics of my app screens to see if that makes anything jog for anyone looking. I am beginning to think the keypad its self is just faulty? (and would have settled on that a long time ago if it wasn’t for the fact that it’'s clearly communicating on SOME level)

Did I mess something up?


In the Keypad settings set Arm/Stay and Arm/Night to Night routine.

Are any Core, WebCore, or other app installed that may interfere with nominal keypad operation?

Do beep tones work from DTH? tap speaker icon?

Try arming your system with the keypad by entering your pin; then On (Away)
(Not sure it could be On then pin as on my Xfinity)
Should give 30 second exit beeps (last 10 secs are very fast)
then after delay period system should go into Away mode, check on your Phone app SmartThings status

Set Arm/Night, etc: OK I set them to “I’m Back” I dont have a night routine. its pretyt much a binary system. everything is all on or everything is all off. Since its a business we are either in there and working or everyone is gone.

core/wecore: I don’t think so? but nothing of those names for sure. Here are the apps I have installed:

The keypad Beeps when I press buttons. If I do a few of the things I found in other places like push and hold 8 to change a setting… it gets the beeps. It beeps differently at me if I try to enter 5 numbers. And at various stages of playing with this and trying different apps. At one point I would get a delay beep when a contact was tripped no matter the state of the system… door contact 1 is opened and the delay would start. beep…beep…
for about 20 seconds then a faster beeping then it would stop. (This happened when I was using SmartAlarm app for a bit before i figured out it was not being supported any more and thought maybe that was the issue). Panic button creates a tone when I push it.

I’ve tried both pin/on pin/off and on/pin off/pin. None of them arm.

I do have some key fobs I got with the stuff I bought a long time ago I was going to use it with securifi almond + but the router quit before they ever got the support running for it right. And those work perfectly. At this point just thinking I’ll go buy a few more of those and have everyone carry one. cause man. I;ve put days into this so far and just cant make it work.

Everything else is working brilliantly. just can’t get the keypad to arm or disarm the system. It acts like it doesn’t send the contact or signal when the code is pushed.


I beleive on the Iris it is pin followed by ON/Off/Partial Can someone with a working Iris keypad please confirm

I assume Smartalarm is removed, but it along with the DTH test confirms key pad works. There is only exit delay, no entry delay in the Keypad module, that requires SHM Delay, however until the exit works I suggest waiting.

Just a thought, you do have User’s with Pins added to the Lock Manager?

Panic button AFAIK is not supported beyond the DTH. What is should do is go into immediate intrusion alert status. ST in their wisdom has not documented that process so developers are stuck with using simulated contact sensors

Please do some additional exit delay testing then check the DTH “Recently” for any issues or missing commands. You should see it issue the Exit Delay command.