[OBSOLETE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

I found the issue. Modules SHM Delay Child and my version of Keypad were modified to issue the setArmedNight command only on an Xfinity or Centralite keypad type 3400. The Iris should show as a 3405-L, please check your device list and confirm.

Please update both modules from the repo or code and post the results on the SHM Delay thread.

Regarding the keypad data entry I’m after, sorry I gave you invalid info. In the Ide Log for the keypad look for something like the following when arming in “Partial” mode.

Received arm command with keycode/armMode: 9999/2
Where 9999 is your pin and 2 is the armmode. it may be 1 or 2 0=off 3=away
Please let me know the armmode.
Thank you

The factory reset procedure is here: https://www.youtube.com/watch?v=eeqUJKU6HMA

It 100% does not work on my two keypads. The keypads previously worked, but then were reset and paired to an Iris hub for firmware updates (battery drain issue) and since then refuse to factor reset. I’ve tried this procedure literally several dozens of times with new batteries, different delays, etc. I am convinced my keypads are just fubar and are trash.

It looks like it’s “1”:
“Received arm command with keycode/armMode: [xxxx]/1”

Also, after the update it appears to be working now! Thanks. SmartThings should really consider hiring you and a few of the other programmers here to help them write some much needed code for their product.

Thank you for the info on the armcode and the positive comments about the folks here who provide their time coding Smartapps and Device Handlers.

However, I honestly feel Samsung may abandon or deprecate the current ST platform in their rush toward the mass consumer IOT market.

I really hope not. I guess we’ll see.


since youve updated the firmware on your keypad.

can you tell me the model number of the Iris Hub V2 you’re using?

I see online my local Lowe’s has one Iris Hub in stock. I dont see in the description whether it’s V1 or V2. I just see the model number- “9412-L”.

let me know.


I have the Iris Keypad setup in SmartThings app along with the ULM and Smart Alarm apps. However I cannot get it to work with my Arlo Pro Siren. When I go into Smart Alarm > Alarm settings, there is only the option of “Home” as my siren which is the Iris Keypad I think and not the Arlo Pro BaseStation. It lets me choose the Arlo Pro as a motion detector but not as a Siren and not even as a camera…

Anyone know what I’m doing wrong? The Aro Pro is added to my SmartThings account…

Nevermind, I got it to work. Must have not set it correctly, now its working fine. Awesome. Thanks for this DTH and APP!

OK I am still having one problem. Entry and Exit delays are not working. Its set to 30 seconds. But when I use the keypad to ARM and open the door(with door sensor) the siren goes off right away.

The keypad shows a status of “ENTRYDELAY” under devices in smartthings…

EDIT: OK I figured it out. You cannot use Smart Home Monitor if your using Smart Alarm and ULM. You also MUST set the routines in ULM AND in Smart Alarm.

Lock Manager does not support EntryDelay. One way to achieve an entry delay is with my Smartapp, SHM Delay.
Btw ULM is deprecated, use ethayer’s Lock Manager

So use ethayers Lock Manager and SHM Delay along with SHM(SmartThings official app)?

That’s correct. Be sure to use the keypad dth suggested in the SHM Delay documentation

Can someone post a step by step instruction to add Iris Keypad as a new device? Some of the instruction have “Install DTH” as the first step, but how to install DTH? Do I have to add my hub to the Developer page first? Thank you much!

Check @jdroberts Faq

1 Like

When you are ready

  1. install a Keypad DTH
    The direct link to the Keypad DTH I suggest is at the end of this message.
    The Repo settings are miriad Centralite-Keypad master The name is Centralite Keypad.
  2. Pair the keypad with the Hub and test it
  3. then install @ethayer’s Lock Manager
  4. then my app SHM Delay

I copy-pasted the above code and clicked “Create”

I got the following error message:

No signature of method: script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467.metadata() is applicable for argument types: (script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467$_run_closure1) values: [script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467$_run_closure1@2e768059] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

What am I doing wrong?

Add it to devices not apps

@tapsemi, You have to install select the Lock Manager first (which is the second option), before installing the other 3 childs. And another tip is to pick “Z-wave Lock with Code” as the type under IDE My Device for the Lock Manager to recognize it has a keypad devise.

I was able to install the Lock Manager smartapp. But my next problem is how to set disarm passcode.

This is what I did on the SmartThing (ST) app on my phone:
Markplace> Lock Manager> New Keypad, and added the smartapp on the keypad.
Markplace> Lock Manager> New User> Set Code 4-8 digits, select slot 1.

After doing that I the keypad appeared to be armed when I arm the ST app. But right now the keypad will trigger an alarm when I press any key on the keypad. It’s a good sign because it means the keypad and ST is communication, but that also means the passcode doesn’t work. How do I use the keypad to disarm ST system? Thank you.

Really shout out to all the programmers. You guys are amazing typing up the code and instructions! Really appreciate your works!!

Are you installing a keypad or a lock?

In either case

  1. remove the market place app
  2. then follow the directions to install this lock manager into the IDE.
  3. Then on your phone go to Automations–>tap Smartapps on top menu–>scroll to bottom–>tap + Add a Smartapp–>Scroll to bottom–>tap + My apps. Install lock manager from the list

OK I need some help with the IOS keyboard config! I was going around the house calibrating all my temperature sensors. I came to the Centralite keypad, and was not able to use a minus 5 degrees. There is only an option for + degrees. Can someone give me some guidance on this?