SmartThings Community

[RELEASE] Lock Manager

smartapp_locks

(Dana ) #1565

That, or pixies. Bizarre…


(Mike) #1566

My next step this evening will be remove the lock from smartthings, reset the lock, put a code directly into the lock and leave it. Isolate the lock completely from any outside systems to see if it holds the codes that way.


(jkp) #1567

Also check the cables in the lock to ensure they have a tight connection. Is this a new lock? Perhaps the batteries that came with it should be replaced.


#1568

Before you do the codes directly on the lock, perform the same steps we did yesterday with Smart Locks. Then enter one code (#3) and let that sit over night.


#1569

General question on Lock Manager. I just purchased a an IRIS key pad. Do I use the Zwave lock with codes as the DTH? If not, what should I use. Lock Manger works great with my Schlage lock!!!


(Arn B) #1570

Assuming you are using Ethayer’s Lock Manager you need to use the Keypad Module to define the Keypad. User pin codes for the Iris Keypad must be 4 digits.

Use the keypad DTH at miriad/Centralite-Keypad/master, or you may get it at this link: https://raw.githubusercontent.com/miriad/Centralite-Keypad/master/devicetypes/mitchpond/centralite-keypad.src/centralite-keypad.groovy

Along with these two SmartApps

This should get you up and running. I’m using this exact setup with an Xfinity/Centralite Keypad.


[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps
#1571

arnb:

Thank you very much. I did not know where to get the Centralite DTH. I have been using Lock Manager for the last several months and it has been great. I have been jacking with this keypad since 2 days before Christmas. Thank you for providing the missing link.


(Mike) #1572

Sorry, I’ve already removed the lock from smartthings, reset and programmed directly into the lock. If (and this seems to be a big if) the codes stick and work, I’ll re-add the lock to smartthings and add 1 through smartlock and see what happens. Then IF that one sticks I’ll reintroduce lock manager.

Start from the beginning and add 1 thing at a time to see where it breaks.


(Dana ) #1573

Congrats on retaining your sanity through all of this, Mike.


#1574

Not sure any of us are sane. Just better at masking it.

You know, there’s a jingle we can start singing… :joy:


#1575

Perfect plan. Troubleshooting 101 (one thing at a time), not 50. Never find a root cause that way. I think ruling the lock out directly is a better course of action. You will know if it’s defective sooner. :slight_smile: or if its a SmartThings issue.


(Mike) #1576

24 hours now since the reset and programming codes directly into the lock, all codes are still functioning. So I’m going to rule out it being an issue with the lock.

Next test is the SmartLock app, I’ll add 1 code through the app and see if it sticks.


(Dana ) #1577

Fingers crossed.


#1578

I just couldn’t see the lock being faulty. Had the codes not been able to be stored at all, then ya, that would resonate to me. Is it possible that there is some sort of faulty storage mechanism in the lock? It is possible that something could be wrong with it.

So after you test Smart Locks and if that sticks.

Then if you want to get down to the bottom of everything, you need to determine if it is Lock Manager or the associated Device Handler that is crippling it. After you perform your 24 hour testing on Smart Locks, I would start over and do the test with Lock Manager and the “z-wave reporting” Device Handler. If that holds for 24 hours then you know most likely what he culprit is. If it fails, then you have the other answer.

Like Dana said, Fingers crossed :slight_smile:


(Mike) #1579

24 hours on smart locks and everything is still functioning. Using the Z-wave lock (not the one that says with codes) DTH. Having done some research the one that does not say with code is an updated version of the DTH.

Before implementing lock manager into the mix, does anybody know of it will work with the default DTH? I’d like to implement the app with a DTH that I know is currently working before switching device types.


#1580

I would use the “z-wave reporting” for now. Not sure if the stock one is supported. I know that my version of rboys now supports using the stock one just so u can be compatible with Smart Locks, but that is basic function with Lock / Unlock and nothing more.


(Mike) #1581

So this morning with zwave lock reporting DTH, lock does not respond to any codes.

A few things I observed.
When switching to the zwave lock DTH and lock manager, the lock had 7 codes already set. According to the user manual, lock manager in learn mode should read these codes from the lock and display in the app.

This is what mine looks like.

I should also note I noticed the blank lock codes screen early on in the troubleshooting

The manual also indicates by hitting done (save??) it should re-initiate this learning process. On mine, this does not happen.

I also noted that with zwave reporting it would allow me to created users with any length codes even though the lock is set at 4 digit codes.

I could save a code and it would send to the lock but the code does not stick.

Switching to z-wave schlage touchscreen lock, which is the modified version of garyd DTH from ethayers repo, I can see in the history right away that it reads the 4 digit code setting from the lock.

This DTH also does not read any of the previously stored codes from the lock. It also allows me to set codes, and right now one hour later the codes are no longer working on the lock.

So at this point, I’ve determined the lock functions by isolating it completely on its own. I’ve determined it communicates with smartthings by using the stock DTH and stock app. The issue occurs as soon as Lock Manager is introduced into the equation. Whether that issue is with both DTH’s or with the app itself, I’m not sure.


#1582

Well that’s great troubleshooting.

Determined that the Lock itself is solid and retains codes and they work the following day

Determined that Smart Locks with the stock DTH is solid and retains codes and they work the following day

Determined that using Lock Manager with either of the two DTHs either does not retain codes or that they don’t work the following day.

I would get in touch with the developer and see what logs or tests he wants you to provide so that he can troubleshoot it further and see if he can find a cause.


(Glen King) #1583

@mrobi: I experienced some similar issues back when I first tried to install this for my Schlage lock. Turns out I had not installed things correctly. I deleted it all and reinstalled, and since then things are great. I’ve not read all the posts for your issue, but have read some. Forgive me if some of this has been covered, but here are things that are happening for me:

I have a few codes in the lock.

I make sure that any codes in the smartapp come after the used slots in the lock itself. So if you have seven codes in the lock, the first slot you use in the smartapp is slot 8.

I don’t need the app to learn the codes that are in the lock. That said, the DTH does a great job of alerting me to which slot - and therefore which user - has unlocked the door and when.

Hope that’s useful to you.


#1584

He factory reset the lock with each test we ran.

  1. Direct Lock adding codes (No SmartThings). Code worked following day.

  2. Lock with Smart Locks installed using stock DTH. Code 1 and 2 default set, so added code to slot 3. Code works next day.

  3. Reinstalled Lock Manager using one of the two custom DTH and adding code to slot 3. Code worked. Next day, it did not.

  4. Switched to the other DTH for Lock Manager and entered code in Slot 3. Code worked. An hour later, code no longer worked.