[OBSOLETE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

and from what I was explained earlier, smarthome is the default monitoring app through smartthings? if so, ill give your delay app a try… that is a very handy idea!

Yes SmartHome is the default.
Thank you for giving it a try. Any feedback would be appreciated.

Question - I have 2 keypads, one of which was added a long, long time ago and one I added today. On the one I added today, the network indicator light continues flashing even though the keypad seems to work fine. On the older one, no lights are active until I approach it. I’m using mitchpond’s original DTH and his X-3400 keypad manager, though I will be switching those out Any thoughts why the indicator light might be flashing?

The continuous flashing of the network light generally indicates that the
keypad hasn’t finished pairing properly.

I believe there was an issue with the timings from mitchpond’s original
DTH, where some keypads didn’t want to finish their pairing, but did work,
at least most of the time.

When using the DTH from this thread, pressing the tamper switch after
pairing has “completed” should cause the keypad to actually finish the
enrollment process, and stop the flashing (and probably beep at you too)

Thanks! Everything appears to be working now. Debating whether I should stick with Mitch’s Keypad Manager or go ULM. I think I’ll install ULM and play with it a bit.

The ULM (User Lock Manager) is deprecated. You may want to try E Thayers Lock Manager, then add my SHM Delay to get an EntryDelay

i cant seem to find the latest version DTH for iris keypad (centralite) Does anyone know of this?

Pretty sure you can still use the link at the top of the thread for the github repository.

Anybody add or remove and re-add one of these lately?

If so are you on android?

Does it work?

For one reason, one of mine reset to factory. I had to re-add it now it won’t work. Acting like these did years ago when adding on android, something was broke with the android ST app and adds for these while completed were not allowing the device to work property for some reason.

I added mine to an IRIS hub months ago to update the firmware and was never able to get them to factory reset and pair ever again.

Take the batteries out.
Hold down either the on button or the partial button while putting the batteries back in.
It makes a crazy chiming tone thing.
Start ST discovery.
Press the on button

I’ve done this many times

For the factory reset, you might have to hold down one of the buttons above, and the tamper button in the back while putting in the batteries.

I’m using this device handler for my Iris Centralite keypad. It all seems to work fine, except the status doesn’t update on the keypad when I arm it to partial (by that I mean the partial light will not light up, even though it does arm SHM to armed/home). I was wondering if anyone else has had this problem? It seems to show the correct state the rest of the time. I know this isn’t a huge deal, but it would be nice if it updated correctly. I have reset the keypad with the same results. I don’t have an Iris hub, so I don’t know the version of the firmware on this keypad (although, I’d be hesitant to update it given some of the experiences of others above). Thanks for the help!

I may be able to help, but need more information.

  1. In the Lock Manager–>Iris Keypad Profile: is Act as SHM device? set to: true/on or false/off.

  2. After arming with the “Partial” button, what does it say in the My Home -->Iris Device–>recently log:
    Armed Night or Armed Stay?

  3. Disarm SHM, then in the Dashboard, tap Armed (Home). Does “Partial” light? (Act as SHM device must be true)

  4. Is the SHM Delay app or any user written Core Pistons in use for the device?

  1. Yes, the Keypad is set on/true to act as SHM device
  2. It says Armed Night
  3. Yes, if I arm it through SHM, the partial light will light on the keypad.
  4. Yes, I’m using your app for the SHM Delay. I don’t have any pistons that affect the keypad.

Thanks for your help!

Thanks that info really helps.

When arming via dashboard it sets Armed (Home) mode aka Stay that sets the “Partial” light on your keypad.

When arming via keypad with “Partial” setting “Stay (Night)”, there is no matching button on the Iris keypad to light as there is on the Xfinity key pad that has Home, Night and Away armed modes. SHM delay was developed on my Xfinity keypad.

I want to be 100% sure before moving forward with any changes. Please let me know the following

  1. Which version of the Keypad module is being used: The original or the SHM Delay modified version?

  2. In SHM Delay global settings: Is True Night set on/true or off/false.

  3. In SHM Delay global settings: Mode Fix: on/true or off/false if on please include your settings

  4. Please go into the IDE then click/tap Logs. Then arm the keypad in “Partial” mode. Go back to the log and find the transmission from the keypad with the pincode and alarm code. You will see a bunch of stuff then your pin perhaps a slash then a number: 0=off 1=stay 2=night 3=away. What is the number? If there are too many entries, click on the matching keypad text following “All” to filter the log entries

  1. I’m using the SHM Delay modified version.
  2. I have True Night set on/true.
  3. Mode fix is on/true, and my setting are: for Disarmed/Off I have “home” as the mode for both valid and default; for Armed (Away) I have “away” as the mode for both valid and default; and for Armed (Home) I have “night” as the mode for both valid and default.
  4. For this I don’t see a great match up, but there’s a line that says “send 0xC200 1 1, delay 100” and a lot of lines that say “Sending Status 0200 to device…” Is that what you needed?

Thanks again for your help.

I found the issue. Modules SHM Delay Child and my version of Keypad were modified to issue the setArmedNight command only on an Xfinity or Centralite keypad type 3400. The Iris should show as a 3405-L, please check your device list and confirm.

Please update both modules from the repo or code and post the results on the SHM Delay thread.

Regarding the keypad data entry I’m after, sorry I gave you invalid info. In the Ide Log for the keypad look for something like the following when arming in “Partial” mode.

Received arm command with keycode/armMode: 9999/2
Where 9999 is your pin and 2 is the armmode. it may be 1 or 2 0=off 3=away
Please let me know the armmode.
Thank you

The factory reset procedure is here: https://www.youtube.com/watch?v=eeqUJKU6HMA

It 100% does not work on my two keypads. The keypads previously worked, but then were reset and paired to an Iris hub for firmware updates (battery drain issue) and since then refuse to factor reset. I’ve tried this procedure literally several dozens of times with new batteries, different delays, etc. I am convinced my keypads are just fubar and are trash.

It looks like it’s “1”:
“Received arm command with keycode/armMode: [xxxx]/1”

Also, after the update it appears to be working now! Thanks. SmartThings should really consider hiring you and a few of the other programmers here to help them write some much needed code for their product.

Thank you for the info on the armcode and the positive comments about the folks here who provide their time coding Smartapps and Device Handlers.

However, I honestly feel Samsung may abandon or deprecate the current ST platform in their rush toward the mass consumer IOT market.