[OBSOLETE] Lock Manager

I can’t seem to get this to work with my Yale YRD446.
The latest version mentioned that it’s unnecessary to use a special DTH.
When adding the lock to the hub it comes up at Z-Wave Lock.
I tried with the default ST DTH, and changing it to “Z-Wave Lock with Codes”.
No luck…

I’m not exactly sure what feature you are asking about. Could you explain in more detail or even better show the section of the manual? Pretty much all of Yale’s available options I have in the DTH except language selection.

I was able to resolve this with a dipswitch on the kwikset 916 lock. Thanks.

I unfortunately don’t have a ZigBee Kwikset lock to test with but from what I understand, none of the commands are supported except manually through dip switches. Because of this, for Kwikset locks, my DTH shows the current setting but you can’t modify them. As I’ve never actually tested this I don’t know if that is true for everything.

I already deleted this DTH and I can’t find where to download it again. Can anyone post it for me? Apparently ethayer deleted it from his repo.

When I try to installing the Apps from the ‘update from repo’ I can select the 4 apps but when I check publish and click ‘Execute Update’ I get the following error

500: Internal Server Error
Reference Id
Wed Mar 15 15:51:52 UTC 2017

@Dan_Fox its on this repo. And change from master to legacy

1 Like

I tried that. It’s been removed. Legacy repo is empty.

Hmmm … you need to switch to the legacy-code branch:

@Dan_Fox Im looking at it, not empty. Make sure you are changing the branch

Got it. Sorry for the trouble. I’m new at this stuff.

I am getting the same error when adding the 4 apps

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Wed Mar 15 16:55:54 UTC 2017

@maxpowers Make sure you two-step this.
Step 1 - select ‘Lock Manager’ from the IDE, check ‘Publish’ checkbox and click ‘Execute Update’

Step 2- After ‘Lock Manager’ is installed, then go ahead and click update from repo, select the Lock Manager repo again, select the 3 remaining child apps and then click ‘Execute Update’ (you can leave the publish checkbox

Is anyone else getting “Updated 0 devices and created 0 new devices (1 skipped due to errors)” when trying to pull the Schlage device driver into ST using github integration?

Yes, I am getting this too. I actually reached out to SmartThings support and they said they couldn’t help. I then pinged an engineer at SmartThings who also got the same error. He said he was going to have another engineer look into it.

1 Like

thanks! I have the same error!

Newbie here so apologize in advance. I tried the universal zigbee DTH and noticed I was unable to unlock or lock my kwikset 910 from the app after the change. Can anyone recomend a DTH for the 910 that works with lock manager but also allows you to lock and unlock from the smartthings app?

EDIT: Turns out the DTH was the problem. The native Zwave DTH does not work with lock manager for my kwikset 910. I had to get the Rboy DTH and now the lock manager app works. Thanks for the great app!

I have a 910 too. Loaded the lock manager and can’t edit/add users to the lock. Doesn’t overwrite the users added to the lock on the device itself. Almost like it doesn’t communicate. Is this the same issue you had? Can you tell me what you did to fix it if it was? And if you can tell me how I can get the rboy handler, link if possible. Newbie too. Thanks.

Yes, I tried everything but I could not get the lock manager to work with any of the DTH’s! I would add my lock, and it would download the slot information. But for some reason, it didn’t recognize the existing codes that I had manually setup on the 910 zwave. I am wondering if maybe the problem is that I have a master code setup? I don’t know. I also tried assigning new codes using lock manager, and the app allowed it but then I would test the new code, and it never worked on the lock. So althought the app allowed me to add a new user and code, it never actually communicated this data to the lock.

What finally worked was the Rboy zwave DTH paired with the latest version of lock manager. I would share the DTH code with you, but since Rboy is a paid site, I think that would probably be frowned upon. Maybe the admins can chime in on that.

EDIT: here is the link https://smartthings.rboyapps.com/

Yes that is the exact problem to the key (no pun intended). Just wondering if there is a work around with the existing app I already have, maybe a change in the coding?