[OBSOLETE] Lock Manager

I’m very new to the use of this app. I am integrating it with a QwikSet 910 smart code. I was able to get it all running, added users, assigned codes, and tested them on the lock. At some point after doing this, I see an error with the on the slots used. It would hang on “Pending refresh…” and then eventually error out. Any ideas or help would be greatly appreciated.

Thank you for letting me know. I’m not really sure what this could be based on the information you provided.

It sounds like everything was working well until you clicked ‘Refresh Lock Data’ and then you went to the lock info screen and something threw an error. What do you mean? Can you explain what the error looked like?

Something helpful to do, is to log into the SmartThings IDE and take a look at the log page. Then, on your mobile device you will do the action that caused the error to happen again. You might see a red error message at the top of the screen that says something like ‘you are not authorized…’ While the real error will display in the IDE logs.

The error typically looks a little like this:

If you could send me that error message in the IDE logs, I could probably help you out. Be aware that sometimes the IDE logs contain personal information like lock code numbers that you might not want to share on the public thread.

Wheno I hit the refresh button, I can see in the ide log that there are
code requests, starting at 30 and working down to 1. Once it gets to a
code slot that is not used, no response is seen, and the code request for
that slot repeats, semmingly endlessly. I just began playing with this
today. I will need to dig more into it if there is more useful info. To get
the lock back to a good status, I manually reset the lock and re-added it,
and recreated the users and code.

I just checked the status in the app, and the 4 slots I have set has a
status of failed to create user code. So it seems the initial setting of
the code works, but there is some issue with the device refresh.

Ok, so is it the error on the lock info page that says… “Lock info was unable to load. There may be an issue with the lock. Please check batteries or connection and try to refresh lock data again.”

I just tested refresh on my 910’s and I’m getting good results. It’s consistently taking ~4minutes to refresh the codes.

To my benefit though, you should just about never need to actually use the refresh method… but it should work when yah do.


Can you see if this DTH can be used again for the FE locks, “Z-Wave Lock Reporting.” This is the one I used before the upgrade and it has worked fine ever since the original Lock Manager. None of the DTH’s work now for the FE.


Kwikset 916 - I’m running into the same issue with slots that already had codes assigned prior to the update not refreshing. The app is able to refresh slots that have never had a code, but fails on refresh of slots that had a code assigned.

Prior to updating, I completely removed the lock from the beta app, and deleted the beta app from the SmartThings app and IDE. I then installed the release version fresh from GitHub. All my prior codes (2) are still working, and I’m unable to overwrite the code. I’ve deleted and reinstalled the app several times, and tried two different DTH.

App message after clean install:

App message after a manual refresh:

Entries from live-logging on smartthings IDE:

It seems as though it cannot read slots with codes already inputted, nor can it overwrite new codes into these slots.

One thing I noted was that the standard “Z-Wave Lock” DTH allows communication with the lock, but the standard “Z-Wave Lock with Codes” DTH does not communicate with the app at all. I’m wondering if the DTH is the cause here? I had no issues with the custom DTH from the beta app, and “Z-Wave Lock with Codes” seems the more appropriate DTH.

Thanks for all your hard work!!

ETA - I’m also seeing in the logs that it shows 2 users, despite my deleting all users. I added one user back, and logs still seem to indicate 2 users. Maybe the issue is with removing users and not the codes themselves?

Below screenshot - Changed user 1 codes and applied changes, then removed all users and applied changes, then added one user back and applied changes. Overwrite was selected for all three attempts.

1 Like

I’m attempting to add a the Kwikset 916 Zigbee lock to the Lock Manager and I’m getting the following error:

7cc1aa23-a8a7-458d-af25-6f83720d26e8 5:59:26 PM: error java.lang.NullPointerException: Cannot get property ‘slot1’ on null object @ line 250
7cc1aa23-a8a7-458d-af25-6f83720d26e8 5:59:21 PM: error java.lang.IllegalArgumentException: Command ‘requestCode’ is not supported by device c32f2caa-6836-4441-a7e7-49ff17391f6c of type ‘ZigBee Lock’. Supported commands: [configure, lock, unlock, refresh] @ line 259

The phone smartthings application says: Oops! The lock that you selected is already installed. Please choose a different Lock or choose Remove. I’ve tried removing and readding the lock, but I get the same result each time.

Same problem here

@cuban210 You’ll need a ZigBee DTH with lock codes. You can find mine below. I’m about to release a small bug fix update today but it won’t affect anything with this SmartApp. So you can use the current version.

Seems like I have to bring back the old codeReport way before f doing things with maybe a combination of this new way too.

The inlaws brought the flu over last weekend so I’m feeling pretty ill today though.

“In laws no longer have access to Front Door”

1 Like

I have tried clearing everything out (removing app, removing lock, factory reset lock), and building it all up again. Still having issues. once a code is set on a slot, the requestcode doesn’t return anything, and the updatecodes doesn’t work. Seems to be driving me nuts. I have not loaded an custom device handlers. Should I? Is there one recommended that I should use?

@CrispyCreme @Dan_Fox. Have you two tried the SmartThings DTH Z-Wave lock with codes? I believe Kwikset locks will actually return all codes (unlike the Schlage DTH which simulates that by saving codes in variables). That may solve your issue if you haven’t tried. Unfortunately I’m not sure what is exactly in the SmartThings DTH code as it is not open source.

You will need to use the SmartThings Z-Wave Lock with Lock Codes DTH with Kwikset locks. I’d recommend garyd9’s DTH ethayer has modified in his GitHub for other locks.

I apologize for the newbe question, but how/where can I add that DTH? What repository do I need to point to?

Yes, I have tried the SmartThings “Z-Wave lock with codes” DTH. Unfortunately, that DTH does not allow communication with the Lock Manager app.

The only DTH that allows Lock Manager to refresh the slot information on the 916 is the SmartThings “Z-wave Lock” DTH.

I switch the device handler to the Z-Wave Lock Reporting in @ethayer’s legacy-code area, and everything started working great!

Thank you for the help. Zigbee lock now working. Is there a way to disable the random digit generator when first touching the lock?

Same here, the “Z-Wave Lock Reporting” DTH from the legacy-code branch of the old app is working great. I’m able to read/delete/assign codes now on my 916.

Just as a FYI; the Zigbee keypad DTH has been updated so that the Exit Delay Tone (Countdown beeping) will work properly with Lock Manager.