[OBSOLETE] Generic Z-Wave Repeater

One of the things that always bothered me with the Iris plug in module is the generic Z-Wave device or switch DTHs when all I wanted was a repeater. This shows a simple interface of online/offline and works with Health Check.


  • Checks connectivity every 15 minutes
  • Only shows messages in Recently tab on status change or manual refresh (NOTE: a manual refresh will temporarily remove the health check flag if offline)
  • Reports after two failed attempts
  • No events after offline detected to force App Health Check to show correctly (will take about 35 extra minutes)

Current Version: 2.00a

NOTE: If you upgrade to 2.00 or above from an older version, you must press ‘Force Reconfigure’ in the app. If you do not do this step, the DTH will not work correctly.

The code can be pulled from my GitHub at jhamstead/jhamstead (master) or from the GitHub link here

How to…Add Device Handler:
Navigate to: SmartThings. Add a little smartness to your things. or
SmartThings. Add a little smartness to your things.
Click ‘New SmartDevice’ in the upper right.
Click ‘From Code’
Paste the code from the link (github) above into the text area:
Click ‘Create’
Click ‘Save’
Click ‘Publish’ > ‘For Me’

Change repeater device handler to new code:
Navigate to ‘My Devices’: SmartThings. Add a little smartness to your things. or
SmartThings. Add a little smartness to your things.
Locate your repeater and click on the name in the first column
Click ‘Edit’ on the bottom of the page view
In the ‘Type’ drop-down scroll to the bottom and select ‘Z-Wave Repeater’
Click ‘Update’ to save changes

Enjoy! Let me know of any issues or problems.


This is the first release, but I plan on showing less messages and having a more responsive offline. I hope to have a more robust version soon


This look great, I will give it a try

1 Like

I just updated to version 1.02. This version fixes a health check bug and limits logging.

New Features/Fixes

  • Checks status every 30 minutes
  • Shows online status in ‘Recently’ tab at most every 6 hours to limit logging
  • When offline detected, tries to connect a second time to verify status, then reports
  • No events after offline detected to force App Health Check to show correctly (will take about 1 additional hour)
  • Shows offline faster than Health Check
1 Like

Version 1.03 released.

Minor bug fixes.

I’ve also updated to a 15 second delay for response verification as I saw a false positive at 10 seconds (30 seconds for offline as it checks twice). If anyone else sees this let me know. I could set this delay up to 25 seconds, there is just a longer delay after clicking refresh.

This is great! Thanks for publishing

I tried this DTH and out of 4 Iris Plugs only 1 shows correctly. 2 show Unknown and 1 shows Unavailable. Any ideas?

I’m not sure exactly but to possibly fix your issues I released a new version. There is now a force reconfigure button. That will make sure that the correct settings are set on install. You should only need to press that button once.

I excluded and re-paired the 3 that showed Unknown and Unavailable. So far, they seem to be working correctly.

1 Like

Thanks for this. Changed all three of mine to this new device handler and now two show online and one shows offline. Any idea what determines if it goes online or offline?

So online/offline is determined based on a query response for the Z-Wave repeater MSR. If it does not get a response in 30 seconds, it tries again. Two failed responses and it reports offline. I too however occasionally get offline messages even when the repeater is online. I’m not sure as to why the hub does not get a response. However with health check, I have not noticed a false alarm. In any case I’m testing some longer delays, such as 60 seconds.

thanks for this great work!!

Anyway is not clear to me what the force reconfigure would do



I’ve started adding a force reconfigure to most of my DTHs. It is a harder refresh by resending configuration parameters. Normally configure is run on installation of the device or DTH but I’ve seen it fail for some reason. In this DTH’s case, it resends health check information, then runs a normal refresh.

Thanks a lot

and thanks to your handler I figured out that all my six plugs where off… now I did reconnect 3 of them, but I guess the range of the zwave repeater is really short, am I wrong?

The Iris plugs are Z-Wave Plus so they should have good range (in comparison to older Z-Wave or ZigBee). I’ve increased the response delay to 60 seconds and have been getting better online results. If my testing continues to show good results, I’ll probably release the update shortly. In reality the only change is to the runIn statement. Changed from 25 to 60.

Ok I will try it…

Also the repair of zwave keeps giving me errors for the offline repeaters and one of the online… must be related to the offline fact right (maybe the online is not really strong)
Failed to update mesh info and Failed to update route

I have sensors which are literally 4 m away from the and the other one wall away (20cm) and they are off line… what do you suggest I do?

Hmm. If you are getting offline and Z-Wave repair issues, I’d try a replace of the device. First you’ll need to reset the Iris plug. To do so, hold in the button when you plug it in. Then run “Add a Thing” to restore the ZigBee control. Then go into the repeater and click replace. Then quickly push the button on the plug 5-8 times. Hopefully that should resolve your issues.

I plan on releasing a new version this weekend. The scheduling in SmartThings has been giving me issues. This new version will do things completely differently. It will check every 30 minutes. Two failed responses and it will be marked offline.

1 Like

Major new version 2.00 released. This version completely changes the algorithm for online/offline detection. It will not be as fast as the older version but is much more reliable. This version also fixes the false positive issue with Health Check.

NOTE: If you already have this installed and upgrade to this version, you must press ‘Force Reconfigure’ in the app. If you do not do this step the DTH will not work correctly.

For fresh installs this is not an issue.