Generic Multichannel Z-Wave devices stopped working with new SmartThings app

So, we were recently forced onto the new SmartThings app since SmartThings Classic stopped working entirely. I have a generic multichannel zwave device (well several of them) that has been setup and working for years in the SmartThings Class app. What I have is a Z-Wave relay with 2 channels, connected to a pair of light switches. In the classic app, it would show the main device and the two child devices allowing me to control individually or together. This was using the Generic Z-Wave Multichannel DTH.
In the new SmartThings app, I only see the parent device. When I try to switch it on, nothing happens. In the IDE, it still shows the child devices and the association. I looked through the community threads, but all seemed to be about specific branded devices where the brand provided their own DTHs. I tried reassigning the DTH for the switch, and the IDE just error (the updates were not saved).
This seems to be a general problem with SmartThings platform, but I do not know how to diagnose further. I would appreciate any help with diagnosis, or an updated Generic Z-Wave Multichannel switch DTH.

EDIT: So, more debugging revealed some additional information:

  1. Turning the parent device on or off did not natively work, In the classic app, I had a SmartApp or a routine or something that made turning the parent device on/off trigger the child devices. Whatever that process was is not visible in the new app. Since, the old app just stopped working, I cant really go back and see what that was. Not sure what happened or where that went or how to recover that functionality.
  2. One of my child devices on 1 of my generic multichannel devices is visible when setting up new automations, but is not visible in the general device list in the new ST app. Whats unique is that child has a virtual switch setup against it, which was needed in the Classic App to drive any automation against child devices. That virtual switch is visible and working in the new ST app, i.e. it turns that one child device on and off. However, I cannot find the automation that is driving the virtual switch… again, some of the automations seem to be hidden in the new app.
  3. I changed the DTH on one of my generic multichannel devices to a Z-Wave Relay. Since it already had the child devices attached in the IDE, they remain. In the ST app, when I navigate into that parent device, I am able to control the child devices after updating each the DTH on each of them to “Switch Endpoint”. So, controllable, but not usable in any automation, SmartApps, or otherwise because they are not listed devices.

It is interesting what still works (the virtual switch controlling 1 child on the unmodified generic multichannel device), what works with modification (the updated DTH to relay), and what is just unreachable, i.e. the routine for the virtual switch and the child devices for setting up new routines.

Again, any help is appreciated. This trial and error process is very time consuming as well as potentially destructive to smart routines. On a side note, all of my presence routines based on my phone as a presence sensor have also stopped working :frowning:

EDIT 2: After poking around the new app, I finally discovered that 1) Mobile phones used for presence no longer show up in devices… its just enabled for presence, 2) Any automation that was dependent on a phone presence was disabled in the new app and 3) Other presence devices were dropped from any automations which used a mix of phone presence and dedicated presence device. I havent had the time to go through all of my presence based automations yet and fix them. This is getting very time consuming. Shame on Samsung

1 Like

Tagging @jody.albritton @Kianoosh_Karami

This may be related to the same issue that took out the Fibaro devices earlier this month.
ST did a hot-fix to bring back a secondary channel for the non-compliant Z-wave devices but I beleive it was Fibaro specific.

I just did my last minutes new app switched. Turns out same as @jcamerin that all my generic multichannel devices lost the child’s control in new app. Only parent visible in the devices.

I am hearing conflicting reports on whether child devices are supported in the new V3 app or not. Or if there’s something specific that has to be done to update the DTH for them.

Since this thread is regarding a stock DTH, not one provided by a brand, maybe @blake.arnold can check on it as a migration issue.

Have been working great for weeks… I sure hope they didn’t suddenly decide we didn’t need them…

Try delete the child and recreate again. Or delete the parent & child device and create again.

Try using the DTH Zwave Dual switch. I have had sucess with this DTH
for dual relay devices


What do you do about the second switch? Right now mine is has the type “Z-Wave Light Switch Multichannel Child Device”. I don’t think my second switch ever really worked though.

The second switch should be “Z-Wave Binary Switch Endpoint” try to just manually change it to that DTH and see what happens. If that does not work, the solution (at least for the Enerwave ZWN-RSM2 dual relay) is to do the following:

Delete the device from the app and Reinstall.

Go to IDE select My Devices. Click the name of your switch and scroll to the bottom and select edit. Change the DTH from Multichannel (or from whatever Smartthings initially called it) to ZWave Dual Switch.

There should then be a new device (your second switch) that shows up at the bottom of SmartThings called Z-Wave Binary Switch Endpoint.

So your 1st switch DTH is named Z-Wave Dual Switch and the 2nd switch is Z-Wave Binary Endpoint.

1 Like

That did it! Thanks so much. When I first got it I read that Smartthings didn’t support multichannel devices and gave up tinkering with it. I had to delete and reinstall but after I changed the device handler the second switch showed up and they’re both working! BTW my switch is a GE ZW4105.

1 Like

Good to hear! I’m not a software guy at all, just a big tinkerer in the smartthings world.
I just copied and pasted directions I learned from another dual relay post which had worked for me. Unfortunately Samsung is turning their smart home world upside down right now with all these changes. It looks as though many of the early adopters who write DTH code and have historically shared it with others have jumped ship to Hubitat. So unfortunate… I just want my stuff to work!
No idea why multichannel is so difficult but again, I’m not a software guy. I have another multichannel device - dual relay with dual contact sensors that is not working and no one can help right now. :frowning:

The ultimate question is how will this Smartthings platform look after all the changes are implemented and the bugs are fixed. Will it be as robust a product that originally got everyone hooked? Lets just hope all the smart ones writing code dont jump ship before they get a chance to play in whatever new world Samsung is headed to.

Thank you so much for your help! it worked with my enerwave RSM2.
I own 2 more relays from a different brand (Vision), I’m gonna try this weekend and see if it work also, as they are multichannel devices as well.

1 Like

Thanks for pointing out that DTH. Not really sure whats happening though. I can select the Z-Wave Dual Switch and hit the Update button. I get a banner at the top of the page that says the update was successful. However, on the page it still shows the old DTH. I can refresh or go back into edit and it shows the old DTH also. So, even though everything indicates that it updated, SmartThings is actually not updating. Any ideas? Anyone from @SmartThings actually look at these forums and can possibly help? This switchover and trying to get things working again is driving me insane.

This forum was set up a number of years ago so that customers could help other customers. It’s not an official support channel. For that you need to contact them via Twitter, Facebook or the official support:

There are a few smartthings employees who check in here from time to time on their own initiative, but there’s nobody assigned from support to do so.

Thanks. I will try the official support channel again.

1 Like

@jcamerin am actually experiencing the same thing as you will another dual zwave switch I need to fix. It keeps saying its updated but it goes back to its original state. What we need to try now is to exclude the device from the system and see if we can rejoin it to the hub and then make the change. I would do it to mine and let you know but mine is in a box in my dirty, dusty attic and is a pain to have to go up there and do :(.
Can you try this and let me know if that works? I am assuming your dual switch is more accessible than mine :slight_smile:

1 Like

Only slightly and I’m out of town ATM. I’ve been resisting excluding the device as that will mean a fairly significant task to go fix all of my automations. However, all signs so far are pointing to this being the only option. If only there were a way to download or save everything off so I can recreate it all. Given how many of my devices are not ST specific, this might push me to a different to try out another system.

1 Like

I just purchased a Hubitat hub myself. Should be here this week :slight_smile:
I will end up in the attic at some point. If I am still on ST I will exclude/rejoin mine and let you know the outcome. Or if you do yours first, let me know.

ST Support’s response was that they dont support “Z-Wave Dual Switch” or any multi channel DTHs on the platform.