[OBSOLETE] Fibaro Wall Plug ZW5 (Z-Wave+) DTH

This is an DTH for Fibaro Wall Plug Z-Wave+ version 3.2

This DTH provides the following functionality:

  • On/Off
  • Power and Energy Monitoring
  • Manual refresh both Power and Energy (by tapping one of the value tiles)
  • Reset for accumulated kWh value
  • Configuration for 12 parameters:
  • Always on function
  • Restore state after power failure
  • Overload safety switch
  • Immediate power reports
  • Standard power reports
  • Power reporting interval
  • Energy reports
  • Periodic power and energy report
  • Energy consumed by the device itself
  • Power load which makes the LED ring flash violet
  • Ring LED color when on
  • Ring LED color when off
  • Parameter synchronization status information on main tile
  • Summary power and energy information on main tile

This DTH was briefly tested by me for issues like lockup after fast switching and failure to respond without connected load and does not seem to have this issues but I don’t guarantee it’s is completely free of them.




Good work! Tried it and it works good for me.


This is great!

Thank you

I tried using this, but the tiles were not updated to reflect current state (i.e on/off). After looking into it, I can see that I get the status in an unhandled zwaveEvent (BasicReport), and not in the expected SwitchBinaryReport. Could this be a difference in firmware of the device? To be honest, I just got my first smartthings hub a couple of days ago, so I’m not sure how to retrieve the firmware version of a z-wave device.

Check the box for your Wall Plug - if it says version 2.0 - 2.5 you have older firmware and should use older DTH (you’ll find it somewhere on the forums). This one is only compatible with 3.2 (Z-Wave+) version.

Great work @ClassicGOD works like a charm

Thanks, this is great work. But any idea how to increase the font size on my Galaxy Tab2?

So been away for a while from smarthings so was very happy to see a device type for the fibaro wall plug when checking the forums for the first time in a long while.

Thinking of trying one out for the powe outlet that supports my tv and htpc with power. So I wonder, can I save data continously in some way and get graphs? Is this something that WebCore could do (I have just seen it mentioned, dont really know how it works. Can I get notifications when power consumption passes certain consumption both up and down , can I turn off led ring color when power consumption below certain value etc. How are you using it?

Best regards

Is this still accurate in the code?
Requires: Fibaro Double Switch 2 Child Device
Importing this Device Handler from Github gives an error.

I ask because i frequently get that the device is unavailable, turning it on/off makes it available again though, but might give issues with Smart Lighting if the device is “offline” i think

Code is still accurate. Ignore “Requires: Fibaro Double Switch 2 Child Device” line it’s a remnant from my other DTH that I used as a source for this one - I simply forgot to remove it, sorry for the confusion.

Do you have any periodic reporting enabled for the plug? If there is no activity from the plug for some time ST assumes it’s dead. Try enabling periodic power and energy reports every hour (3600sec) and se if that helps. Or remove

capability "Health Check"

line from the code.

All of my Fibaro device handlers will get a rewrite sooner or later so I’ll try to provide better support for Health Check capability at some point.

Thanks, i’ve set 15 tot measure now, will see what that gives


I have a pair of Fibaro wall plugs FGWPE/F-102 ZW5. I´ve used classic god when I installed them initially, and now 3/5 stopped working. Or the issue in hand is that:
I had not problems adding the plugs to the network. They are detected and I can see the power consumption and the state (on/off). However, if i try to change the state (on/off) remotely it doens’t work. I´ve tried factory installing the wall plugs and adding them again, same issue. Can´t change the state through the app?

Any guesses how to proceed?



Joachim I was in your situation. I go to the smartthings Web page and login. Inside the location you can see all device. I select the wall plug(called meter energy…) and I decide to select another type, I choose aeon smart energy plug 5. Now work better but I can use the some parameters. If you solve can help me the way? Thanks

Ah. thank you for the hint, I manage to solve it by changing the device type in the handler. It was set to something else than standard of some reason!



Hi Robin,

I´ve already installed the custome code int the IDE handler. My problem were that they suddenly stopped working. I manage to solve it by changing the Device Type to Fiber wall plug zw5. (Somehow it changed to another device type out of the blue?).

Thanks for the help though. :slight_smile:




I just wanted to drop a line to thank you for this great piece of work.
It has taken me a couple of hours to realize that the device handler you shared had to be uploaded under “My Device Handlers”, and not as I was trying as “My Smart Apps” (once logged into the URL https://graph.api.smartthings.com/)…

Once that was done, the Fibaro Wall Plug device had to be edited to the new type “Fibaro Wall Plug ZW5” (visible once the device handler has been saved in the previous step) - under the initial pairing with the Smartthings Hub it was mapped automatically as a different type… and at that moment the smartthings app in my smartphone was able to switch on-off the wall plug.

I would be very greatful if you could mitigate my curiosity: how were you able to figure out all the fingerprint data, the information in the “device configuration” section, etc?

best regards,

After adding the device to the network you can go to device info in IDE and look at Raw Description all the info needed to create a fingerprint is there (all z-wave devices have to introduce themselves when added to a network - that is how the HUB has all of this information).

If you don’t have the device yet but want to create fingerprint for it you could use the device specification available at https://products.z-wavealliance.org/products/

The device fingerprint I used in this case is just a device type (deviceId) + all the supported command classes
The secondary fingerprint is the same minus the secure encapsulation (0x98) command class (in case the device was joined insecurely)

since creating this DTH I also figured out that before the current fingerprints you could add this fingerprint:

fingerprint mfr: "010F", prod: "0602"

Its basically manufacturer and model id that should identify the device 100%. It also can be found in Raw Description.

1 Like

Hi, I can’t get my two fibaro wall plug zw5 (102) to work. They communicate with the hub and are reporting consumption and state, but I can’t turn them on or if from the app or from webcore.

Updated to the latest version of the device handler, but didn’t help. They where both working earlier.

Have tried to delete one of them and added it back. Didn’t help either. Tried another device handler that didn’t work. I have deleted the device handler from the ide afterwards, and I have checked that the devices uses your handler.

If I change a value in the settings for the device in the app, it reads “sync in progress” and soon after it says “sync incomplete”. Here are two screen shots from the app and preferences on the device in ide.

Enable logging and post the logs for sync here. Also try enabling and then disabling param 1 “Always on function” - I can see you used different DTH previously and maybe you enabled this setting (Wallplug in this mode will ignore off commands and be always on).

Noticed the hub stopped responding yesterday evening when night mode didn’t turn off the lights. And this morning, the morning routine didn’t run either. So I pulled the power plug and batteries from the smartthings hub. When I left home, the routines were running as normal again.

Did as you suggested and set “always on function” on and off on both mye wall plugs, and everything sync as it should.

So now I can turn the power plugs on and off from the app. Haven’t been home yet to verify it, but it looks promising.

Guess the clean up and removing device handlers not in use, and the restart of the hub did the trick. Maybe some of the parameters in device handler wasn’t set either.