[OBSOLETE] Aeotec TriSensor

Sorry, but I only work on integrations for devices that I own and writing a device integration using a 3rd party API bit me once so I now only write handlers for z-wave devices…

Is there a way to change out the motion on the main ST page to Temperature. I am using this for a Greenhouse temp monitor. I had a Qubino Z-Wave Plus On Off Thermostat 2 ZMNKID3 which was working but would go offline every couple of days. Turns out it was reporting up to 12 temp variations in burst that would only be a second long. Tech support asked me to exclude and re-include and it went south from there. It only partially installed as a energy device and then put my hub in a remove device loop for a day.
I was wanting a hard wire powered device but got this in quick. If you know of another good hard wired power device I would be interested in it and could use this device as a backup. I added your previous code change that shows Temp as the main tile but having the temp, instead of the motion, on the main panel would be great.

The changes I mentioned only work for the classic mobile app.

If you don’t care about motion at all then removing the capability “Motion Sensor” line near the top of the code might solve your problem.

Thanks for the help. I tried removing the capability “motion sensor”. It didnt seem to do anything. I moved everything I could find that would have something to do with the order or main panel and it works perfect in the classic version but does nothing to the new app version. Problem is, I have know idea which edit did what because I was looking at the new version!
Is there anyway to make the new app version change? And do you have a recommendation for a hard wired temp sensor?
Thanks again for the help!

In addition to removing that capability line, remove the line below and the comma from the end of the line above it.

vid: "generic-motion-4"

The new mobile app caches the UI so you won’t see that change for 12-24 hours, but you can force it to refresh by creating a new DTH with a different name and then manually assigning it to the device.

Thanks Kevin. Your device handler worked great.
This was my first time messing with smartthings and a modified DH.
Luckily everyone’s comments helped me get there.
Consolidated how to setup / edit device handler instructions:
After device is already added as a device and working but you want access to the device settings,
Log into smartthings on the web.
go to my device handlers
create new device handler
from code
copy and paste code from github repo
save and publish
then edit the device and change type to the new aeotec trisensor which is located at the bottom of the dropdown list.
click update.
on the mobile smarttings app, open / reload the aeotec device, and now there will be the new settings menu.
thanks again Kevin - these options were exactly what I was looking for.

Anyone know if there is a device handler that runs local for this?

Hi @krlaframboise and others -

So, I just bought two of the Trisensors, and I cannot get either of them to respond as expected. The devices connect, I can change to your device handler, and I made the changes to the settings. Still, on both devices the illuminance sensor does not seem to be responding (which is really what I want these for) and the checkInterval state never seems to change.

Any suggestions? Thanks in advance.

***UPDATE: I excluded the trisensor and started again from scratch. This time it worked. Go figure. Thank you for the DH @krlaframboise ***

1 Like

I signed up specially to thank you for creating this device handler. I’m using it on the ZWA005-C

The default one available through the app was severely lacking, and the LED motion sensor was driving me crazy - it was a google search on that topic that brought me to this thread. The sheer configurability that your device handler gives to this sensor makes me very happy with the purchase of it in a way I would not have been with the default device handler. Thank you.

Is there a way of recommending your device handler be made available in addition to / instead of the existing one, for those users unaware / uncomfortable with installing custom ones? I would imagine this would be in Aeotec’s interest too, given the extra options it unlocks.

Aeotec had links to several of my handlers, including this one, but I think the only ones left on their site are the Siren Gen5, Siren 6, and Doorbell 6 and they’re not easy to find.

That seemed to happen right around the time Aeotec announced that they were going to be manufacturing the SmartThings hub, but maybe that’s just a coincidence…

Manufacturers can submit custom handlers to be published, but if the device is functional with one of the generic built-in handlers they won’t approve a custom handler for it.

If it’s published then ST is responsible for it so it wouldn’t make sense for them to approve custom handlers when the device works fine without them.

Hi Kevin, Is there a way to put LUX/Illuminance as the main metric to track instead of the motion or Temperature.
Im using this sensor mainly to track the luminance in the house, and I have routines that switches lights on/off based on lux levels. Its working great, but sometimes to troubleshoot I need to refer to the lux levels from the main smartthings dashboard for easy reference.

If you can find a built-in handler that displays the way you want it to then you can replace the mnmn and vid attributes in my handler.

Because of ST caching issues you can’t just swap them out to see what they look like with my handler so you’ll have to create a different virtual device for each built-in handler you want to test.

If you replace those attributes in my handler it might take days for you to see the change because of the caching issues. The only reliable way to force the UI to change immediately is to remove the device, delete the handler, and create the new handler with a different name.

Long story short, it’s possible, but probably not worth it…

I just set this device handler up with my TriSensor. Thank you for developing it.

I wanted to have all LEDs off while I have the Settings screen up, that is how it is, but when I close that screen the LEDs start flashing again for Motion.

Am I doing something wrong?

Did you wake the device up after making the setting changes?

If not then you wouldn’t have seen that change immediately, but it should have synced that setting within 24 hours.

Correct you are, after 24 hours everything finally calmed down and took effect. It is now working the way I wanted to. Have a great evening and thanks again.

1 Like

Hi i have a ZWA005-C I am in the uk i added DTH then added to my hub by factory resetting then scanned. i could see it and it was reporting everything but battery levels. i was also unable to change any settings and only had in settings, edit in which only shows location and room, add to home screen or remove device or information wich shows controller varsion 2.2. 15-4 . i am unable to make any changes to it either in under my devices in smartthings groovy website . i deleted it and started
again and its still not reporting battery levels. do i have to edit anything for a C version? and what am i doing wrong? there are no drop down boxes to change device type ect. a little help please. i would be so grateful thanks.

Not to worry manged to sort it out. all of your comments have been a great help thank you

If you’re still having issues with this part then you need to go into the IDE and manually change the “Type” filed to this DTH because SmartThings didn’t assign it automatically when the device was joined…

Hi Kevin
Thanks for this fantastic driver. I live in the UK and I am unable to get this to work. I have imported the driver and published it and I have tried to change the device type to Aeotec TriSensor in account.smartthings.com. However, when I do that the Network ID field if blank. I’ve tried using 1E from your video and the device does work but there is no Settings button. If I click Driver / Select Driver in the Smartthings App, then it reports there are no drivers available.

If you have to copy and paste code, like you did with this one, then you’re dealing with a Groovy DTH and not an Edge Driver.

When you joined your device it was assigned a driver and once a device is joined with a driver it can’t be changed to a DTH which is why your having issues.

The onboarding process is kind of messed up so if you repeatedly remove the device and join it again SmartThings might eventually assign it my custom DTH, but if you manually installed the SmartThings “Z-Wave Sensor Driver” then there’s probably no way to use this custom DTH…

Hi Kevin
Thanks for the response. I am not sure I understand all of it though. Originally I installed the device prior to installing your custom driver. It was added with a device type of ‘placeholder’ and no’network id’ populated.

I copied and pasted the code into the https://graph-eu01-euwest1.api.smartthings.com/ which is where we are redirected to in Europe. Originally the account.smartthings.com just gives you a web version of the App interface, but luckily I had the above URL saved and the UI matches what is in the video guide I found to installing your driver.

Under Device Handlers, I do not have a Z-Wave Sensor Driver listed. I have a couple of Nest ones I added from tonesto7 and a Wemo Power Switch driver. Nothing else has been added, apart from your driver.

What is it you think I need to do?