[OBSOLETE] Aeotec Home Energy Meter Gen 5 composite DTH

This DTH is designed to work with 3, 2 and 1 clamp configurations but was only tested on 3 clamp configuration so any input is welcome.

This is a composite device. That means it will install a virtual device for every clamp (except for 1 clamp configuration) and a main device displaying information for the whole HEM. It requires “Aeotec HEM Gen5 Child Device” to work correctly so install both parts of the DTH before switching to it.

This DTH provides the following functionality:

  • Power Monitoring
  • Energy Monitoring
  • Voltage Monitoring
  • Current Monitoring
  • Configuration for following parameters:
    • Power and Energy detection mode
    • Reporting Threshold
    • HEM threshold
    • Clamp 1 threshold
    • Clamp 2 threshold
    • Clamp 3 threshold
    • HEM percentage
    • Clamp 1 percentage
    • Clamp 2 percentage
    • Clamp 3 percentage
    • CRC-16 reporting
    • Reporting settings for group 1
    • Reporting settings for group 2
    • Reporting settings for group 3
    • Group 1 time interval
    • Group 2 time interval
    • Group 3 time interval
  • Reset for accummulated kWh value for separate channels and whole HEM
  • Refresh

Forgot to mention: To prevent accidental resetting of kWh data to perform the reset you have to press the “Reset kWh” tile at least twice with about 0.5sec delay between presses (or SmartThings may not register the second press) in a span of 2 seconds.

Aeotec Home Energy Meter Gen5 3 Clamp configuration has issues communicating when not securely included. To make sure you included your HEM securely remove it from the network and then re-add it pressing the buton on the HEM twice.

If the meter is trying to send too many reports at once some of them will go missing so I recommend distributing readouts over all 3 groups and setting the groups to different time intervals.

If you make the meter report too often it can stop responding to commands. If that is the case you can try sending the configuration few times, patiently waiting few minutes and retrying or resetting the HEM to factory defaults.

My HEM is on early 1.0 FW version so the issues mentioned above could be potentially fixed in the newer fw version. I’m waiting for my Z-Stick to perform update on mine. For FW update file contact Aeotec Support.


(small font on main tile is a SmartThings app bug that should be fixed with next ST App update)


@ClassicGOD - I’ll give it a try tonight or tomorrow.

Have you ever considered building a DH that treated each clamp as a child device? This way with a single 2 clamp device you could actually treat them like 2 devices?

Well I did consider it - this is exactly what this DTH does. lol :smiley:

Ha, I read way to fast. Great. I will for sure use this. Saves me some $$$.

I have a 3 phase backup generator (If I had known better, I would have bought a single phase generator, as that would have made installing and using it far easier! I always seem to be at the limit of one of the phases, while the others are under utilised. And the loads shift according to what part of the house we’re in. My perception is that had I bought a single phase generator, I would not have had this problem.) and am considering using one of these to monitor the load of each of the 3 phases of the generator.
If I understand the description of your DH correctly, it will report the load on each of the phases? Will I be able to use the reported loads in a WebCore piston which will warn me if one of the phases reached its limit?

Yes and yes.

1 Like

Thanks, @ClassicGOD. Do you perhaps know if it would make any difference if the 200A clamp version is used on a generator with a maximum output of 20kVA (total of about 30Amps)? I only see the 200A version of the 3phase version for sale (EU version.)
I’m excited about this solution. I’m planning on fitting one of these to my main distribution board in the house, and a second one to the sub-distribution board of the generator. That way I’ll be able to tell if the home is being powered by the grid or the generator, which will enable me to shut down high energy devices like underfloor heating/geysers etc. With the generator running, I’ll also watch the consumption on each of the phases, shutting of non-essential devices as the other essential devices are turned on before the maximum ability of the generator is exceeded. (Not yet sure how I’m going to do this, but I think what I will do is to turn all high-energy devices off as soon as the generator starts and once the generator comes online, turn them back on one by one. I’ll be using webCore to do this - bit worried that my (lack of) ability to set up pistons will allow me to accomplish this.)
Edit: I suppose a better approach would be to configure the switches of the high energy consumption devices not to restore to their pre-power failure state. so that they don’t turn on by themselves when power is restored by the generator once a power failure occurs, and then use webCore to turn them back on again.

[quote=“949BFN, post:7, topic:88359”]
Do you perhaps know if it would make any difference if the 200A clamp version is used on a generator with a maximum output of 20kVA (total of about 30Amps)?
[/quote]Shouldn’t make a difference as long as you are under the max rating for the meter.

Thanks. Hoping to receive mine today. Will eventually do a write-up of how I’m using these (don’t know of how much of what I want to do, I’ll be able to.)

Hi again @ClassicGOD - do you perhaps know of a reason why I’m getting a “Sync Incomplete” error? I have 2 of these devices at my home and both do the same. Yesterday, I removed one of them from the hub, and before including it again, I did a reset according to the manual (Long press of the configuration button). That did not help and I’m still seeing the “Sync Incomplete error”.

I was wondering if you are aware that the data is being displayed in very small text on high-resolution screens of devices like a Samsung S8?

By the way, it doesn’t seem that I’ll be able to use the HEM to turn off devices to prevent me from exceeding the backup generator’s capacity - the HEM is responding too slowly to changes in demand.


Smal font is a bug with the newest Android app version (hopefully they will fix it soon)

Sync Incomplete points to one or more parameters not syncing/meter not responding to configuration requests (it sometimes fails to respond if it is set up to update too often - you can try going to settings and clicking done few times in a row, waiting few minutes nad repeating).
Is this the 3 clamp version?
Try opening Live logging tab in the IDE then enabling logging in the settings (in app) and clicking done - post the result here.

Also make sure that the meter is included securely - go to My Devices in the IDE and click on the meter, under the “Raw Description” section you should see: zw:Ls
If the meter is not included securely it will not respond to configuration requests.

Yes, it is the 3 clamp version.

Looks like mine is not included securely?:
zw:L type:3101 mfr:0086 prod:0002 model:001C ver:1.08 zwv:3.67 lib:03 cc:70,32,60,85,72,86 epc:3 ep:[‘3101 32’]

I suppose the reason for that would be that the HEM is located far from the Hub? I have just acquired a Minimote - do you perhaps know if the device will be included securely if I use the Minimote to include it (instead of the App). Hope so, because it is going to be quite an exercise to move the hub to the Energy Meter - my understanding is that to ensure a device is included securely, it has to be very close to the hub?

I’ll check when I get home for the log entries.

Have you pressed the buton on the HEM twice when adding to SmartThings?

To include the HEM securely you have to pres the button on the HEM twice. Try that. Mine was away from the HUB and still managed to include securely using this method.

Is zw:L (as opposed to zw:Ls) always an indication that a device was included in non-secure mode? I notice that I have quite a few items without the “s”. Wonder why that would be.

I’m unable to get it to include securely. It’s just a meter away from the hub when I include, but it shows up as a generic z-wave device and as zw:L. Any idea what to do?

As I’ve indicated above, I have 2 of these devices. I bought a 50m fly-lead this afternoon and to the hub right to the HEM’s (sitting next to each other). I have removed them from the hub 4 times and even with the Hub 10 cm away, I could not get one of them to join in secure mode.
Wonder what the trick is…

And while adding the meter to the network you are pressing the pairing button on the meter twice (2 fast presses. under about 0,5s)? This worked for me - it never joined my network in secure mode when pressing once but joined it securely on the first try i pressed it twice.

PS. Yes, zw:L means the device is not joined in secure mode, the other thing is that device joined securely should have “sec:” section in the raw description.
Basically the first large letter is the device power mode/type.:
L is for Live (devices plugged directly to constant power source, so your relays, power meters, light bulbs etc),
S is for Sleepy (battery powered devices that have to be woken up to receive communication like remotes, motion sensors, window sensors etc)
and I believe B is for Beamable (battery powered devices that need to be controlled in real time. They wake up every few sec or so for few milliseconds to receive commands. Door locks for example are beamable so the HUB can open them remotly).
The second small letter is ‘s’ for secure inclusion or blank for normal z-wave inclusion without additional security.

I tried a few times, but it doesn’t work. Did yours show up as a generic z-wave device after include?

@ClassicGOD: Yes, I did try the double press, but no luck. Thanks for the info about the different codes - very interesting.
@joar.brunes: Yes, it recognised it as a Z-Wave device (even thought I had the custom DTH loaded).

Do we have the same versions / firmware?
zw:L type:3101 mfr:0086 prod:0002 model:001C ver:1.08 zwv:3.67 lib:03 cc:70,32,60,85,72,86 epc:3 ep:[‘3101 32’]