oAuth Issues all cloud to cloud integrations broken (02/05/16)

if this is all because of the news story surfacing yesterday from Michigan University, then its a poor show as ST hasn’t been hacked as the news stories are suggesting, the risk from this kind of attack is very low as we are not getting new apps approved so the source is visible. very difficult to hide an exploit in plain sight within a smartapps code as is being shown.

now if this cock up is ST’s response to patch the vulnerability because of the Bad PR the news stories have generated …all i can say to that is bravo… :expressionless: rather embarrassing as you’ve scored an own goal again!!

but i am purely speculating, and it may well be just unfortunate timing :slight_smile: maybe the ST guys can update us soon, because UK support isn’t responding to tickets

Seems as though ST have already ‘replied’ to these articles in the announcement part of the forum, but there is no suggestion that they have taken any part of the system down.

I don’t see any other posts suggesting outside of the UK is down? If it was a reaction, then I would have thought the lot would have gone rather than just a specific country?

But this proves a point that really, you should not be using ST, or any other similar home automation stuff without some sort of backup (such as a light switch for lights), or for security at this time, or possibly in the near future. I use it as secondary (such as door sensors which just tell me if a door is opened when I am out, use it as a way to turn lights on/off to mimic that we are home…) but would never use it as primary security (that’s door locks, standard hard wired house alarm…)

@SplanK the EU shard is not up to the same version as the US Shards code, we dont even have the new capabilities yet that were announced months ago… so if they tested a patch in the us and then rolled it out to all shards, then that could account to as why only the EU shard is the only one affected… again purely speculation. but the timing is impeccable.

just managed to login through the app and all seems Ok. Fingers crossed it’s sorted.

Me and my work colleague are back in as well

Support were able to get my mobile App back up and running.

Here is the response I got from them

You're not the first person to get in touch with this issue today, it seems to be an authentification error.

I've managed to get this resolved by uninstalling the SmartThings app or the devices that you're getting this issue on, and then freshly reinstalling the app. This should then allow you to log in using your existing user credentials.

In terms of accessing the App that worked I can now focus on the Oauth issues, I’m not seeing any consistency yet though with some of my Oauth devices reporting and some are not.

yup, i was never locked out of the app, i got the prompt to log into my account very early this morning, which i did, it didn’t prompt me for the welcome code.

Support havent even responded to my email yet and it was sent in hours ago… I have Alexa back up and running, but Sharptools, Home Remote & IFTTT are still broken, all report error 500, cannot complete login to the IDE because as soon as i log in i get error 500.

Lifx, Smarttiles & Alexa are now working. so they are obviously working on something and have been since just after 8am this morning as the behaviour and issues have been changing all morning which i why i think its possibly a botched patch/installation

1 Like

I have had a response:

Thanks for getting in touch.

We have been experiencing issues this morning regarding authorisation issues.

I’ve just had a confirmation through from engineers that the issue has now been fixed, all that you need to do is close down the app completely, and log back in.

If this doesn’t resolve the issue, do get back to me and let me know what device(s) you’re having the issue on.

yup i just got that, replied that SharpTools still is producing a 500 error immediately when logging into the IDE when attempting to authorize. But the fact remains that was a 4 hour outage affecting all UK users (lots wont have noticed as they would have left for work) and status.smartthings.com again has no record of the issue…again.

i think its time to remove status.smartthings.com as it patently serves no purpose other than incorrectly giving good PR for availability even when issues are present

1 Like

I’ve had no problem getting into the IDE today and IFTTT connect is working fine at the moment I’m not seeing the errors in the log I was before.

It might be fixed but I’ll no for sure when I get home tonight

Looks like this might be wider the the UK as the US is just waking up

Sharp tools is broken for me (error 401 when clicking on a widget, error 500 when trying to auth).

Smart Tiles seems to work though!

Smarttiles is also OK for me but when I look at the tiles the weather tile is showing me snow @ 1C when its currently sunny @ 13C so something is definitely still not working. In the IDE the weather tile reads 13C.

Just checked sharp tools and while i can get in it won’t update or refresh my things…(exclamation mark in App)

yup i think they have killed sharptools. maybe worth replying back to the everything is working response everyone got from Support and tell them…no it aint! :smile:

hopefully this is something they are going to fix and not just state its something @joshua_lyon has to fix as its 3rd party etc…, because i imagine he wouldn’t be a happy bunny if this is the case.

could just be the result of the crazy UK weather at the moment, right now the sun is shining and it is glorious but in the last 3 hours we have had rain, sleet, hail and snow…so you never know? maybe the weatherman just ain’t keeping up

1 Like

Also having issues in the US.
Every morning I have a Smart Lighting automation turn on 2 hue Lux bulbs at 5:25 and off at 6. They turned on correctly, but had to manually turn them off, since there were major delays. (~30sec). Was able to turn off with Minimote.

SharpTools wasn’t working for me. Kept getting Error Code 401. OAuth is definitely messed up in the US.

I have emailed support with a screenshot of the IDE error I get when trying to authorise Sharptools.

Just a curiosity… anybody tried to uninstall/reinstall Sharp tools?

yup, i uninstalled cleared cache and app data, removed the Smartapp… cannot authorize because of the same issue once re-installed

Maybe related - 4 days ago ?

My sharp tools worked yesterday and I am quite sure this morning before ST turned itself inside out…?