SmartTiles Authorization / Access Token Problem?

smarttiles.click
smarttiles

(Morgan) #1

I saw the outage yesterday, but now none of my SmartTiles will work?


(Brian Diehl) #2

Close and re-open the browser.
Mine started working last night once the outage was resolved.


(Rey Rios) #3

Mine is working today. FYI


(Morgan) #4

I’ve closed and open the browser, and no luck on mine either of mine. i have the one installed from Smarttiles site, and I have the older one that I had put into my own app.


(Brian Diehl) #5

Have you tried opening the SmartTiles smartapp and clicking Done to force an update?

Do your devices work for any other method of control?


(Matt) #6

maybe run the update utilities in IDE/Locations/Smart Apps.


(Morgan) #7

Yeah, i’ve tried those things so far, forcing an update in the Smart App, and running the Update in the IDE. All of my SmartTiles still just say not authorized. I’ve emailed support, so should be interesting to see what it says.

I was having issues with my ST integration from my Echos as well, I wont if those aren’t authorized either.


(Brian Diehl) #8

Almost sounds like the access token was revoked.


(Morgan) #9

Is there a way to reissue it?


(Brian Diehl) #10

If you have one dashboard that isn’t in use (only using 4 of the 5 or something) try creating a new one.
If you are using them all, maybe sacrifice the one with the least amount of items on it and remove it and re-create it… See if that fixes anything?


(Alex) #11

@thrash99er,

In case somehow the access tokens got invalidated, you could reset them via ST app by going to the dashboard instance > Preferences >Security > Revoke Access Token.

If there is another issue, email us more details at support@smartTiles.click.


(Morgan) #12

If i revoke that access token, I have to reinstall it on all devices i’ve been using it with correct? Since the uRL will be different?


(Brian Diehl) #13

That sounds correct.

Typically I just email the link so I can copy and paste it on all the devices.


(Dennis Tegenbosch) #14

Since i had to reset my tablet to factory defaults its no longer working for me.
I need to loging every time i use smarttiles after more then a period (hours?), somehow the token isnt working. Also when u ise the link in the smart tiles app, i first see the launcher and have to press on the launcher, thats new?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #15

Yes. For better or worse, SmartTiles v5.8.0 requires the use of Login; we are no longer permitted to issue Access Tokens.

Please see, follow, contribute to the Topic here:


(Dennis Tegenbosch) #16

Ok, well i removed smart tiles in smartthings and reinstalled it, and it works.
But thanks for the explanation about the launcher, it’s a pity that it has to change.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #17

If you reinstalled, then you are currently on the “green” edition, which is still at Version 5.7 for a while longer, until SmartThings publishes our v5.8.0 update. Then you’ll be stuck with the new situation automatically, unless you a very lucky to never revoke your token(s).