Notification when hub goes inactive?


(Mike T) #1

This morning my hub went inactive. According to the post “FYI: Your ST Hub May Be Offline This Morning” this was caused by an Amazon server issue. I don’t have a beef with Smartthings about this, but what I find troubling is I got no notification from the app about this. I have a presence sensor in my car and rely on it to trigger a few things when I leave home. Of course none of them happened since the Hub was offline.

I looked thru the SmartApps and there is not one that sends a notification when the hub goes offline. The app on my phone knew, so somehow the word was able to get out. Is is possible to create a SmartApp to notify when the hub goes offline? Or, even better, have an option in the app that allows a user to choose to be notified with a ringtone or popup when this happens?


(John Essey) #2

@mikeT … what does it look like on your phone (when the hub is offline), can you screenshot that? I’m on Android, and I think it’s not always reporting accurately, and, I cant always sit in the Logs view on the IDE when I’m in my office (though I have been lately…).


(Solardave1) #3

You could probably cobble something together using iftit to ping amazons servers. You could go old school on a wintel box and write a batch file to ping the server and smtp if it returns a 1. This is the main issue I have with ST and any mission critical service that’s hosting center/“cloud” based and I get bashed when I point it out on these forums by all the ST / cloud fans that drank the ST cool aid. Brought my whole ip cam security system down and latched my a/c off and its 93 degrees in Florida today. But I’m being called a troll and told to shut up which is why I’ve been off the boards lately. So all of you enjoy the hit or miss experience of not having local control over your infrastructure and I’ll spend my weekend un-enrolling everything and gong back to a pair of Vera’s with auto failover. And I hear there’s a special on orange cool aid at the supermarket for ST users. Good luck.


(John Essey) #4

@solardave1 … Yeah, I can see the local server advantage(s), no denying benefits of it.

I’m using Pingdom https://www.pingdom.com/ (free version), but would gladly plug in “a” Amazon source/site if I knew what to put in (too lazy to really look, but considering…).


(Csader) #5

@solardave1 It’s not your concerns that are the problem. It’s messages exactly like the one above that are the problem. It’s your phrasing.

ST / cloud fans that drank the ST cool aid
So all of you enjoy the hit or miss experience...
And I hear there’s a special on orange cool aid at the supermarket for ST users. Good luck.

Expressing opinions is one thing, but this sort of deliberate jab at people here who legitimately want to make this work is completely unnecessary. Calling out the limitations with what sounds like distain for a company that you chose to give your money and rubbing it in the faces of the rest of us doesn’t help the situation at all.

Some here will say I’ve taken the troll bait. I’d like to give you the benefit of the doubt and say you’re not a troll, much like I will give ST the benefit of the doubt that they can find a solution to some of these problems. But in order to stay off the troll radar, maybe think about how your posts portray you before you put them here.


(Solardave1) #6

Fair enough. I hope you have a pleasant day.
For the record, I was one of the biggest fans of ST in the beginning, devoted a huge amount of my time and submitted numerous well structured, professional bug reports and beta tested features for them (and received more than one thank you from ST).
But as I said, fair enough and have a nice day.


(Mike T) #7
what does it look like on your phone (when the hub is offline), can you screenshot that? I’m on Android, and I think it’s not always reporting accurately, and, I cant always sit in the Logs view on the IDE when I’m in my office

I also am using an android phone. Nothing special appeared on my phone, thats the problem. I usually get a notification my status has changed to AWAY after I leave, and I didn’t see it. So I looked in the log and there was the message that the hub is inactive.


(Emily Allen) #8

Hi everyone,

I just wanted to let you know that we’ve heard you and plan to send out more proactive communication to users whose hubs go offline in the near future.

Thanks for the feedback!

Emily Allen