Alexa voice control completely broken after enabling the new skill

I decided to open a new thread because I haven’t seen anyone report this. After enabling the new smartthings skill for alexa, I have completely lost voice control. The alexa app sees everything and I can even control devices from the alexa app, but when I try to use voice control, I get “Sorry. Something’s wrong. To control , try disabling the skill and then re-enabling it from your alexa app.”

I’ve done that. I disabled the old skill too. I deleted every single device from the alexa app, disconnected my smartthings account, then reconnected and rediscovered everything. Same problem.

Any clues or suggestions from anyone?

I read that before posting. I also did all that the person in the comments did.

have you checked the alexa website for duplicates?

1 Like

I figured it out. A little different problem. I’ll post back here in a few - dealing with work issues. :slight_smile:

So here’s the deal…my wife’s amazon account is actually the “main” amazon account. That’s also where our prime membership is and where our echo devices are registered. However, our accounts are linked and on my phone, I’m logged in as me. I still have access to all the devices, including my own fire hd, but it’s my account. When I enabled the new alexa skill, I did it from my phone, hence linking it to my amazon account, not my wife’s.

Once I backed out and did the linking to my wife’s account, voice control is working again.

So for anyone who has a family setup like me, be wary of this!

BTW, using the website vs the app to manage the devices is WAY easier!


Tell me, I’ve put in multiple requests to have their apps device and routine lists bookmark their spots.

If you have 200+ devices and 150+ routines, and the bloody list resets to the top after every edit, drives me crazy!!!

At least their website allows bulk deletions!!

Man, this was spot on. When I was force migrated, everything stopped working. Couldn’t figure it out. My household is set up the same - wife has the paid Amazon Prime account, along with Amazon music, so the Echo is registered under her Amazon account, and I’m a household member/linked. If I de-register the Echo and put it under my Amazon account, it won’t play any Prime Music (kids use it all the time). Anyway, I did what you did - enabled the Smartthings skill and linked it to my Samsung account on my phone - nothing worked. Un-linked it, deleted the devices, and grabbed her phone and did the process on her phone - enabled the Smartthings skill and linked it to my Samsung account. Finally, lights and switches and plugs all worked again via voice control thru the Echo. Thank you.

However… a new confusing problem. Everything works great… until the next day. I have no idea. I go to bed, everything works via voice command. Wake up, and when I attempt to turn on any lights or groups via voice thru the Echo, I get the dreaded “Something’s wrong, try disabling and re-enabling the skill”. You - or anyone else- have any ideas? This is maddening…