Nothing connects after factory reset

I have a SmartThings hub with several motion sensors and outlet switches which were all working fine. I had not used for a while and when I tried to start up again the app said it was obsolete and I should install “Home Hub”. I installed Home Hub, then had to factory reset and reconnect the hub because I could not persuade Home Hub to find the hub.

Since then I have not been able to connect any of the devices to the hub. I put the devices in connect mode like I did the first time, the hubs scans and scans and says it cannot find anything. Is there a step I missed?

Which hub do you have? What are some of the devices that you can not connect? I am curious if they are zigbee or z-wave or both.

My first thought is this could be a stale device handler issue provided you had removed all your devices when you rest the hub. If you had installed device handlers for any of these devices, login to IDE at and choose device handlers from the menu, open each handler and Publish for Me. Then try excluding any z-wave device or reset zigbee devices and try to pair them again.

Also, when you reset the hub, you would need to delete all your devices. Here is a guide.

Mystery solved, after weeks of trying found the solution 10min after posting question:
each device needs to be individually factory reset to forget previous connection.

In this case they were all z-wave devices (GE & Leviton outlets, Samsung Motion Detector). I am not sure if this issue/solution is universal or limited to z-wave but it worked for me.

1 Like

After inadvertently deleting my entire hub/comfigatuons by selecting Delete Private Data, I just went through a reinstall of all my devices. Interesting how you have to put the hub which has been factory reset into exclusion mode so to reset your devices too. One little tid bit unless you find it in here like I did.