No Smart Apps or Device handlers in IDE

Hi folks,

I’ve just logged on to my Smartthings IDE - I’ve not logged on for ages.

I have logged on to update and publish all the WebCoRE Smart App - as per the notification in my webCoRE dashboard.

I’ve navigated to the My Smart Apps in the IDE and it says, “You don’t have any yet - add one now”.

I know I have smart apps, I’ve been using them for ages!

I’m logging in under my Samsung Account - for some reason my Smartthings Account login won’t work.

I’m also showing 2 home locations - both showing true but one empty and without a hub. I use both apps at the moment, but mainly the Classic App as it’s easier to use.

Can anyone help me please. I could do with updating my Smart Apps.

Thanks in advance,


are you logging in at

I would imagine at this point there are very few if any SmartThings accounts remaining. They have been migrating all ST accounts over to Samsung accounts.

but login to the link I posted above first

1 Like

I’ve managed to clear the empty hub by naming it STSC. That meant I was able to see which it was in the app and was able to delete it in the new app.

I’m down to one home location. But still no smart apps or device handlers in ide. They show under the My Location tab, but nothing in the My Smart Apps or My Device Handlers tab.

Very frustrating.

You tried to help me with this issue about a year ago and I’ve still not managed to fix it.

Hubitat is looking more and more attractive.



Contact ST support and see if they can resolve the issue for you.

1 Like

Sent them an email last night.