SmartThings Community

My IDE is now Empty. No Hub or Devices!


(terence peace) #1

So I logged in as normal to https://graph-eu01-euwest1.api.smartthings.com/hub/list

Everything had gone. It’s says I have no Hub and I need to add one from the smartthings app(which I have)
Also there are no devices listed and my WebCore has gone as well.

I have the same email addy with my Samsung TV\Phone\smartthings.
Yes I’ve contacted support in the UK, but they never get back to you…

Anything I can do to fix this?
Thanks


Getting forced into a blank Samsung Account!
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2
  • What happens when you login to: https://account.SmartThings.com ?

  • Do you by any chance have both a Samsung login and a SmartThings login? There have been many cases of these two logins not being in sync. Optimistically, this is a temporary situation; but you may need Support to resolve it.

  • If you have another device (Android, iOS) from which to login using the SmartThings App, that might be helpful to isolate the issue further.

I wish I could give you some certainty. All I know is that I have read about this many times now, and have had ActionTiles Customers experience it. In all cases it either resolved itself, resolved with the user figuring out that they had Samsung vs SmartThings login confusion, or resolved with the assistance of Support.


(terence peace) #3

Thanks.

As I’ve said before we have no support in the UK.

When I try to login to the link you posted I get the same options. Login to my Samsung or ST account.
I did try but it was empty.

My android app is ok and things work. It’s just the IDE that’s gone haywire.


(Jimmy) #4

which one did you try? When did you join SmartThings?


(Jeffrey) #5

Do you have multiple locations?


(terence peace) #6

Hi
Iv’e tried all EU links and they are empty. My samsung phone\TV and smartthings us the same account.

Now I can’t even delete my location to start again. I am in the UK.


(Jimmy) #7

Don’t do this. Sounds like the best approach is to wait for support to get back to you.


#8

As long as you still see everything from the mobile side then everything with your account is still intact (Location/Hub).

Don’t make it worse by removing anything or adding this and that. Wait for support.

Logout of IDE. Logout of ST Mobile app. Goto as Terry stated https://account.smartthings.com. (Login) What shard are you redirected to? After you Login, goto Locations. Select the Location. Does it show your Hub? Now go and select Devices from the Main screen. Still blank?

If you delete the Location, don’t expect to see anything in your Mobile app again and be prepared to add every single device again. Not recommended.


(Jeffrey) #9

Are you sure you don’t have 2 locations under locations? I have two from a migration and if I get into the wrong one I of course see nothing and have to switch to the other one.

What does locations show?


(terence peace) #10

I get this shared https://graph-na04-useast2.api.smartthings.com/location/list

And that’s empty. I won’t hear back from UK support till the new year. What a mess ST is becoming.


#11

That’s a US shard. You have something up with your account or email address. As I said before, leave things in place and don’t delete anything. The fact that you are able to see everything from the mobile app means that nothing is deleted so that’s all good. Just have to live with the inconvenience of not having other functionality until they get back to you.


(terence peace) #12

No.
If I use the link posted I got to the USA one. If I use the link I posted in the first post I go to the right shard, EU.

OMFG I just tried to sign back in to my android ST app and it won’t let me…WTF ST…

It’s trying to get me to register my hub again. But when I try it says I can’t because it’s already in use!


#13

All you are doing is making things worse. Something with your email address and ST / Samsung account has gone awry.

When you sign in, say you forgot password so that it emails you and then follow those links in the email.


#14

And FYI. When you goto https://account.smartthings.com, it shouldn’t matter whether you are in the UK or US. It redirects you to the shard you should be on. I am in the US and I entered the UK shard you mentioned above and it redirected me back to the https://account.smartthings.com site to login with the redirect back to the UK one within the url, so I know that the main url works. Something has happened with your account.

What you could do is call US Support and tell them that you are in the UK, but all of a sudden when you login to the web, you are redirected to one of the US shards instead of the EU one that you belong on and explain that you can not see your location / hub / devices. They may help you out if you are calm and collective with them.


(terence peace) #15

Because(as I’ve said) my Samsung account is under one email addy.
If I ask for a password it just tells me to follow the link to Samsung and pick another password.


(terence peace) #16

As I’ve said. If I follow the USA one, I then have a USA shard which is wrong.
If I use the EU link, I go to a EU shard which is right, as I live in the UK.

And we in the UK can’t phone ST. Only email and that takes days. This only happened today.

I managed to login to my android ST app. Will leave it at that till the new year.


(Jimmy) #17

This doesn’t make sense. The link he posted is is for ALL shards. There is no USA or EU version.


#18

What I’m saying to you is that the official login page is https://account.smartthings.com. The link you went to is just the shard for the UK. If the https://account.smartthings.com is redirecting you to one of the US shards, then you have a valid case to call the US 800 number.


#19

If one calls a US 800 number from the U.K., the call will go through but will be charged international rates. It’s only a free call within the US.

Might be better to use the chat option instead if that works.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #20

This absolutely “cannot” be true (though of course I cannot dispute what you say you experienced).

Approximately 15% of all SmartThings Hubs are sold in the UK, and continue to be sold at that rate (I can arrive at that figure from extrapolating ActionTiles sales proportions and related data). It is an official market for the product. Unless SmartThings is silently trying to exit the UK market, it makes no sense that they would provide support far worse than in North America.

While SmartThings UK has a distinct marketing and support division from North American operations, they are still a part of “SmartThings Inc”, and surely Samsung SmartThings (which is working on global expansion) would not lower customer service expectations to the level you mention without an explanation. Am I out in left field, @Brad_ST?

We have lots of Customers in the UK. It distresses me to think that they are unable to receive SmartThings Support of a similar level of quality than in NA…