SmartThings Community

What a mess, samsung! (February 2019)

We were fine when we used the classic app with SmartThings, then you came along and messed everything up. We migrated to the new app and found out a dozen of our devices are not working because the custom device handlers are not supported. We spent 2 days trying to go back. NOT A EASY TASK! The IDE is so buggy, along with the phone app interface, it is so confusing! The hub is offline and we have 40 devices that we could not keep. Now, the offline hub cannot be deleted, there is 2 locations I can’t delete EVEN IF WE WANT TO START FROM SCRATCH! The instructions for resetting the hub (V2) I found online are confusing and conflicting and never work. I can’t even close my account and have all locations/hubs/devices deleted and start from scratch with a new account.

SAMSUNG, you bought SmartThings to grab a share of the market, and now you have messed it all up by taking it over!

Automation is supposed to make life easier. IT IS NOT!

If one of the locations is empty, you go to #2 in the following thread to remove it…

1 Like

This hub “sda3” is inactive in IDE (but was active in the new app, why?):

And when I delete it:

2019-02-24%2010_10_45-Something%20Went%20Wrong

So, forget about deleting it, I have 2 locations and I would like to delete one:

The Derby St one is new. The “home TO DELETE 1” has the sda1 (inactive) listed as the hub so, I obviously want to delete “home TO DELETE 1” and when I do, it says “Home TO DELETE 1 deleted”, then it is still listed.

2019-02-24%2010_14_01-Location%20List

So, any way to delete my login account so that my hub and my devices can be freed, and let me set up everything NEW with a new emails and new account? Will the hub still be held up even the old account is deleted? (There is no way to delete, cancel, or disconnect the account, is there?)

Even starting from scratch could be that difficult?

Tech support wait time was 4 hrs yesterday and she was just reading scripts.

I am tired of this. Who jumped ship and what do you recommend?

jkp, I am following the #2 you recommend:

“Home TO DELETE 1” is the one I want to delete and its default location is false

2019-02-24%2010_29_47-Edit%20Location

and even it accepted my click on the delete button, and show the “Home TO DELETE 1 deleted”, 2 locations are still there:

It looks samsung the takeover of SmartThings is a total screw up.

You will not be able to delete that location since it contains your hub.

Note: please remove the image above that contains your hub info since it lists your hub ID

What do you have in the Derby St location?

It is a new location and no hub no devices inside.
The “Home TO DELETE 1” is the one with the inactive hub and 13 devices I could not delete.

Remove the derby street location and let’s go from there.

Done (by setting default location of “Home TO DELETE 1” to true so that Derby St’s default location is false):

Now, I have only one location which has an inactive hub and 13 devices.
When I try to delete it, I get this:

2019-02-24%2010_48_11-Something%20Went%20Wrong

Ok, login to the Classic app. If you are not logged in, use New to SmartThings when you login and use your Samsung account.

I basically want to know if you see your devices and possibly control them.

1 Like

Done:

Should I try to delete the hub?

What is the color of the led light on the front of the hub?

I’m not sure if this is related, but I ran into the same error while trying to delete a location and deleting all the apps and devices for that location through the IDE solved the problem.

No, let’s not delete anything at this point.

1 Like

It is Green. solid.

Which hub do you have? If a v2 have you try powering it off for a minute and removing batteries. Then power it back up.

And you spoke about using the STSC app, was the hub online with it?

V2 with fireware 000.024.00020. We did remove the battery and disconnected power for 2 hrs last night. Let me do it again:

… 2 minutes passed.
Now powering up…
blue…
then solid green.

Yes, we played with the new app too and at one point we did see the hub online with it. But now only the “Home TO DELETE 1” location is in but no hub no devices.

Click on the 3 bars and select Devices. See if your hub shows there