No network connection - when registering hub

Hello,

I’ve recently bought a SmartThings starter kit with the hub (model: STH-ETH-250) included. My first attempt to get everything set up was to follow the instructions to install the app on my phone, put in the batteries and connect the Ethernet and power cables to the hub. I’ve also created a location in the app.

When I attempt to add the hub in the app it doesn’t show up automatically, so I have tried manually.
I can get to 40% progress entering my welcome code, but when I hit ‘Register your hub’ I get this error:

“No network connection - A network or server error occurred. Try again later.”

I’m now stuck and can’t progress. I’ve tried to reset the hub using the reset button at the back. I know the internet on my phone is working (I’ve tried to register the hub using Wifi and mobile data without any luck). I did notice that when I click on the Customer Service link (labelled: “Tap here for help”) that the web page sometimes very briefly shows an error that the network has changed, but it quickly rectifies and loads the web page correctly, so there might be something going on with how the app is connecting to the internet.

Any ideas would be greatly appreciated. As of now the kit is completely useless to me, and I hope I can get it to work.

1 Like

What is the color of the led light on your hub?

Starts off blue then turns bright green solid

I suggest contacting ST support…
https://support.smartthings.com

1 Like

Will do - thanks :slight_smile:

Found a solution with the help of customer support.

First issue was the App. I had the ‘SmartThings’ App (which you’d expect to be appropriate for ‘SmartThings Hub’, but no) - you need to use the SmartThings Classic App.

Next, the Hub I have is originally from the US and the App assumes your region when it creates a location for you automatically. Remove the location, add a new one and make sure the region matches the origin of your Hub (in my case the US). Et voila! It now works…!

Also, got the same error and called Samsung Support and they told me I cannot use a US-based Hub in Europe, so that concluded my case. I had to purchase a Hub from Europe as US servers do not allow the Hub to connect and activate while on European IPs. :slight_smile:

Having similar issues with v2 hub. Classic app can’t be downloaded or run from APK. What else can I do?

There is nothing you can do in regards to the Classic app… it has been shut down and no longer works.

What are you trying to do?

Trying to connect and use SmartThing Hub V2, US Zwave, Can’t seems to make it work in Israel.
After entering the SN of the I’m getting Network error occurred please try again later.
Hints?

I turned on VPN to usa, in the past I installed it with VPN to Canada and everything worked properly, now I had some issues with the hub V2 and had to do hard reset to the device.
Trying to add it again and getting a network error

@Brad_ST , @Aaron
Please help… Any ideas how to prevent network error when connecting US Hub V2 in Israel ?

Hi Shai -

I took a look and did not find an obvious explanation. As far as I know there should not be an error connecting your hub. Do keep in mind that you are responsible for compliance with local laws regarding radio usage. The US hub was manufactured to comply with US regulations which may be different for you.

Do you have a screenshot of the error you can share?

Thanks.


Friends this is the message I get.
I turned on VPN to usa or canada , in the past I installed it with VPN to Canada and everything worked properly, now I had some issues with the hub V2 and had to do hard reset to the device.
Trying to add it again and getting a network error

Now the lamp has turned solid blue

Anyone have a solution for me?
The last two days I have been spending too much time setting up this device.
im Writing to you the things I tried.

I opened an account in EXPRESS-VPN , I activated on the router VPN to Canada, Miami and even New York. Nothing worked. Still a network problem.
I changed my Google Account address to New York, I tried to add the device, still not working.
I replaced the router I replaced the cables.
Still a network problem.
I changed the account to English, switched phones and still nothing works

I had all the same issues and could not get device registered when connected using a patch cable to my LAN using the ethernet setup option. Tried WiFi setup and everything progressed as it should. Try WiFi setup option.