A network or server error occurred. Try again later

I am running both SmartThings and SmartThings Classic.

SmartThings Classic runs without any issues.

SmartThings does give me an error of: a network or server error occurred. Try again later. when I select the SmartThings hub. There is also a list of unknown devices listed which do not show up like this through Classic.

Any thoughts?


Use SmartThings classic until the new one’s capabilities are beyond beta testing?

Samsung confirmed it’s a known issue.

I’m having the same issue. Anyone able to find resolution? Thanks!

1 Like

Classics not working either when trying to register as a new user.

So, so not ready for main stream.

Looks like I’ll be returning my kit for refund…

Which hub did you buy? The 2018 hubs require you to use SmartThings (Samsung Connect) to initially set up your hub

Yup tried SmartThings. Got the network error. Tried Classic, just doesn’t load any further than the first page on the app.

Kinda stuck.

Tried both my home wifi and the mobile network, but same issue.

Its the STH-ETH-200

But im trying to register a new account, not doing anything hub at this stage, right?

iphone or android?

Android (8)

For comparison, I’ve setup a heatmeiser hub and heating which just worked ™ and some stand alone devices too. Only have come across this issue with smartthings :frowning:

This is the exact same problem I’m having. The SmartThings Hub v3 starts up and the light begins blinking red and green but when i got to add the device in the app, it says “Couldn’t add device A network or server error occurred. Try again later.”

getting this error now…need some kind of help as the hub doesn’t do anything anymore…cant add devices cant change smart lighting ect…was going to buy more motion sensors but now i may end up buying nothing because of this…do i factory reset my hub or something??

EDIT: would of been nice if anyone bothered to reply to this after fixing it if they did…after getting annoyed i uninstalled the newer samsung smart app then installed the older “classic” version. this allowed me to again change lighting settings and I’m not getting the error as of right now.(ill edit later if it happens again)

Second EDIT: i went back to the newer application and it gives me the error or sits at “processing” the older application still works though…this is with a V3 hub and only zigbee devices all within range and most within line of sight to the hub. i kind of like the older app a bit more anyway…when changing the lighting/motion sensors it shows you which sensor goes off when your walking around in the ui.

All my device give the same error…

Any idea why?

All my devices work fine in the classic app. (v3 hub)

I’m having this issue intermittently. Did anyone find a solution?

almost 2 years later and they still have not figured it out. Same problem here. Motion sensors suddenly not working anymore, activities logs not being updated.
What a cluster f…ck… At a minimum I would expect some douche from Samdung to explain they have service issues again and when they will be resolved.

1 Like

I might have been lucky, but I ran into an issue where my devices weren’t showing the correct statuses and hub would not show status in the SmartThings app and gave the error listed in subject. I fixed it by following the advice in this thread, of downloading the classic app. Opened my Hub in there, navigate to Z-Wave Utilities, Repair Z-Wave Network, then chose Start Z-Wave Network Repair. After a couple of minutes, I went back to the current app, checked that all my devices were up to date and everything was just dandy again.