No motion detected from Ikea Trådfri Motionsensor

I’ve just purchased the Ikea Motion Sensor today and no joy. It’s not detecting motion. I can see the latest Zigbee Motion Sensor driver is actually today (2022-10-18T18:28:55.910973961) So looks like there was a new driver literally minutes before I onboarded it. I have other Aeotec motion sensors which work perfectly but need this one for outside as it has an ip44 raiting but can’t get it to detect motion. Anyone actually sorted this.

I had same. So i returned

My guess is that the firmware in the ikea motion sensor is not up to date (2.0.022)

I have one with the latest firmware on it that is working with the driver you noted.

Edit: several hours have passed and my ikea motion sensor has now gone offline :face_with_symbols_over_mouth:

How can I find the firmware version of the Ikea Motion Sensor? It’s using the Zigbee Motion Sensor driver and doesn’t give you any informationa apart from the controller version.

I might be doing the same however there is a Smartthings hub update which came out yesterday but hasn’t hit my hub yet (Mine is currently on 000.044.00009 and the 5.4.2 Zigbee stack). Hopefully I’ll get it tonight or in the next few days and I’ll check after that and update here. If still no joy I’ll probably be doing the same. As I have no idea whether my motion sensor is faulty or it is just issues with the transition. Some people say it’s working for them.

I also have Home Assistant so can connect it to that to see the firmware version.

On SmartThings the only way i know of to see the firmware version is with the CLI.

Should it have detected motion? My IKEA motion sensors all report offline after a few hours of inactivity. It has been a problem since day one with the Edge drivers. They come back online as soon as there is motion.

They usually have at least one false positive a day so they don’t stay offline too long.

I’ve only had my Ikea motion sensor less than a day and so far it’s gone offline numerous times and the only way I’ve gotten it back online is re-adding it. It’s never detected any motion thus far. Last night my Hub got updated to 000.045.00009 Firmware and 5.4.4 Zigbee stack but unfortunately still no joy (No Motion Detected) So I’ve either got a faulty sensor or more likely Samsung has screwed this right up. I’ll ping their support a message today and see if I get any joy otherwise I might have to return it and look at another brand.

I allso have the same problem. I added the motion sensor just fine, but can only see battery status, no motion regristration :(.

Tryed deleting it 3 times, but no differince :frowning:

The motion sensor seems to have had a fix applied that doesn’t actually do anything. For the buttons it corrected the code for a fallback to Zigbee group 0 to allow for the binding table not being received. For the motion sensor there wasn’t a fallback to start with and there still isn’t so a return was added that didn’t change anything.

That’s exactly what happened.
It came back online as soon as motion was detected.

My Ikea motion sensor was added about 3 months ago and has never worked properly. Like many it does not report any motion. I have used both Groovy and multiple Edge drivers, non of which have worked.
At best it reports motion once then stalls forever.

Unfortunately i now am in the same boat, my Ikea motion sensor using the ST zigbee motion driver is stuck in the motion detected state

2 others still using the old connection method from groovy seem fine

I just changed the edge zigbee driver to edge thing, then switched back to edge zigbee and the device successfully detected and reset after set timeout

Nope, it failed to remain working after a while and is now stuck with motion detect

I don’t as finally able to get my IKEA dimmer buttons working tonight but IKEA motion sensor only displays battery but doesn’t register motion events. I’m hopeful this will be fixed soon.

Had anyone heard anything more about this? I really want to use these motion sensors :frowning:

There’s another firmware update coming to fix the issue the current firmware caused.

So any news on this?
Just installed tge motion sensor to smart hub v3. Doea not react at all to motion. Just say no motion detected?

Latest firmware 45.00011 that came out on the 31 Oct 22 hasn’t resolved this issue, neither has the Zigbee motion sensor driver released on 1st Nov 22. Apparently this issue isn’t a priority fix for Samsung as I can see people have been reporting the issue for over 3 months now.

Looks like a fix entered the main repository nine days ago but hasn’t moved up to beta yet.

Just gets more confusing, my Ikea motion sensor now works fine ? Using the ST motion sensor driver