Newly installed smart apps not showing in mobile app

If a majority of broken things around here got fixed in either days or weeks, I don’t think we’d have the volume of piss we see being spilled and foamented in our complaining threads these days.

p.s. not pointing fingers; it is what it is. we love ST and the ST Team, but are pissed that it’s been so broken for so long. So, not adding to the piss; just intending to acknowledge it in a humorous way (humor=not my strong suit. So, I try). :slight_smile:

1 Like
1 Like

I spent an hour and a half trying to troubleshoot a custom app I reinstalled that ran but did not show up in my Smartapp listings. A Google search lead me here to the solution. Thanks @bamarayne for documenting the error and fix


I am probably being dense, but as a new SmartThings user I am not sure where to find ‘API’ Should I be in the SmartThings android app and if so which screen?

Here ya go…

Excellent - Thanks a lot.

1 Like

been trying to install smart tiles for three days, rebooting, re installing etc etc, this finally fixed it, so thanks for that

1 Like

Just curious if you are facing this issue, are you using a V1 Hub or V2 hub? I can not get my apps to load on my v1 hub on the newer SmartThings app. The v1 hub will load smart apps using an older version of the SmartThings app though…The v2 hub loads apps no problem.


Hitting the same issue here. Any workarounds? In my case I’m trying to install Nest Manager.

New Android app on playstore tonight, fixed my issue with Smart Apps not loading. Wow! Hopefully that helps!

1 Like

I’m having this problem currently, but unchecking the box did not fix.

Just installed pollster ‘from code’ to my smartapps in IDE just like I’ve done before with rulemanager and rule and mediarenderer.

saved, published for me, unchecked the box, everything. app still doesn’t show up in my smartapps.

I’m having the same issue, I installed/saved/published(for me) a new app, but it’s not showing up under the Smart App Category I set in the code. I tried the OP’s suggestion of unchecking the ‘Enable local child app discovery’ (it was initially checked when I looked at that screen), but the app is still not showing up for me in the mobile app.

Are there any other workarounds? Should I be setting the Category to something different than one of the existing categories that are listed in the mobile app?

Thanks kindly.

That Category selection is ignored for self-published SmartApps.

They will only show up in the “My Apps” at the bottom of the list of categories.

Thanks for the reply @tgauchat! Should I be concerned that I don’t have a ‘My Apps’ category at the bottom of the categories list under Marketplace > SmartApps? The last entry in the list for me is ‘More’. :frowning:

Yes. Be concerned … be very concerned. :ghost:

I’m guessing, that, perhaps you have published your SmartApp on the wrong shard!

What is your path to the API:

I’m using , I think that should be correct given my location on the west coast, no?

No. Except for Europe and Asia Pacific, the NA regions aren’t geographic (yet).

Find our your shard using these steps:

  1. Logout of the IDE.
  2. go to:
  3. and fill in your login.
  4. Your browser’s URL bar should automatically redirect to your individual shard:

If it still says “graph.api”, that’s NA01; otherwise, the URL will include “-na02-” or “-eu01-” in it.

1 Like

Following your steps leads me to the url
It still says graph.api , but I’m not sure how to deduce my shard from this.

You’re probably on the original NA01 shard, though there’s a chance your browser isn’t showing the redirect. ( FAQ: How to find out what “shard” (cloud slice IDE URL) your Account / Location is on? ) has a bit more info.

Check the various tabs and if your Devices, Locations, Live Logging, etc. are all there you probably are in the right place, despite my guess of what’s wrong.

I’ve seen some chatter that SmartThings have some current issues with SmartApp self-publishing for some reason. Doesn’t hurt to email:

1 Like

Thanks again @tgauchat. I followed your guide and I’m definitely on the NA01 shard. Someone replied to your guide and mentioned that the url redirects differently across browsers so I thought I might as well try logging in to the IDE using Chrome instead of Safari, I published my app, and just like that it’s showing up in the mobile app now. Must be some kind of weird Safari bug!

1 Like