Install My SmartApp


(Michael Kaufman) #1

ok, i;m really new to programming and such. I have wrote a program based on code from git something. I saved the app, published to myself. How do you install the program.

if i use the simulator on the side of IDE it shows in the smartthings app but crashes the app when i click on it. If i logout of IDE and close and relaunch the app its not installed anymore.

what am i doing wrong or how to i install an app and love the bomb… (dr. strangelove reference)


(Florian Z) #2

You need to actually install your published SmartApp through the SmartThings mobile app, and not through the simulator. So launch the SmartThings mobile app, tap the “My SmartApps” tile, then “Explore SmartApps”, then “My Apps”. You should see your newly published app in the list and you can now install it like any other SmartApp.


(Michael Kaufman) #3

The My Apps doesn’t show up in the explore smartapps. That seams to be the issue. any way to get that to appear?


(Florian Z) #4

Yes, that means you have either not clicked the “Publish” -> “For Me” buttons in the IDE, or you did not set the “Category” to “My Apps” in the “App Settings”.


(Michael Kaufman) #5

I did both of them. it shows

Namespace / Name     Versions   Category   Locations
                  Working  Self
Auto relock    	   0.3	   0.2	  My Apps	        Home 
mancave        	   0.2	   0.1	  My Apps	        Home 

(Florian Z) #6

Hm… sorry, I’m at a loss then. Have you tried getting in touch with SmartThings support? They are very, very responsive and super helpful.


(Michael Kaufman) #7

From Support:
Ryan Hanna (SmartThings)
Dec 03 03:49 pm (MST)

Sorry about that. Sometimes the published apps don’t show up right away. Try logging out of the mobile app then logging back in. Restarting the app doesn’t always work for some reason, so make sure you do log out and log back in.

It fixed it. Simple i guess…


(Brent Kenreich) #8

bump. same issue. logging out and back on didn’t help.


(Baloodevil) #9

bump. bump. Logging out and logging in didn’t help. I don’t see the category “My Apps” in the apps section, only “Explore By Device”, “Convenience”, “Family”, “Fun & Social”, etc.

By the way, to see your SmartApp in action you do not need to install it on your mobile app. The IDE has a simulator which actually interacts with the real devices you have. It is a bit hidden, you need to click the “Set Location” green button on the right, then it shows Preferences specific to the app you wrote, then you can click the green button “Install”, which does not install it on your mobile device, but ‘installs’ it in the simulator. The simulator will show some ‘virtual devices’ and your physical devices. It is just like using your app in the mobile app, but through the web based IDE. The could do a better job of making it more clear that it is there and how to use it… maybe using a frame for the simulator that looks like an Android/iPhone device that is always visible, with a ‘Start Simulator’ button under it.


(Tony Gutierrez) #10

Same issue…where the hell do published apps go? Even only publishing “For Me” doesnt seem to add it to the list of apps on my android at all.