New update won't allow my Alexa to control my fire TV anymore


(J Sutter) #1

Ok this is a feature that has worked for me for the last several months. I have done everything from completely removing my harmony and Echo from Smartthings. Then reattaching and reauthorizing each individual device but Alexa will not control my fire TV any longer. Now I AM able to control my other devices as before. I can still get Alexa to recognize my blu ray and smart TV because Alexa doesn’t seem to want to understand DirecTV, but no luck with Fire TV. Alexa does show all my devices in her profile when I run discovery, and Smart things does allow me to turn on Fire TV through the Smartthings app. It stands to reason that if Smartthings will control the Fire TV through the smarthings app and Alexa sees the Smartthings app then she should be able to perform this operation. My reasoning that THIS is a Smartthings issue is because this operation worked fine UNTIL the Smartthings update. Now a couple months ago when Smartthings did its last update I had to change my wording from “turn on Fire TV” to “turn on Amazon Fire TV” even though I did not make any changes in the configuration. But I can not get this feature to work now no matter what wording I use. I know that I am setting this feature up properly and reauthorizing it properly because I am able to get my DirecTV and blu ray players to function properly. I have tried everything I can think up to fix this issue. If anyone else is having this issue or has any suggestions, then please share.


(Jason) #2

Try something that doesn’t end with “TV”? perhaps “fire television” or “fire device” and see if that makes a difference

Amazon broke some naming conventions recently and are allegedly working on a fix:


(J Sutter) #3

Thanks but that didn’t work either. So your saying that it’s an Amazon issue? This worked literally yesterday before the Smartthings update.


(J Sutter) #4

This is greek to me, but here is the device log
238e7e7d-1c92-49f6-b185-3ad958ad0985 10:01:49 AM: debug getChildDevices(false), children=4
238e7e7d-1c92-49f6-b185-3ad958ad0985 10:01:47 AM: trace [[id:13670729, name:Watch Smart TV, type:1], [id:19073533, name:Watch Fire TV, type:13], [id:10599563, name:Watch Blue Ray, type:2], [id:off, name:Activity OFF, type:0]]
238e7e7d-1c92-49f6-b185-3ad958ad0985 10:01:44 AM: trace [[id:13670729, name:Watch Smart TV, type:1], [id:19073533, name:Watch Fire TV, type:13], [id:10599563, name:Watch Blue Ray, type:2], [id:off, name:Activity OFF, type:0]]


(J Sutter) #5

Now I know it’s not “TV” because Alexa does recognize “turn on Smart TV”


(Jason) #6

I obviously can’t guarantee that, But it doesn’t hurt to rule it out. If it works from the App then it stands to reason that the breakdown is from Alexa->ST connection. Perhaps it is the word Fire, or the combination of “fire tv”(since it is one of their products they might be reserving it for other reasons)?


(Jason) #7

Are those logs while you told it to watch smart tv and fire tv? (I don’t think i’ll be much help with the logs either way, just trying to make sure the info is included)


(J Sutter) #8

Yes…I just took those logs after giving Alexa a command. Which indicates that Alexa is communicating with the Smartthings hub, but their is a disconnect after the command reaches the Smartthings device. One other issue of interest. When I say to Alexa “turn on Amazon fire TV” which worked yesterday, Alexa responds by saying that she does not recognize that device in my profile. However, if I say to Alexa " turn on fire TV" or "turn on Amazon TV’ she responds with a noise instead.


(J Sutter) #10

WOW this is getting to be a big Pain. Ok after spending the last few hours removing/ adding devices and activities from Smartthings, Alexa, and my Harmony app, I’ve discovered that Alexa finally figured out how to turn on my Fire TV. I must now say “Alexa Turn on Fire TV Harmony Activity” . Here is where things get strange. This morning she could turn on my other devices minus my Fire TV. Now she refuses to cooperate with my Blu Ray player. No matter what wording I say, she does not understand the Command " Alexa Turn on Blue Ray" I made no changes to the routine whatsoever other then removing then adding the steps to perform the process in the Smartthings and Harmony apps. All Macro’s will perform correctly when initiated in the Smartthings app so I’m about to say screw it. I have done everything I could think of including removing all the Smart App devices and device children in the Smartthings software, and I went so far to completely delete all my activities and devices in the Harmony software. Lastly, I did the same for Alexa. I was planning on setting up voice control through Smartthings/ Harmony/ Alexa in every room in my house. After this issue, I don’t think that’s going to happen. I’ve spent all day on one room with no solution.


(Michael Hess) #11

If you fiddle with the Harmony Smart App it will sometimes recreate the virtual devices for the activities, that’s where the appended “Harmony Activity” came from. I’ve had this happen twice, once when I’m pretty sure I never did anything to it. Like it just magically decided to repoll the harmony servers and recreate everything.

If that’s what happened, just go into the IDE and rename all the activities to remove the “Harmony Activity” portion of their name, and rerun alexa discovery.


(J Sutter) #12

Ok…I was able to fix this issue. Alexa does not understand " turn on blu ray" but she does understand “turn on BLUE RAY” Also, I was able to get Alexa to understand “Turn on FIRE TELEVISION” so I don’t have to say " Turn on fire tv Harmony activity" It’s all about the spelling with her. All I had to do was change the label in the smartthings software under the my devices tab and rerun discovery for Alexa.