Alexa Echo + ST (Alexa cannot find any smarthome devices with voice commands)


(Joe) #1

Ok…newbie here and yes, I am one of those that just bought an Echo on Prime day, but I am not new to home automation. I previously had an Iris system and we have since sold that house and bought a new one, so I thought this was the time to make the change to Alexa. So far I haven’t had much luck with getting voice commands to work. Alexa just responds cannot find ‘devicename’. Here is what I have done so far.

  1. I successfully setup the smartthings hub and device and the device works fine in the smartthings app.
  2. Installed the smartthings skill and discovered my device (device in question is the smartthings smart outlet). Alexa discovers the device fine, everytime.
  3. Removed the skill and re-enabled it many times
  4. Reset the Echo back to factory and started over. Again - all devices discover fine, but voice commands don’t work.
  5. Renamed the device, rediscovered, still doesn’t work
  6. Put device in a group, voice commands don’t work for the group either
  7. I have verified that the smartapp in the smartthings app has the slider enabled that allows access for alexa to all devices and routines.
  8. I have also had this same exact issues with the TP-Link plugs. Everything worked in the TP-Link Kasa app, but Alexa would always respond that she couldn’t find the device with a voice command.

Please tell me I am doing something stupid and there is a simple fix. I don’t want to have to return everything and start over looking for a new solution.

Thanks in advance


(Andy - United Kingdom) #2

Joe
one thing I have had a lot of issues with when using the Echos is the naming convention.

e.g. If you have an Alexa group called ‘Kitchen Lights’ you cannot use the words ‘kitchen’ or ‘lights’ as a device name in Smartthings.
(All Alexa will say is “I have found several devices with that name - which one do you want”)

I use KL1, KL2 (i.e. Kitchen Light 1, 2 etc) as names for my lights

This I have found to cause most problems with voice control of Smartthings devices


(Joe) #3

Shouldn’t I be able to use the device name as they are defined in smartthings?


(Andy - United Kingdom) #4

When they are similar to a group name e.g. KitchenLight 1 KitchenLight2 with group ‘Kitchen Lights’ then Alexa seems to get confused.
I would try to rename them in Smartthings the ‘discover’ again with Alexa and see if this solves your problems


(Joe) #5

Ok…I understand. In my case, I currently do not have any groups defined in Alexa.


(Andy - United Kingdom) #6

Even if I have only one device to control, I create a Group in the Alexa app
Then if you’re careful with the names Alexa doesn’t get confused

e.g I have a single lamp in my conservatory (smartthings named CL1)
I have a group in Alexa call ‘Conservatory Light’ with only CL1 as a group member

I say “echo turn on (or off) the conservatory light” and it works EVERY time

Obviously I also have multiple lights for some rooms e.g LL1, LL2, inside an Alexa group call ‘Lounge Lights’

You just need to come up with a naming convention that works for you!