New Stock Edge Drivers Beta list

Switched over my first IKEA Motion sensor. Pleased to see that it works with ActionTiles as the issues list suggested the drivers didn’t work with legacy apps.

1 Like

My Ikea motion sensor went from 100% to 50% battery, just from switching from Groovy to Edge driver. I just replaced battery prior to re-adding device.

IDE shows placeholder

But device is not assigned to hub, and if i try, i need to add device network ID

Added a second and noted that the app wasn’t happy because the motion attribute wasn’t initialised (‘Checking …’ on dashboard, broken cloud on details view, 0% battery). I had to trigger motion to initialise things.

I noticed my first one went from 70% (77% ?) to 30%. Second one is still saying 0%.

Update: Tried a third to get a majority vote. Battery was 77%, initialised to 50%, and dropped to 30% when motion was triggered. Motion again not initialised.

1 Like

Steven, when the drivers exit beta state, any device we switch to using edge drivers now, will need to be removed and readded once the final versions are released and beta ends?

I’m not certain (and also not in charge of these decisions), but my instinct is that what is currently the “beta” channel will eventually become the “default” channel that all hubs are automatically subscribed to.

If that is what ends up happening, devices will not need to be removed and re-added. But I can’t guarantee it.

1 Like

So was it the intent for everything to go dark and have everyone reset their hubs?

@orangebucket this is probably why you have problem with second device.
I just have one Ikea motion sensor, but i don’t see how hub will know how to differentiate another one if all of this IDs are blank by default

This is how Edge device is added, no Zigbee ID, no Network ID, no Hub,and it’s not Local, it’s still Cloud

Ok lets hope this will be the case :grin:

1 Like

The IDE is part of the legacy platform so it only knows that sort of thing for devices that use DTHs.

If you view the device via the current API (e.g. using the CLI), you will see the EUI (the Zigbee device ID), the network ID, the local execution status and the hub ID.


It is not cloud. It actually runs locally. Also they said that nothing from the edge drivers will be displayed inside the ide

1 Like

I have tried to change the controller with the tool that the app has in device tools menu and it gives me an error: “Check that your phone is connected to the network”
Could it still not work?

Yes it runs local, but it is seen in IDE as type placeholder and in the app it is in linked services.

The information of the zigbee connection metrics between the device and the hub has also been lost.

I went back to Groovy dth, and it shows correct battery status. Anyway Groovy device, connects through another zigbee repeater, was not. It was connected directly to yhe Hub, which was on the border of the signal, and it was conecting/disconnecting all the time. It never connected through any repeater.

The battery level calculation is not always very reliable.
ikea dth does the calculation by voltage reading.
Now they have fused it with the dth zigbee motion sensor and the calculation do it differently, by percentage remaining reading.
The smartSense motion sense dths, for samjin models, from doing the calculation in the cloud to doing it locally in the hub gives me a difference of up to 10%, since they use different calculation formulas in the dth and the hub. the hub does the standard zigbee percentage calculation.
But I don’t know if this will be your case.

I don’t see in the edge drive code that it does a different battery calculation for the ikea sensor, as I see it in the edge drive of the zigbee smoke sensor for the Frient sensors

I just replaced battery prior to changing to edge driver. It should be at least 99%, not 50

Just switched my Sonoff motion sensor, it shows “phaceholder” on Groovy and works fine. I have two automations using it, the first one turns on a device when movement is detected and shows running local (home icon). The second turns off the device after 5 minutes without movement, but it´s not showinhg the home icon. If I disable the “stay this status for how long?”, the icon appears.

Is it possible to run locally automations with this option enabled?

the remains function doesn’t run local yet.


They told us this when lunching the beta

The different percentage calculations is one thing, but it immediately looks from the result like a divide by two has been added/missed, for the IKEA at least.

1 Like

The normal calculation by reading the remaining percentage, divide by 2. In this case they have divided by 4 or the raw value is not correct.

In the ikea dth it has min and max values ​​of 2.1v and 3.0 v. and uses the voltage reading. The rest of the sensors where they have integrated the Ikea dth use the calculation by direct percentage dividing the raw value by 2.

I do not see in the lua code any special case for the ikea calculation by voltage.
I see that it configure the reports to send percentage, not voltage.

I guess the Ikea sensor will accept this configuration!

In the zigbee smoke sensor edge driver there is the frient sensor that also calculates it by voltage and has its specific code with the definition of the min and max values ​​in the “scr / frient” folder and has its own code in the test folder.

I do not have any ikea sensor, but seeing the livelogging in the cli, @milandjurovic71 could check the battery calculation log, it is not easy since it has very long configuration intervals 21600 sec if there are changes> = 1%