New SmartThings App - No SmartApps

Describe any problems you are having

I have no smartapps. I can’t authorize new items in webcore. I can’t add things to actiontiles. Not sure what else I cannot do but I am sure the list will grow.

Does your hub show in the new app > menu > devices?

Yes it does.

No pi hole. I do need to get one of those running again. Loved that thing…wife did not!

Those apps which are linked services do show up in the place you describe. Interesting Action tiles is a linked service but I have no way to authorize new devices.

My hub was assigned to a room. I changed it just cause. No changes.

Contact ST support… sounds like you need a sync performed to get them available in the new app

But again, some of those old Smartapps have been moved to menu > settings > linked services

I contacted support they said it is an IOS bug but the bug only appears for some people and they have no ETA on a resolution. Others have reported the problem but I suspect its only affecting a small subset of users so not very high on the priority list. They keep telling me to update my app.

Tagging @Brad_ST . He was able to get it working for me. The iOS bug they tried telling me was the problem was too many smart apps causes it not to display on iOS, but i only had 3 or 4 installed on my account. I think it was fixed by removing a smart app that was half installed.

jamesonrw I appreciate the assistance on this one. Having a halfway install smartapp wouldn’t surprise me one bit. I was all over the place when I initially started down this rabbithole. I like to think I am a little more skilled now.
I actually thought it could be a old our outdated smartapp so I did take some time to clean them up a bit. Maybe I will look through them a little more. Just off hand do you recall which one fixed it for you?

Do remove echo speaks as ST shut it down

And again, many of those have been moved to menu > settings > linked services

My echo speaks still works. Stopped for a bit but lately its been working as designed.

1 Like

I think mine was actiontiles, but it wasn’t fully installed. I only have it on my primary location, but it somehow got partially installed on the second location.

@ShaggySS Take a look at “My SmartApps” in the IDE. One of your self-published SmartApps references an icon with spaces in the URL. It looks like the app is failing due to that. You can change the icon or add encoding for the spaces. I tested on iOS without the encoding and was able to reproduce your issue and by adding encoding, I wasn’t able to reproduce it. & Wellness/health2-icn.png can be changed to


@Brad_ST You are a genius!! Thank you so much for taking the time to track this one down. First smart app I clicked on right at the top I saw your examples. I modified the spaced as you said and Boom! I have smartapps!

For those who stumble across this mine is due to a smart app called Pool Controller. I will contact the the creator and make sure he is aware. @bradsileo

Thanks again both @Brad_ST and @jamesonrw for getting me in touch with Brad.

1 Like

I would argue @Brad_ST needs a promotion, but then who would fix our issues when support can’t seem to figure it out?


I’m having the same problem, none of my apps show in the new app. I contacted smartthings support and they told me this:

“I would like to inform you that SmartThings app will only show the pre-installed Smart apps, it doesn’t show the custom smart apps.”

Which sounds like what comes out the back end of horses.

I’ve been through all my apps, I only have 1 self-published (the rest all pull and sync with github repos and are up to date) and that doesn’t have a space in the icon URLs.

@Brad_ST - any other suggestions? It’s driving me mad and I don’t want to have to factory reset the hub and hope that clears it.



I found an incomplete SharpTools SmartApp installation which I removed. Can you check again? It sounds like the same thing this user reported:

Edit: To be clear this issue isn’t unique to SharpTools as it could happen with any SmartApp where a user backs out before completing the install/configuration. It is a coincidence that two users have encountered this with SharpTools recently.


I did have Sharptools and as part of my frustration at trying to fix this I went on a massive smartapp purge! I think that must have been it because it’s magically started working again!

Thank you for getting back to me so quickly. Shame that the official support team couldn’t help me out and fed me nonsense.



I’ll reach out via PM. I’m not sure I understand what you mean by an ‘incomplete’ SmartApp installation. The only way to install the SharpTools SmartApp is to go through the SmartThings (OAuth) authorization flow… and there’s no special configuration or installation beyond that. :thinking:

I’ve seen this happen a few times (rare though), for some reason the app doesn’t complete it’s lifecycle while installing and it shows up at the bottom of the SmartApps list under a section called Incomplete. The only solution I found is to delete the app and then reinstall it.