Smart Apps disappeared


My Smartapps in the mobile app have disappeared and it now displays the add new smartapp page instead.

Tried re-installing the app but still the same (IOS 14.2 in case that matters)

As anyone experienced the same ? I have logged a call with support but not holding my breath on a reply.


All your devices and hub still show? Do you have a pi-hole?


Yes all devices and hub still show ok ? Whats a PI-hole?

Also tried on my other halfs phone by logging out of her account and logging into mine and I get the same results… yet her account works fine on her setup…so I guess its my account or something in it.

tagging @Brad_ST

Could it be a depreciated app ? I’ve just seen some post re the NST manager I still have installed and I noticed in the logs some references to failed calls for NST Manager.

I still use NST Manager. It is possible it is a custom app that is the cause but does not mean it is NST Manager.

I have an idea which one it might be but it wont let me delete it as it says its installed by one or more users…

When Ive seen that before Ive usually been able to delete from the location /smartapps tab in the ide , but this app isnt even listed there so Im stuck…?

ST support should be able to remove it.

Depending on the smartapp, you may need to remove any associated devices first, then any device handlers and finished by removing the smartapp.

Managed to finally deleted the smartapp (Grovestreams) that I thought it might be … but nope thats not it.

Found a couple of Nest devices that wouldn’t respond (Nest Weather and Nest Presence ) so deleted those as I don tuse them but no change I still cannot access my Smart Apps from the mobile app.

This is now a pain as I need to make changes.

As anyone else seen the same behaviour ?


Update on this one.

I managed to fix it myself after finding the plugin smartapp from Sharptools had not completed its setup and was hanging the loading of the Smartapps but only in IOS … in android the ST app worked.

I had been looking at another dashboard solution as ActionTiles does not appear to being updated and is quite basic and lacking the ability to do more. So I looked st Sharptools (among others) and found Sharptools wasn’t very good either …very old school … but in testing I’d left in the plugin to ST that caused the issue.

So my SmartApp may be fixed but my search for a fully featured dashboard continues.

Tagging @625alex @joshua_lyon

1 Like

Can you clarify what you mean by it hadn’t completed it’s setup?

Thanks for the feedback. Are there specific features you’re looking for or specific things you feel are ‘old school’?

Just to confirm, were you using the SharpTools for Android app which is focused on Tasker plugins and Widgets (eg. a utility / not pretty)? If you’re looking for a visual dashboard and Rule Engine, check out the web based

1 Like

Hi Josh

No I wasn’t using Android I was using windows laptop to access Sharptools , but my ActionTiles dashboard is displayed on an Android tablet which is how I was able to run the ST app in Android and find the issue.

I liked Sharptools from the ease of use but the feeling /look was standard square or rectangular boxes , and is very similar to ActionTiles capabilities. I was looking for some thing where I can add in gauges or line graphs to display the temperature output from sensors or power meters. And the ability to change shape of tiles maybe?

Also I had problems with the media tiles which I couldn’t get to work … I was using a web server on my local lan that works fine from any browser and also when adding a media tile … after clicking new and selecting media (added new media) the new option added was now out of view and the options box not scrollable. see attached image

These could be me not using it correctly , but if the look and feel was more flexible , and could include content such as I have from Grovestreams see attached grove 2 grove1

But in general really good tool and if I wasn’t already using ActionTiles I would have selected Sharptools .

Thanks Andy

1 Like

ActionTiles is updated regularly. Please contact ActionTiles support for any questions.

I’ve had a similar issue. I haven’t needed to modify anything in my Smart Lighting automations since being forced to move to the new app. I couldn’t find it anywhere. Smartapps was empty.

I’m posting for info for anyone else as a possible resolution if you have the same issue.

I decided to try to re-add Smart Lighting and lo and behold there were all my existing automations. Great, I thought, but on clicking done, Smartapps was again empty. No matter what I tried, I could not get the app to stick. I could make changes to the automations and they worked, but the new app would not keep the app listed.

Having read this thread, and the comment about spaces in smartapps, I looked in the IDE and there was a smartapp in the list at /installedSmartApp/list that was completely blank and with a state showing ‘INCOMPLETE’. No other details. I deleted it and refreshed the iOS app view and bingo, it worked.

TL;DR - rogue blank null smartapp in /installedSmartApp/list stopped iOS app from showing anything in SmartApps - deleting this solved the issue