New phone, installed app, lost connection to my hub on both phones


(Mike Tyner) #1

Very happy with ST Classic on my Samsung phone.

Needed a new phone.

Installed ST Classic app on my new Samsung phone.

Logged in using my Samsung account, as usual.

Location is “Home” as before but no devices no routines no automations.

Logged in using my OLD phone, no devices no routines no automations.

I’d rebuild everything but I can’t get access to my devices.

Help. I know this has happened before.


(jkp) #2

login to IDE at https://account.smartthings.com and click on my locations and see if you have two …

  1. If you have multiple Locations, select the invalid one
  2. Make sure there is no Hub associated to it
  3. Scroll to the right and click Edit
  4. If the Default Location shows “true” (will be read only)
  5. If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  6. Now you can edit/delete the additional Home location as it will automatically be set to “false”.

(Mike Tyner) #3

I didn’t have two locations On the phone app I didn’t have any.

But I found a notice recommending I switch to the new Smart Things app.

I installed it and everything showed up. Installed it on the other phone and that one’s ok too, automations and webcore.

I don’t find much wrong with the new ST app but I just started using it.

At any rate thanks for you answer.


(Sully) #4

So this has popped up a few times recently. @jkp Will setting the current hub location as default now prevent this from happening? Or is it already set, and this just happens randomly as a part of the migration process?


(Chuck Tipton) #5

McKulty:

Excellent diagnosis and read out. EXACTLY what happened to me with a new Android phone. I went to my home PC and signed into the Samsung account, and sure enough there were two accounts. Make the old account, that has all the devices in it set to true, save it, then delete the blank account. All works well on both of my phones. Thanks for your help.