Converted to Samsung Account - Have a duplicate, but empty location i can't delete


(Ethomasii) #1

I migrated this morning to the Samsung Account in the Classic app on Android.

Background - 2 locations. 1 called Home, 1 called Lake.

It quickly migrated but then I couldn’t find ANY devices in my ‘Home’ except for one single presence sensor (my phone) and the image updated to a galaxy. The ‘Lake’ device looks just fine.

Panicked, i closed the app. When I restarted it told me it was migrating my account… i thought it had just done that? This time around it took much longer, and when it finished it landed me back in this new ‘Home’ with no devices and a galaxy icon. I tap the hamburger and pull up my locations… my old location is back, so now i have TWO ‘Home’ locations. Fortunately, my old location appears to have all the devices.

I try to delete the new ‘Home’. I get 'Something went wrong. We are unable to remove your location. Please try again later." I delete my phone presence sensor so there is no devices at all. Still will not delete.

I am stuck with a useless additional location in Smartthings now. Any advice?


2 Default Locations
(www.rboyapps.com - Make your home your butler!) #2

Yes that’s a known issue with the ST migration. Try this, set your second location as the “default” from the IDE and then try to delete it. If it still gives the error you’ll need to contact ST support to have it removed from the backend. Or you can just ignore it.


#3

I do not see a setting for default. How does one do that in the IDE?


(www.rboyapps.com - Make your home your butler!) #4

Click on the location. Click edit, change the name and click set default.


(jkp) #5

In order to delete a Home Location that has nothing in it:

  • Login to IDE at https://account.smartthings.com
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

#6

Thanks,

I was missing the default true/false bcause of the color scheme If it had been a snake.


#7

@jkp I’ve tried every which way you said to do and the location i want to delete just reverts back to true even after i change the real location to true and update it. Any other tips i can try? I’ve been trying to delete this location for the longest that i created by mistake last year.


(jkp) #8

Contact ST support at https://support.smartthings.com


#10

Thanks I will do that


(Ben Dixon) #11

This thread resolved my identical issue. Thanks @RBoy


(Bill Culbertson) #12

Me too. My original defalt location is set to true but the new one that just appeared the other day (no hub) is also set to true and they are both grayed out so there is no option to change it. Can’t delete it either. I did notice that they are on different shards. Maybe that’s why I have 2 default locations.
Also my Smart Lighting stopped working and I mean like all my lighting automations. And another thing is I am not able to install webCoRE or any other smart app fron github. the apps show up as published but are not on the mobile app. Not iphone or android.


#13

Contact support. They can delete the empty one for you.