New App geofencing unreliable

Hi everyone. I’m new to Smartthings and am currently using the new app. I’m finding the app geofencing to be incredibly sub-par and hoping there’s something else I can do to make it check more often.

As of right now I have my battery saver disabled and turned off battery optimization for the Smartthings app. My location settings are maximum wifi+data accuracy.

My issue is that I’m wanting to run simple automations when I arrive home. I’ve tested this over the past several days and 9/10 times I’ll be inside my house already before Smartthings realizes I’ve entered my geofenced area. This is so bad that I’ve extended the radius of my home location to 1600 meters and still had this happen. 1600 meters is simply not feasible area because my entire town will be considered Home and interfere with future automations.

I occasionally see a notification from Smartthings saying getting location info but I’m starting to think that the app isn’t checking location often enough for this to be reliable for me even remotely. I do not think this is an issue with my device location/battery settings as I’ve read several articles to make sure the app runs in the background. I’ve also had much better luck with other geofencing applications

If there’s any insight as to how I can make this even remotely reliable please assist.

EDIT: I’m running an android Q device

There are many other experiencing issues with presence…

I had the same problem, i switched to life 360 and it fires perfectly.

I tried life360 and it works scary well. Immediately after I enter my geofenced area my automations happen. I hate having to have a 3rd party app running in the background and would much rather just use Smartthings but I suppose I have no choice.

Just an FYI for users reading this thread… Life360 can only be installed from the Classic app which is being retired on Oct. 14, 2020. So after that date, Life360 can no longer be installed unless ST/Life360 opts to add it to the new app.

It can also be added in the IDE. Just go to the My SmartApps tab, click the New SmartApp button, and then the From Template button. Life360 (Connect) is in the list of apps here. Just select it, click Create, Publish, and For Me. Once added, you can now activate it in the SmartThings app in the Add SmartApp menu.

A number of other helpful SmartApps can be found in the Templates section as well.

Edit: Just changed the original link so that people who aren’t on the US east server will get the right server. Thanks jkp for the heads up.

2 Likes

Thanks Derakkon
Just added
Followed the steps you mentioned

You posted an incorrect link to IDE to direct users to. Users should be using https://account.SmartThings.com because not everyone will be on the specific one you posted.

1 Like

I know this thread is kinda dead but it someone finds this and is looking for geofencing, I posted this on a newer thread about setting up geofencing on multiple devices (Samsung devices + Bixby Routines)