I’m back automation

Hi.I’m kind of noob here at the community but being SmartThings user for last 5 years.Last couple of weeks I’m having issue with my “I’m back” automation.Only two phones are tracked by SmartThings (my wife’s and mine) and everything worked as it supposed to (unlock the door and disarm security) when either my wife or myself come back home.All the sudden ,if either of us leaves house (and the other one is still home)and as soon it gets out of preset range around the house,I’m back automation turns on (my guess that it checks both of our locations and because one of us is home it just performs it).This wouldn’t be a big deal but sometimes my wife is working in the basement and I lock the door after leaving house only to get unlocked 2 minutes later so it’s kind of annoying.I’m back is set to run if any of the two phones are back home after being 10 minutes away.Not sure if that’s proper way but that worked after I switched from classic app(which was 10x better IMO).Any help is appreciated.And sorry if it’s already answering but I couldn’t find it.Thanks

Hey there! @littleminer, Welcome to the Community! :slight_smile:

I’d be happy to assist with troubleshooting your mobile presence concerns, my first question would be concerning your Automation setup.

Do you have your automation set to ‘When All Conditions are met’ (Both phones being present after being away from your location) for your “I’m Back” Automation?

These steps are not guaranteed fixes. There are many variables outside of SmartThings’ control that affect mobile presence including Wi-Fi and cellular connectivity, mobile devices’ native capabilities and battery/data allocation, electromagnetic fields, and other innumerable factors. Results may vary by person, by phone, and by area.

  1. Enable Location Services to the Highest level of accuracy for Andriod/IOS.

Android: Open Settings > Touch Security & Location (You can search “Location”) > Touch Location>Touch App-level permissions >Find SmartThings and toggle to ON

iOS: Open Settings> Touch Privacy > Touch Location Services > Touch SmartThings > Set to Always.

  1. Log out of the Samsung account on the mobile device and log in again:

Android: Home screen, touch Menu (Menu icon) > Touch More options (More Options icon) > Touch Remove account.

iOS: Home screen, touch Menu (Menu icon) >Touch the account username>Touch Sign out>

  1. Check Geolocation settings and reset them.
    Home screen > Touch More options (More Options icon) > Manage location > Touch Geolocation. Press and drag the pin to the correct physical location and then save.

  2. Ensure only one mobile device is logged into the same Samsung account – each mobile presence device must have a unique user.

  3. Ensure there are no battery-saving/limiting apps, software, or settings active on the phone.

For iOS users, confirm Background App refresh is enabled in the phone’s native settings
Open Settings > Touch General > Touch Background App Refresh > Toggle SmartThings to ON.

If the symptom persists, I would recommend creating a Support ticket so we can look into your concerns further.

You can reach out directly to a support team in your area using the below information:
US: 1-866-813-2404
US: support@smartthings.com
UK: support@smartthings.co.uk

As a last resort, delete and reconfigure the mobile presence device.

I hope this message finds you well!