Network or server error when doing custom automations

I wrote Samsung SmartThings Support yesterday morning… crickets. So I figured I’d test the waters here

I’ve moved over from Wink so I’m pretty familiar with smart devices. There are some things I like and some things I don’t about SmartThings vs Wink. Overrall I’m happy and it’s doing things as I’d like and expect.

I have somewhere between 20 and 30 custom automations set up ranging from turning a few lights on around the house at sunset to daily turn off in case lights are left on to doors opening triggering lights at night to motion sensors turning on nightlights for bathroom visits in the middle of the night.

One thing that annoyed me a bit was that SmartThings isn’t compatible with Chamberlain garage doors. Or vice versa. Either way, on Wink I was able to set it up so that when the garage door was opened, it turned on garage lights (aside from the one you get integral with the door opener) as well as lights in the driveway. I figured I would solve that with a motion sensor.

Bought an actual SmartThings motion sensor (all of the others I have are Go Control) and added the sensor. It sees motion when it should and all works as expected. However, since probably Wednesday I’ve been trying to add a custom automation to turn on the garage and driveway lights when it sees motion and I get a network or server error please try again later.

I thought maybe I added the wrong SmartThings motion sensor so I tried sample automations with other devices and rules and they didn’t work either. I’ve tried an automation to send an alert when a door is opened and got an error. I tried to turn a light on at a certain time during the day and got the error. Thinking the motion sensor was wrong and I screwed EVERYTHING up by adding the wrong motion sensor, I deleted it to no avail; same error.

At this point I tried force closing the app. I tried rebooting the phone. I tried rebooting the hub. I tried from my wife’s phone (I have a Samsung S7 and she has an iphone x).

Now, I was able to accomplish what I wanted with the built-in smart lighting automation. However, I think it’s conflicting with another automation that I have set up to turn the lights on when the door from the house opens or closes. So I’d like to get in and do the custom automation with (what I think are) more options.

I’m able to edit existing automations and it saves. I can also see all of my devices and control them and other automations continue to work so I doubt there is truly a network or server error

I thought maybe I reached a limit so I deleted an automation but that didn’t help either. I wasn’t even able to add that one back!

It’s not a HUGE deal to me to deal with the quirkiness with the garage lights and the motion sensor but I want to edit and existing automation that I have for door contacts in the middle of the night to set off a siren (have a sneaky 15 year old daughter) as well as to turn on the Arlo cameras. I have the cameras turned to off but with motion sensing on. So I want the automation to turn the cameras on but I want to do another custom automation to ensure the cameras are turned back off daily so I’m not killing battery with the motion sensing! So that’s a little more urgent for me at this point.

Sorry for the long post but hopefully there’s enough information here for someone to recognize a problem or lead me to my promised land.

You can add your MyQ garage door to ST through a 3rd party app :slight_smile:

1 Like

can you post a screenshot of a custom automation you are trying to add and then a screenshot of the error message?

Are your devices that you are trying to use in custom automations showing as available/online in the devices list?

2 Likes

oh, the best method for contacting ST support is by Phone :slight_smile:

2 Likes

Thanks for the myq 3rd party link.

Here are a bunch of screenshots just to send a notification if the dining room slider is open!

I tried to attach all screenshots but it says as a new user I’m limited to one. I’ll try multiple posts…

I had a lengthy back and forth email conversation with support. Removed the app, added it back, cleared my cache, repaired the z-wave, checked version of app and nothing worked. Nothing. They said they would get back to me and didn’t. I finally got fed up yesterday and wasn’t feeling great so I sat on the couch deleting and resetting the hub and starting from scratch. Spent hours! Previously I had 32 or 34 automations before I had a problem now I got about 10 or 12 in. I’m going to call them tomorrow and if they can’t fix it, I’ll be returning this POS. Reminds me of the frustrations with wink back a few years ago. I’ll just go back to wink, at least I won’t expect problems to be fixed

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.