Netatmo Fails Since Meltdown


(Eric) #1

Since support will take days to respond, anyone else seeing their Netatmo link gone? I get invalid URL when I try to reset it up since the database meltdown yesterday. Trying to figure out if its widespread issue with other Netatmo integrations.

I also had to completely re-do my Hue integration too as all data was lost on that one.


Netatmo for UK users (Temp workaround)
(tobfaced) #2

You’re not alone, my Netatmo integration is inoperable and the “Netatmo (connect)” smart app throws the same Invalid URL message.


(Scott Shell) #3

Yep… seems to have stopped functioning yesterday morning and has not reported anything since about 11 AM and is reporting an “invalid URL” when trying to reconnect.

I know that there has been some platform problems in the last day so I guess it isn’t surprising that it isn’t working.


(Rudi Prunzel) #4

Yep, same issue here. Looks like the “Netatmo (Connect)” smartapp is not able to connect to the Netatmo web API. It’s reporting a HTTP “Bad Request”. It could be related to the “Aplication State” issue that happened yesterday .

f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎39‎ ‎AM: debug State: [:]
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎39‎ ‎AM: debug getChildDevices(false), children=3
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎39‎ ‎AM: debug Error: groovyx.net.http.HttpResponseException: Bad Request
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎39‎ ‎AM: debug In refreshToken
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎39‎ ‎AM: debug apiGet: Call failed groovyx.net.http.HttpResponseException: Forbidden
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎38‎ ‎AM: debug Error: groovyx.net.http.HttpResponseException: Bad Request
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎38‎ ‎AM: debug In refreshToken
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎38‎ ‎AM: debug In getDeviceList
f36e2e4b-de4b-457d-b898-9cbac5b3c5cd ‎11‎:‎59‎:‎38‎ ‎AM: debug In Poll


(Eric) #5

Well, that’s the thing. Since its “all resolved” now, but perhaps we lost all the old data…I get that. So I want to re-enter my credentials and restore my “state” if thats how they save it.

Something deeper happened here in the platform for sure.

@slagle said to send into support any marketplace apps that have problems. Since this is marketplace IIRC, I will submit a support ticket.


(Rudi Prunzel) #6

Just FYI, I did open a Support ticket (#241502) and this was the response that I’ve received:

SmartThings Support] Support request #241502: Neatatmo (Connect) smartapp not updating/connecting
Sorry to hear you’re having issues. I appreciate you providing the live logs. It looks like you currently don’t have any devices selected under the Netatmo (Connect) SmartApp. I’d like to select the devices and attempt once more. If that fails, please uninstall and reinstall the SmartApp. Please keep me updated as I want to ensure this resolved.

And this was my response:

Of course I had 3 devices selected and it was working fine until yesterday morning around 9am PST, and I haven’t changed anything before or after that.
I’ve already tried to run the Netatmo (Connect) smart app again and it’s failing on the first page (Connect to Netatmo) and it’s returning an XML page (with the error=invalid_token), so I can’t even get to the next page to select the Devices!!!
It looks like whatever you guys did yesterday morning also removed the Application State for this smartapp where the Token is stored!!!

Is this a supported SmartApp? If this is the case could you please fix the issue?

Note – To uninstall and reinstall the SmartApp I’ve have to remove the 3 child devices correct? If that is the case it means that I’ll have to change about 10 rules/smartapps that use those devices before I can remove them and this is not so simple!!!

Like always, the experience with ST Support is very frustrating.
Hey Guys (@slagle / @Aaron ), is this what you guys expect from support?


(Scott Shell) #7

I already had an open ticket and also reported that there is a problem with My Netatmo Connect in an email response to them today… hopefully I don’t get a similar response.


(Aaron S) #8

We are investigating - update coming soon. Thanks for the patience.


#9

Anyone have their netatmo working again? I’m still having this issue.


(Brian) #10

I have the same problem.


(Eric) #11

Had to delete every device. Reinstall smart app. Reconnect. Then hit done. Wait a minute. Reconfigure app and the devices then showed.

Support said no way around it. Old info is gone and they will try to prevent this in the future.

My integration is now working again.


#12

Works for me as well


(Scott Shell) #13

Same here… not willing to do anything with the devices any more though since this is like the 2nd time I’ve had to do this with Netatmo in only a few months… makes the reintegration kind of useless I guess…


(Brian) #14

Annoying, but I will have 10 minutes to do this over the weekend.


(Brian) #15

Thanks guys that worked just got to reinstall all the connections now


(Morgan) #16

I’ve removed my devices and everything, how do i reinstall netatmo ? I can’t find it in the things or smart apps.

is it not support anymore?


(Eric) #17

Its in the marketplace under Climate options. Things marketplace IIRC.


(Scott Shell) #18

It is under Climate Control but under the SmartApps not Things (at least in the iPhone app)


(Brian) #19

I’m going to try installing a duplicate and then copy the state from the dupe and revive the non-dupe.

Experiment. I want to fix it the lazy way.


(Eric) #20

Ha! I tried that too and it would not allow me to duplicate. Which I thought odd. Only after device removal did stuff work again. Oddball.