Nest thermostat not showing up after integration

After so much excitement I linked my Nest/Google account with Smartthings no errors on either side, but I can’t see my thermostat in Smartthings. Tried removing the service and adding but didn’t work. Anyone has tried it yet?

There was no integration with Nest devices until this month

I can confirm it works now

Were you able to actually see your thermostat in Smartthings? I can go through the whole process and allow them to link, but nothing is added to my Smartthings

Yes, can see both current temp reading and setting, as well as humidity reading.

Make sure you’re adding the Nest integration from your SmartThings app, not the other way around (where you’re just giving Google access to your ST devices)

Also, you have to have your Nest account merged with your Google account.
I assume the legacy Nest account won’t work

Yep adding Nest as a service in ST. And my Nest account is already migrated to Google. When It takes me through Google prompts, it does ask specifically if I want to allow access to my thermostat as well. I choose yes and then nothing gets added. When I go back to the services in ST, I see Nest is already added, but when I tap on it a blank page in the ST app showing up.



2 Likes

That was it!

1 Like

I tried resetting and reinstalling all the apps but no luck. If anyone else found another way please let me know.

if you have a nest thermostat, did you restart it?

Yes, I held the Nest button down for 10 seconds. My whole process I removed the three apps, restarted the Nest Thermostat, after it was back up in installed SmartThings, google home, then nest. Went into SmartThings to see if anything changed and nothing for Nest thermostat was there. Not sure if it matter I do have nest temp sensors attached to my nest, I have other smart apps like Wyze, webCoRE, and Kasa. Not sure if any of this helps just trying to put as much info out as possible. My phone is an iPhone 11.

Also I’ll add when I go to linked services in SmartThings IOS app and click on google nest it opens a new window and immediately closes the window like it failed and goes back to the linked services page. If I do the same thing with the linked Kasa app/service it shows the Kasa devices. Anyone else have this issue? Anyone else on iOS?

Did you remove Nest from ST before the whole process? If not, I think that’s the only thing I did differently. So I first unlinked Nest from ST app, and then removed all the apps, and then restarted Nest, then installed the apps. This time on the last page my thermostat showed up.

And just FYI, I’m on Android.

I tried again same way you did it and still not able to add or see anything. I’m thinking it might be an iOS thing right now. I have an old kindle fire I’ll see if there’s a SmartThings app for and try that next.

1 Like

This morning I took a look at the SmartThings app and the thermostat was there. So maybe it’s just time?

1 Like

Hi guys, having trouble adding my Nest Doorbell into Smartthings.
I’m not even seeing Nest under device brands.

Did you need to do anything else to get that to show up in the Smartthings app besides what was discussed above?

what region are you in?

Im in Canada.

Possibly a region thing, I just checked my app and it’s listed under doorbell brands.

you in the U.S.A?