Need to open ports in the Firewall for Smartthings

I have a Sophos UTM firewall, and with this firewall, and by default, the incoming and outgoing connections both are blocked.
Please note, I repeat the outgoing connections are blocked as well.
After I have integrated the firewall for my home network, ST has stopped working.
When I allow all the connections from ST IP to outgoing traffic the automation works, and hub shows green led. But I would just rather open the required ports rather than opening the entire traffic to and from to this hub.
So what protocols and ports do i need to open on the firewall for ST to work?

1 Like

Gosh, this is not about blinking led. I know all that, I have been using ST for a while.
The issue is about what ports I need to open for outgoing traffic to that connects ST to ST cloud.

Would be interesting to know. Have you tried just https (443)?

From @sidjohn1’s post:

What to do: A solid blue light is expected during the normal setup process and when downloading firmware updates (in some cases). However, if the light remains solid blue for longer than 5 minutes, this indicates the Hub is unable to establish a connection with our servers. This problem can occur when outbound traffic from a local network is being blocked. Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, and 37



I have https (443) open on this vlan (IoT)

@TylerDuren, thats exactly my problem.
When i reboot the hub, the led turns green, and within mins it turns solid blue.
I am looking at the firewall logs, and it says that the traffic outgoing has been blocked.
I can just allow the traffic from this IP, but that will literally open the entire port range for that IP, which i dont want to do.
Rather grab the port numbers that ST requires and open those ports for the ST hub’s IP address.
So we dont need to allow incoming connections right? just opening the ports 11111, 9443, 443, 39500, and 37 for outgoing should be enough?

I’m just telling you what @sidjohn1’s link to the official SmartThings Support document says. You’ll have to try it and see.

This old thread may be helpful too.

HI! I’ve been having a similar problem! I had to allow ST to ping the router… on Ubiquiti, I had to allow ping to subnet gateway address in Guest_Local firewall ruleset!