Need help with Monoprice Recessed Window/Door Sensor

I previously purchased a monoprice door sensor:

It stopped working after many years of reliable use. I took it out and its CR2 battery measures less than 1V (from 3V new), so I figured it must have run out of battery.

But even with a replacement battery, I can’t get it to work again.

I can’t find its manual. I believe it is the same as aeotec recessed door sensor (Recessed door sensor for Z-Wave • Aeotec, which is either Aeotec recressed Door Sensor user guide : Aeotec Help Desk or Recessed Door Sensor 7 user guide : Aeotec Help Desk). However, its manual mentions an LED which mine does not have.

I deleted the sensor from my hub. I tried holding the button 20s. I also tried pressing the button 3 times. But I just cannot get it to added/discovered to my hub again. Do you have the same sensor that can help me with the instruction?

Let me look for my manual, I have the same door sensor. Anyway, it is not the same sensor as Zooz, even that looks the same, different internals


try excluding it first before including it.

1 Like

Usually I just swap battery and place it back. Battery last very long time (couple years)
Otherwise do exclusion first, than inclusion.

1 Like

Thank you. Looks like mine also have an LED but it is not lid. I hope it is not dead. I will check the power again.

Also, I have already deleted the sensor from my hub. Does it mean I have already “excluded” it? I don’t remember how I add the device in the first place. Do I just “scan for device” to add it? It never show up for me.

I fixed the power issue (there must be some leaks from previous battery). Now when I press the button, I see the red LED come on steady, not flashing. But I have no luck adding it so far. How do I put it in inclusion mode in the SmartThings App?

So frustrating.

From an answer in monoprice, I figured that reset the sensor requires open and close 10 times within 10 second. That seems to work and I put the LED into blinking instead of steady.

With that, I tried “Scan Nearby” multiple times to no avail. Finally, I decided to add device and specify the Aeotec Recessed Window/Door sensor and that worked! But, after it got added to my hub. It stays in Open state and will not report when I close the door!

Change DTH to any other contact sensor, it will change state to correct one, and clear cache prior to opening device details

can you elaborate on how to change DTH?

Go to, and devices from drop down menu
Than select your device, and you will have device details like this

Than select Edit, and change Type, and click on Update

1 Like

I don’t have the Monoprice Door/Window Sensor in my list. This looks like a custom DTH but I have never had to use it for the last few years. How come?

My DTH is from @RBoy. You can choose any other z-wave contact sensor, just to reset sensor’s reporting. It will show correctly after that

I tried switching to Z-Wave Plus Door/Window Sensor DTH and also a DTH I found in this thread Monoprice recessed Zwave plus door sensor - #19 by gkl_sf

It didn’t seem to work. I am beginning to think that the sensor is defective or damaged by battery. I regret I didn’t tried changing battery earlier, or clean the terminals before I delete the sensor from hub, that might also caused the problem.

Try to remove it and add it again. I had this happening to me once. it will show status correctly

Thanks for sharing the manual above! I couldn’t for the life of me find mine, and I keep all my ST papers together.

I had to remove my sensor to swap it to an Edge driver. Even though I removed the device both in the app and in the device list through the ST Hub device list, I had to Exclude it using the Smartthings app, Z-Wave Utilties - Z-Wave exclusion. Once it was searching for a Zwave device to exclude, I pressed the tamper button on the sensor for about a half a second and app showed that it had found a device to exclude.

To include, used the ST app to add a nearby device. While it was scanning for a device, again, pressed the tamper button for about a half a second, and then waited another 5-10 seconds and it showed that it was added.

If you have issues, you may need to attempted this a few times.