Need Help Pairing Ring Contact Sensor to SmartThings Hub

Twice (with two different sensors) I have tried to pair a 2nd generation Ring Contact Sensor with my 2nd generation SmartThings hub and have been unsuccessful both times. I use the SmartThings app on my iPhone. I put the sensor right next to the hub, get the green blink 3 from the sensor and the ST app says “preparing”, but after a few minutes the app tells me “something went wrong.” I have googled for help but can’t seem to find any suggestions that work.

Can somebody here tell me the secret? I am pretty sure this can be done.


1 Like

Some people have reported it’s a little tricky. See the following thread:

Ring Contact Sensor Handler?

I have them paired, no issues with DTH and now with Edge driver. I’ll get back to you on how to do it.

1 Like

Start pairing process in ST app, using Scan nearby feature under add device. Using paper clip push the pinhole reset button located in battery compartment. Release when light around test button start blinking rapidly green. After a couple of seconds Setup process will adk you for 5 digit number from QR code. Enter it. Device will be added as generic z-wave device.
You will have to go to IDE and change Device Type to Z- wave Contact sensor. With stock DTH, Tamper Alert will not work.

I have made my own DTH from template and added Tamper Alert that works fine. I have changed runLocally: true, and interestingly my self published DTH works locally. Tested without Internet.

Recently, couple days ago, I was able to add fingerprint to Edge driver and it works great. Still testing.

This sensors are made for security, never failed or never had false report, and battery last forever. I switched all my door/window sensors to this. With magnet taken out of that case, they also work on double hung windows.


Thank you both for the replies. I seem to be going thru all the steps properly but still no luck. milandjurovic71, just to be sure because no directions come with the Ring Contact Sensor, after I’ve pressed the reset button and see rapid blinking, the LED on the sensor goes into a slow green blink 3 times - pause - repeat. That means it’s in pairing mode, right? I have also done the Z-wave exclusion thing. I’ve rebooted everything. Checked for updates. BTW I do not have the ring alarm system though I do use the cameras.

You know what is really weird, is that last fall I was able to set up the same sensor from Ring without problems and it has been functioning fine ever since. I just can’t seem to add any more. It’s like Samsung or Ring doesn’t want you to use this device anymore!

If you or anyone can offer any more help I would appreciate it.


I was re-adding sensors a couple days ago, and everything works fine. You might need to do factory reset, by holding pinhole button for 10 or 20 seconds.
PM me with your email address, and I’ll send you program manual for it

1 Like

I’ve done a video on pairing the Ring Alarm Contact Sensor. Here are the recommended steps to install:

  1. Go in to SmartThings and click on the + to add a device.
  2. Scan the QR code on the sensor
  3. Hold down the button on the sensor for 10 seconds
  4. Wait about 30 seconds and SmartThings will find the device and pair it.
  5. Give your contact sensor a preferred name and save.
  6. Sign into your SmartThings Account IDE at https//,
  7. Go to your list of Devices by navigating to tab, “My Devices”
  8. Find the contact sensor just added. Click on the device and then click on Edit at the bottom of the page.
  9. Look at the device “Type” and it should display as “Z-Wave Sensor”. This DTH works, but does not allow for full functionality. The battery level indicator is not accurate and there will not be Open/Closed options in your automations.
  10. To get better functionality from the Ring Contact Sensor change the type to “Z-wave Plus Door/Window Sensor”
  11. Now click the “Update” button to save your changes
  12. Go to the ST app, refresh or restart the app to see that the app has updated the sensor with the new handler. Go to automation and you should see all the available choices

Bud do I need to hold down the button on the sensor 10 seconds if it is already in what I think is pairing mode; i.e., blinking slowly 3 times, pause, repeat?

PM sent. Thank you.

Email sent. You might have to start with Z-wave exclusion to remove sensor properly. I would recommend to do factory reset first and then add sensors again.

You mean factory reset of sensor right? Not the hub.


Thank You milandjurovic71. Can you please confirm that the sensor is in pairing mode when the green LED flashes slowly 3 times then pause then repeat?

Have app in scan nearby mode. When is flashing 3x slowly, press the front button for a second or two, and release. It will start flashing green fast. After second or two, app will notify you for secure setup, where you can enter 5 digit code or scan QR code. I just tested. It works
Factory reset sensor by pressing pinhole button for approximately 20 seconds. Light will flash red, and go back to 3x green slow flashes


milandjurovic71 that was it! The instructions you gave worked perfectly! Note that your instructions/process were a bit different than what I have tried and been suggested to do. They should be pinned to the forum. Thank you very much.

1 Like

Is the edge driver working? I tried to re-install my ring sensor and I had to go Thru the DTH method. I have all the z-wave edge drivers installed also. Maybe I don’t have the right one…TIA

I have supplied the device data and raw description for the Ring Alarm contact sensor and I am hoping that an Edge Driver will be created soon. My request is here.

1 Like

I did see your request. Hopefully one can be created before 9/30. I’d hate to have to replace 36 sensors :skull:

Yes. That would not be very convenient, for sure! :anguished:

1 Like

You can add fingerprints yourself to stock driver, and correct profile and publish it for yourself. I am not developer, but i had it done and it works. I have not created any invites yet.

1 Like

Are there any news for that Sensor. I would Like to have an Edge Driver for this device