Ring Gen 2

First I’m newish to the smartthings family. About 2 months or so now. I’m heavily investing though between HomeKit, smartthings, and homebridge.

I have the bronze colored 79$ on sale Ring doorbell generation 2 as it’s listed on the box. I have searched a little, finding a couple different articles and answers. One saying to install and change the DH type in IDE. I tried installing in Classic, and then in the new. Both times it reports that Ring doesn’t have any devices to install. So of course then there is nothing to try in the IDE side of things.

Any help on how I can get connect to smartthings would be great!

Thanks
Jace

Try using the new ST app. You don’t need a custom DTH for a Ring Doorbell (for a Ring Gen-2 Alarm Keypad you’ll need this DTH). The Ring door should integrate directly with SmartThings using their cloud to cloud integration from the new app. Click on + -> Add Device -> Search for Ring.

I did that. It asks for ring login authorization then pops up no devices found. I have tried from iPad running current iOS 13, and iPhone with beta 14 beta 7. It’s a ring doorbell 2 gen.

You would want to contact Ring directly since they control this integration

Thanks for the reply. Anyone specific or what forums or site to try and get the answer?

I know it’s not the original ring doorbell but I figured with gen 2 it still should somewhat fall under the same device.

I tried contacting ring through there community forums and they of course put it back on Samsung smartthings. Since smartthings doesn’t integrate with all ring devices they would have to do it so it could work.

I know that it’s a gen 2 2020 model but It is the basic model. I didn’t think it would be hard to use the ring bell original handler, but I definitely don’t know any of that back end stuff.

Anyone from the integration teams could you please consider adding the regular ring doorbell Gen 2? Would be great!

Originally, companies sent physical devices to smartthings, and smartthings wrote the code for the integration. That’s how the original ring integration was done.

However, as of 2019, smartthings published their API and it is now the responsibility of the individual device manufacturers to create and maintain their integration, if they choose to do so. Smartthings no longer does that coding.

This leaves some of the legacy integrations like ring and Lutron in limbo, with the device manufacturer saying smartthings has to update it (since it was originally smartthings that wrote the integration code) and smartthings saying that the device manufacturer now has the responsibility for the integration (which is true, because smartthings changed the way they do integrations last year.)

So there isn’t anyone at smartthings who does these integrations anymore. :disappointed_relieved: All we as customers can do is keep asking the device manufacturers of the devices that we are interested in to create a SmartThings integration. Some will, some won’t. But the more people who ask, the more likely they are to eventually do it.

This forum was established a number of years ago so that smartthings customers could help other customers. It’s not an official support channel.

If you do want to try to get some official smartthings attention, you can try their Facebook or Twitter. But they are likely to just tell you that it’s up to the device manufacturer now.

I have the same issue. When you go to add it to ST it doesn’t see any compatible devices and fails. My solution was to add it to Alexa and use the Alexa ST things skill. It isn’t added to ST but at least I can use the doorbell to trigger events. I really don’t understand how so many manufacturers just decide to support only their platform, or only one or two platforms. Seems to me that the more platforms you support the more devices you will sell.

You can try still using the Ring Connect Smartapp on the ST Classic app. It takes a few tries where you get logged off but it worked for me. I did have it setup already though, so not sure as a new user if it will work. Worth a shot.

Can’t even get into cIassic anymore. I spent some time on it yesterday and discovered that on my fire tablet I could get Alexa to bring up the screen when the bell rings. This is still much better than the regular ring method of get notification, load app, wait for it to sync, answer the door. That may be one of the dumbest things I have ever seen. You simply can’t answer the door in time. The only down side of this is that the Fire tablet cannot do 2 way audio with the doorbell, Fortunately I have an echo dot nearby and have and Alexa routine that turns that on as well.

I noticed you replied a while back that you tried it a couple times in the classic app to get the doorbell to install. I have tried almost daily with no luck. Are you sure you have the 2020 version ring doorbell gen 2? It’s not the ring doorbell 2, but the original gen 2.
Thanks

I have the original g2, a doorbell 2 and a pro. Since the time I responded and the app change I deleted all ring devices. I then went back in and added them through the new app. Device by brand. They all connected with the motion sensor and the ability to do live view through ST.

A couple of other changes I made which fixed some issues.

  1. Moved my hub away from my router. This fixed some discovery issues.
  2. Went into Alexa and removed the ST skill and deleted all the devices in alexa. I had dups due to the apps. The alexa web interface lets you clean everything up easily.

Hope this helps

I am having the same problem, it say that the only compatible Ring is Ring 3.