Ring ZWave outdoor contact sensor missing controls

I obtained a RING OUTDOOR CONTACT SENSOR and have added it to my V2 hub. After adding it to the hub, I went to the IDE and updated the type to Z-Wave Plus Door/Window Sensor. That got the battery to update and I can see when the device contact sensor open and closes in the app.

Now, when I went to setup an alert on the open/closed the contact sensor is not there in automation.

Some threads I see mention changing the handler in the IDE, But I do not see that as an option for me.

Any help with this?

Anyone help?!!??

I would delete the device and start over.

1st add @milandjurovic71 “Z-Wave sensor Ring” Edge Driver and then try to re-pair the sensor using the new Edge Drivers. Do not change anything in the IDE after you re-pair it. It should show up as Placeholder in the IDE which is what you want to see.

Is there something I have to do to the hub so I can load EDGE drivers?

You should be able to click on the attached link and load the driver.

It works well with v2, v3 and Aeotec hubs. Some people with WiFi hub have problems.

I am having this same issue but when I click on Milan’s driver invite and I click “accept” I keep getting a message saying “There was an internal server error.” I’m pretty new to this, am I doing something wrong?

It sounds like you are doing the correct things.

What model hub do you have?

It’s an Aeotec hub

Steps: Click on link > sign in account > click on enroll > click on available drivers > install the driver you want

I have seen other posts today with the same problem. Could be an ST problem. You might want to report to customer service.

1 Like

I am assuming this is Gen2 sensor. I’ll add it tomorrow. Working on adding settings for Ring drivers.
I’ll have something in day or two.
I have added settings for contact sensor only, however current driver needs to be reloaded, by changing driver to any other, and chaning it back to Ring driver.

1 Like

@KevinHittle can you please load my driver and let me know if works.

J install your driver on Ring contact sensor outdoor. today. It don’t working.

Sorry, I was away from home for some time. Can you please try again.
We’ll make it work