Need help from Samsung Smartthings Support -- Device is GE ZW4203 Plug-in Socket

Life was wonderful with the Groovy DTH. The device worked flawlessly for months.

In my journey to Edge Devices, I moved this device to the GE Z-Wave Switch/Dimmer/Fan/Outlet from @philh30. This driver worked well for some of my other devices.

However, it’s not working for the GE ZW4203. As I described in another thread, I get a spinning disk followed by a network/server error message if I try to control the device from the SmartThings UI. Controlling from the device works fine.

Ok, so it’s too early to jump off the Groovy dinghy. But now I am stuck. There is NO was to revert that driver to the DTH as I am using Phil’s driver for other devices.

What’s the prognosis on a resolution?



Have you tried a Zwave repair? If not, give it a try.

This forum was set up a number of years ago so that customers could help other customers. It’s not officially monitored by smartthings employees except for a few of the developer sections.

To get help from support, you need to contact one of the official support channels. See the bottom of the following page:

The first person you get will probably just be a Samsung employee reading off a script, but if you hang in there, eventually it will get escalated to the smartthings technical team.

Thank you. Didn’t mean to vent … but I guess I did?

Yes, I did Z-wave repair several times. No luck.

I didn’t read it as venting, just wanted to make sure you knew that Samsung support isn’t reading these posts.

1 Like