Problem with smartthings outlet


(Scott Chapman) #1

Just purchased a smartthings outlet (z-wave) and I got it paired and set up but it doesn’t appear to be functioning at all.

It is super close to the hub (like 10 feet) but I don’t seem to be able to trigger it from the app, and it doesn’t ever show any events or anything.

I’ve tried removing it and setting it up again (holding button on it to clear it out), and it seems to get recognized but otherwise doesn’t work at all.

I’ve also rebooted hub, and I’ve tried doing a z-wave network repair. What is interesting is when the repair happens I can see some events in the hub’s log where it looks like there are failures to repair other z-wave IDs (this is my only z-wave device). Not sure if removing and re-adding it created any problems but it is just not working at all for me…

Any advice?


(Jason) #2

it’s zigbee so the zwave utility will have no effect. You would need to unplug the hub with batteries pulled out wait at least 15 min then plug everything back in if you wish to rebuild the zigbee mesh that can up to 24 hours to rebuild

Have you contacting support, opened up a ticket?

Have you tried doing a factory reset on it, removing it from the app/ide then adding it back in?


(Scott Chapman) #3

wait, it’s zigbee? Really? sigh I have opened up a ticket.

It is a really new device (just started setting up a couple of weeks ago). I can certainly try to unplug and remove batteries and see if it is any better in 24 hours.

Yes, I have tried removing from ide (no apps installed for it yet, just trying to get it to work manually)


(Scott Chapman) #4

No, can’t be zigbee. Device shows up on the hub as z-wave device…


(Eric) #5

well the device has a label with some protocol icon, and a model#. What are the specific identifications?

The device (not hub) reset procedures vary by device and protocol. You should not have to reset the hub.


(Scott Chapman) #6

Yep it says z-wave plus (of course the samsung site does say it is zigbee). I am going to assume it is z-wave since all indications are that’s what it is.

There are instructions for “connecting it if you have problems”. Followed them with out any success. It is paired and at least initially seen by my hub, but does work and the hub doesn’t appear to be able to get status or anything from it.


(Jason) #7

Sorry, as far as I know the Smartthings device only extended Zigbee, I know that the Iris branded gen 2 plug has zigbee and zwave. can you post a pic of the device?


(Scott Chapman) #8

It actually does have Iris logo on back too… Pictures look exactly like what is on their website. Backside looks like:


(Edward Pope) #9

That is the IRIS smartplug not a Smart Things device.

Here are the basics for it from a link on the forum. This may help you with getting it to work with ST.


(Scott Chapman) #10

No, seriously it came brand new sealed in a samsung smartthings outlet box. instructions that came with it have completely different setup instructions (which obviously don’t really work)

Here is what I ordered (and received): http://www.amazon.com/gp/product/B00MI5V5N6


(Edward Pope) #11

Someone replaced or exchanged it then, you can see that it is an IRIS from the information you presented in the pic. I assume that someone returned it, and they just re-shrink wrapped it and sold it as new. Not unheard of in the stores.


(Edward Pope) #12

Also, if you look at the picture at the back of that device you will see that it has completely different markings.


(Scott Chapman) #13

Aw man! Before I return this one, is it actually better?? Seems like having a z-wave repeater with zigbee plug is a pretty nifty trick…


(Edward Pope) #14

If you get it to work with the information from the community, I would keep it. I suspect that it may have to be reset since someone likely tried it with their system.


(Bernie H) #15

The Iris 2nd gen smart plug is Zigbee for the outlet and has a Zwave repeater so it can be paired as two devices. The repeater pairs as a switch I believe. Both parts pair and reset differently. A google search should bring up the right way to do both. I’m cooking dinner right now or would do the leg work.


(Michael Hess) #16

I prefer my Iris for power monitoring, it updates more reliably than the ST one for me.

Reset it by holding the button while plugging back in, for the ZigBee portion. Install the Iris device type FIRST, then try to pair it again via the app.

The Z-Wave repeater can be reset by tapping the button 8 times FAST, the light should not flicker on or off until the last tap, then re-pair to make sure it’s connected right. I had to do it 2-3 times, will show as generic z-wave repeater with on/off that doesn’t do anything.


(Scott Chapman) #17

Oh, I pressed it twice to get it to flash and it paired as a z-wave device. Do I need to do it again to get it to be recognized as a repeater?


(Michael Hess) #18

No, if it’s already there, don’t mess with it. Resetting zigbee won’t affect z-wave.


(Scott Chapman) #19

I meant resetting the z-wave part (8 quick presses). Right now it appears as a z-wave device not specifically a z-wave repeater. Is that a problem?


(Michael Hess) #20

Yeah mine just says Z-Wave Device now that I look at it. I have no idea how to tell if it’s repeating anything anyway so can’t say if that’s a problem or not. It’s not hurt my network so I just ignore that device.