Myq Smartapp won't work on garage

Hi,
My smartthings classic has been opening and closing garage door fine for months but now the smartthings app won’t operate the door. Just says “closing” or “Opening” but door does not move.
I tried stepping through the smartapp and it gives me a username or password error. But I loaded the MyQ app it does work the door although I go get an error. The garage door sensor reports correctly.

Does this have something to do with the Chamberlin side? Is there a way to get this working?

…AR

MyQ changed their API recently. You need to update the MyQ app and device handler in ST. Then update the device. Details and instructions can be found in the MyQ thread…

2 Likes

Thank you, I will give it a try.

Sir-
I updated the MyQ Smartapp but I have a problem that probably isn’t related to needing an update as this happened before I updated. I cannot put my username and password into the app anymore. I removed the SmartApp and I am attempting to add it back in and username or password error occurs. I worked with Chamberlin support to be sure I could log into their MyQ website okay, which I can. But the app is acting like the credentials are wrong. I am currently not at home on my network, can that be an issue? I am remote.
?? This all worked before.

Best if you post in the thread I posted above. That way the developer of the app will see your post and assist with getting it working for you :slight_smile:

Did you update both the smartapp and the device handler? The new app now shows the current versions for what is installed.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.