My ST hub does not detect new qubino devices despite be working with several ones

I have a ST hub working for more than one year now with 5 Qubino (1D Relay, and Flush shutter) devices.
I bough 2 more qubino devices (one 1D Relay and one Flush Shutter ) and now cannot make the hub detect them, despite the old ones keep working fine.
Both devices are working fine because I tested them with other hub. Naturally, I’ve tried everything, from factory reset, exclude them using other hub, etc. But no success at all.
Does anyone has an idea about what can be done?

  1. general device exclusion then try to add
  2. run z-wave repair
  3. ok, will sound strange - if using custom device handlers, go into IDE, open each, save and publish them again

Thank you jkp

I already tried general exclusion, and then add them again. I also tried to make the z-wave repair.
I’m using custom device handlers with the devices that are working ok. The problem is that the ST doesn’t see the new ones that I’m trying to pair.
Visualising the log on the IDE nothing is detected. Anyway, I will try to save and publish the Handlers again.

c66eaa6a-b33e-4d25-81f8-7755e72f9912 9:56:20 AM: debug detecting status for 4c0313b1-2a96-42ef-a909-72744b1b4017 : true
c66eaa6a-b33e-4d25-81f8-7755e72f9912 9:56:20 AM: trace in ssdpDiscover
c66eaa6a-b33e-4d25-81f8-7755e72f9912 9:56:20 AM: debug scheduled run, numberOfRuns: 4
c66eaa6a-b33e-4d25-81f8-7755e72f9912 9:56:20 AM: trace in discovery
c66eaa6a-b33e-4d25-81f8-7755e72f9912 9:56:13 AM: debug No devices to add, verified devices: [:]

I understand what you are saying. To note: I have seen this issue (same issue, different devices) about 10 times in the past few days. the recommendation of saving/publishing existing DTHs being used has resolved their ability to add devices.

@Automated_House also posted the same advice in your other post

hi and thanks
i tried to save/publish all the related DH, but no success. I managed to include a device from another vendor but not a qubino. i tried the same new flush shutter i had, and a new 1 D relay.