My Samsung Air conditioner with SmartThings wifi control no longer interfaces with google home

Now that summer is back in full power I decided to turn on my Samsung AC. Something happened over winter that the AC no longer seems to interface with google home at all.

I can still turn it on in the SmartThings app on my phone but in Google home it shows up as a gray screen.

When I try voice control Google Assistant “turn on the air conditioner in the bedroom” the reply is “that mode isn’t available for the room A/C”. Apparently Google can’t control anything about the Samsung AC anymore.

What’s killing me is that now my routines are broken (leaving home, returning etc.).

Has anyone run into this?

1 Like

You may need to be using the new V3 app. They’ve said that they are going to discontinue the V2 classic app, although they haven’t said when, but they’ve moved pretty much all of the support for Samsung brand smart televisions, vacuums, air-conditioners, etc. to the new app.

You can use both apps at the same time, but you probably won’t be able to use the Samsung brand devices in the old app anymore.

FAQ: how to tell which version of the SmartThings mobile app that you have

I have the same issue. Google assistant integration worked great using the samsung smarthome app (On, Off, mode change, temp change all worked)

New smarthing app (latest android release) and now “that mode is not supported on room AC” when I try to turn it on with google assistant.

Hi there. May I join the question, even if I‘m a newbie here?
I‘ve just installed my new Windfree A/C. The devices are visible and controllable in Samsung Smartthings app(same screenshop as in TS post). Now I wanted to integrate them in Google Home (to control with Google Home mini with voice). The coupling was done and my A/Cs become visible Google Home app, but I can‘t do anything there and also no status is seen.
Is it problem with Google or Samsung?

UPD. I found actually that there are two different connections available in Google Home App - one called Samsung Smart Home and another called Smartthings. Both connect to Samsung account when used and show air condition device, but in both cases it is not controllable.

1 Like

Hey Samsung, this is a load of crap and won’t stand!

These are extremely expensive electronics, and you can’t simply abandon their development.

When will google home integration be reintroduced?

1 Like

Last week I installed also Samsung windless AC and samsung wifi kit, but when I want to set it up on a Smart Things app it is telling me NO Indoor Unit… Tried many things and still nothing, could you tell me what model do you have and how did you linked to smart things app? My model is AC035RN1DKG, but with wired remote control and extra wifi smart kit. thanks

1 Like

As of now (Jan 2020), this seems to be the only way to get Samsung Aircon working with Google Home:

  1. In the Google Home Linked Services add “Samsung Smart Home”
  2. This is the older Samsung service, predating SmartThings
  3. With this setup your Samsung Aircons will show up in the Google Home, and you will be able to assign them to the rooms. You will be able to say “Hey Google, turn on the aircon”, and it works!
  4. However, you will be able to only turn the aircon on and off, no other controls are available (temperature, cooling mode, etc)

If instead of Samsung Smart Home you will try to link SmartThings, your Samsung aircons will not show up in Google Home. It appears that the Samsung Aricons are being filtered out explicitly on the Google side. To validate that, try the following steps:

  1. login to https://account.smartthings.com
  2. find your aricon under the devices list
  3. Click the Edit button on the bottom of the device details page
  4. Change Type from “Samsung OCF Air Conditioner” to “SAMI Samsung Air Conditioner” and hit Save (don’t worry, you’ll be able to switch it back)
  5. Now refresh Google Home
  6. Your Aircon from SmartThings will show up and you can assign it to a room. However you won’t be able to control it (all settings are grayed out)
  7. Change Type back to “Samsung OCF Air Conditioner” in SmartThings, and it will disappear from Google Home

Hopefully Google Home will start supporting “Samsung OCF Air Conditioner” soon! It seems to be so close!

2 Likes

Hey there,
For some reason, now when I changed back the type, my AC vanished :slight_smile:
I do not see it anymore not even in the ST App.
Has anyone any ideea how to solve this issue?

I have tried adding the AC back in the ST App, but I get an error telling me to move closer

Hi,

well it looks like this issue still persist.

  1. after linking my SmartThings account to Google Home I don’t see my AC device (in Google Home). SmartThings account is visible in Google Home service provider section as linked account.

  2. after linking Samsung Smart Home service to Google Home I see my AC on the Google Home list. Sadly I can just turn it on and off… there are no other controls available.

NOTE: SmartThings account will show up in Google Home only when you have a scene setup in SmartThings app.

I created a case using in build “report a problem” functionality. Will se whether Samsung will get back to me…

I also contacted SmartThings support team (support smartthings.com) but they told me they only support US users…

Yesterday I started having issues in Samsung Smart Home provider sync and Google Home were not able to turn on and off the air conditioners anymore. With SmartThings integration the airconditioners are not yet supported. I tried to unlink and re-connect the Samsung Smart Home service in Google Home app but it seems to be disappeared… Are you experiencing something similar?

1 Like

I have exactly the same problem.
I tried also to configure the air conditioner with smarthing but I can’t control with google home

same problem here… looks like it aint supported anymore? Started some days ago that my google home returned with the awnser she cant connect to the service anymore or something like that.
And when i connect samsung smartthings it doesnt see my aircos, only the tv…

Same here. Lost the Samsung Smart Home integration few days ago. And SmartThings integration still doesn’t work

There is a workaround that kind of works, but it’s ugly:

  1. Login to https://account.smartthings.com
  2. Find your aricon under the devices list
  3. Click the Edit button on the bottom of the device details page
  4. Change Type from “Samsung OCF Air Conditioner” to “Samsung OCF Air Purifier” and hit Save (don’t worry, you’ll be able to switch it back)
  5. Now refresh Google Home

The Aircon from SmartThings will show up in Google Home. You can say “Turn on the purifier” & “Turn off the purifier” to control it (still no temperature control). SmartThings app still works as well.

I really wonder where is the block that stops it from working with the “Samsung OCF Air Conditioner” device type

3 Likes

Thnx! Worked for me 2

1 Like

It works for me. I also configured mode control by IFTTT. But no temperature control :frowning:

1 Like

Everyone who has this problem, can you please contact SmartThings support here https://support.smartthings.com/hc/en-us ? (contact on the bottom) I’m hoping that with enough of us asking for a fix, someone at Samsung will look into it. I’ve sent my support request by email, and will update this thread if there is a progress. Please join me!

2 Likes

With Samsung Smart Home out IFTTT method is the last resort. Still ugly though. Dont see why they still dont support it as an air conditioner directly through ST. It used to work a long time ago

Progress! You can switch your device type back to “Samsung OCF Air Conditioner”, and it will not disappear from your Google Home anymore! Still only power control though, not temperature or any other settings. But my family can go back to saying “ok Google, turn-on the aircon”!

1 Like