My 4 Ge Light bulbs in the smartthings ap do not show the current dim state


(Kevin Baugh) #1

When I first installed me Ge light bulbs everything worked correctly
They would turn on and off when I tap on the device the dimmer would
reflect the current dim state

Now after I assume a smarthings update the ge bulbs will still
turn off and on correctly but when I tap on the device it always
shows 0% dimmed I can dim the light lets say to 25% and it dims like it should
but when I go out of the device in the smart things ap then go back in it always show 0%


(Realy Living Dream) #2

I still have a couple GE bulbs. I just went through turning on/off, setting level, turning off/ on. They all showed the proper status and dim level


(Kevin Baugh) #3

Mine do not I have removed them reset them and re added them still the same problem


(Lee Florack) #4

I have about (16) of the GE Link bulbs, but after a recent move, I’m down to (10) in actual use. They still turn on/off fine, as well as dim/brighten without issue too. However, like you, most of them no longer report their dim % like they used to. Besides being a general annoyance, this makes using capture and restore in my CoRE Pistons not work properly.

So, I wrote ST support, and I received this response:

Thanks for writing in, so sorry for the inconvenience. It may help to try resetting the device while the Hub is looking for it, so that it can re-connect good as new.

To do this, start with the bulb nearest the hub and move your Wi-Fi router as far from the Hub as the Ethernet cable will allow to lessen interference. In the app, go to the Marketplace and tap ‘Connect New Device’, then follow the reset instructions in this article (again, nice and close to the Hub):

GE Link LED Bulb

The device may not appear in the app. If it doesn’t after a few moments, try seeing if it’s responding correctly in the app, and more importantly reporting correctly in the app - if it is, go ahead and take it back where you want it. If it does appear in the app, go ahead and name the device something easy to identify, and let me know so I can work some magic on my end. Do note that the Hub can’t communicate with devices that are too far away, so I recommend trying to keep it within around 30-40ft of the Hub.

Give that a shot and let me know if you’re able to get it working!

I haven’t had the time to do this (I actually think I have done selected bulbs previously - just not all of them) so I can’t say for sure if it’ll work. We’ll see,

Lee


(Realy Living Dream) #5

I’ve had to do that several times over the years. Not in probably 6 months or so though. Lately a simple powercycle of the bulb is enough to wake it up.


(Kevin Baugh) #6

Luis (SmartThings)
Nov 17, 8:57 AM MST
Hey Kevin,
Thanks for reaching out sorry for the trouble.
Unfortunately, since the GE Bulbs are not officially compatible devices we wouldn’t be able to troubleshoot or provide support for them. However, you can always check out the community forums and see if anyone has had any luck on that custom integration.
You can post there and even reach out to the developers directly if you have any questions, they’re super friendly and always willing to help. Here’s a link to get you started: https://community.smartthings.com/search?q=ge%20link
If you have questions in the future, don’t hesitate to reach out.
Kind regards,
Luis
SmartThings Support


(Kevin Baugh) #7

Power cycles are not helping my situation


(Ricci Hoffer) #8

I noticed my GE Link bulbs are no longer showing the correct dim status on ST when adjusted by Alexa (Alexa, Ask Alexa and EchoSistant). I changed the Device Type in the IDE to ZLL Dimmer bulb from GE Link bulb and it things seem to be back to normal and updating status properly. I am pretty sure that it was working properly with Alexa using the GE Link Bulb type before.


(Lee Florack) #9

So, based on my earlier problems described in my earlier post above and the post just above from @rhoffer, I switched my (10) GE Link bulbs to use the ZLL Dimmer device type. The good news is that the dimming percentage is now updating - at least so far (short test so far). The ‘bad’ news is that the ZLL Dimmer type does not fully support slow dimming. It seems that the bulbs continue to retain the ability to slowly ramp up or down only until a relink is needed. But once the bulbs need to be relinked, ramping up or down or turning off slowly, no longer functions as it did using the GE Link Bulb device type.

So, the choice between these two device types seems to be, either having the percentages report properly or have the ability to ramp up and down properly. Since the ZLL Dimmer device type is more generic it seems that having the more specific GE Link Bulb device type work properly is the right answer. However, because it’s not a SmartThings supported device, I’m not holding my breath.

PS: So, if you want both ramping up/down and proper % feedback, you can set the bulbs up with the GE Bulb device type and then switch to the ZLL Device type. This will work until a relink is needed. Whenever a relink is needed, do the standard relink procedure and then, using IDE, temporarily set the bulb to use the GE Bulb device type. Then switch it back to the ZLL Device type and it will retain ramping and % will also work. You may need to do something with the bulb in between changing device types, I’m not sure. This is a PITA, but it works for those who eant both functions to work.


(Ricci Hoffer) #10

Got to playing with the original GE Link DTH on ST Github. On Line 218, I changed [‘delay $delyForRefresh’] to zigbee.onOffRefresh() in the def setLevel (value) section as it is on the ZLL Dimmer Bulb DTH. The modified DTH updates the dim level when using Alexa. I don’t believe it will run local any more due to it being a custom DTH after the change. Tagging @tpmanley for a possible fix as he was in on the last change (Change 10). I am a noob at this and not sure where to go next with it.


(Lee Florack) #11

As you did, I modified the standard GE Link Bulb Device Handler and it seems to work for me as well. Percentage feedback works and dimming ramp up/down is also available. Thanks! If you get feedback on any other improvements, I’d like to make those too.


(Tom Manley) #12

I’m not able to reproduce the problem at home but it could be because I’m a little ahead of what is in production. Is the problem only when setting the level through Alexa or is it also when set through other SmartApps or directly adjusting the level slider?


(Lee Florack) #13

For me, the % is not shown properly at any time - no matter how the adjustment is made. And it’s not just that it’s not properly displayed. If I try to determine the current percentage, it seems to be unknown. (for instance if I write a CoRE piston to do something based on a current percent.) With the change discussed above, it seems to work fine all around (so far).

For additional information, I know that the percentage used to work fine. I’d guess it worked up until a number of months ago, but I can’t recall to any detail.


(Ricci Hoffer) #14

My issue was the update of the dim slider/setting when using either the Alexa app, Ask Alexa, and EchoSistant. Ths bulb would change to the desire %, but the slider never updated. It also does not update when changed with a CoRE piston. I am not sure what @lflorack was using when his dim staus was not updating.

While checking it with Smartlighting everything started updating correctly again using the stock DTH, strange.

Edit: spoke to soon, no longer updating using alexa. Going to check CoRE and Smart Lighting.

Seems to be intermittent. Back to working again. I have live logging running and will check periodically.


(Lee Florack) #15

The percentage setting essentially didn’t update and display properly no matter how I made the change - directly in SmartThings, core, smart tiles. anything. To be clear, the actual change takes place (the bulb changes percent as directed), but the display of the current percent does not update.


(Tom Manley) #16

I took another look at the GE Link DTH and nothing is jumping out at me as a problem. Since I wasn’t able to reproduce the problem using Alexa or with the level slider I think we’re going to have to take a look at things on your hub to see what is going on. If you haven’t already please contact support so we can dig into it.


(Kevin Baugh) #17

I was told at the top of this thread that ge bulbs are not supported

I changed my ge bulbs to cree bulb type and the dimmer functions like it should


(Ricci Hoffer) #18

I haven’t caught it not updating in the last 20 hrs. It seems to be back on track. I will watch it close and give them a call if it creeps up again. Thanks.


(Lee Florack) #19

Mine is doing well too with the change to the DTH. GE Link Bulbs used to work fine, but something was changed along the way and the dimming percentages stopped being displayed and ‘capture and restore’ also stopped too because it appears there’s nothing to capture anymore. So, although the bulbs took the dim/brighten commands OK, the dim % was no longer shown. I’ve never reported this issue previously because GE Link bulbs aren’t officially supported by ST. With the minor code change to the ST GE Link Bulb DTH that @rhoffer found by looking in the ZLL Bulb DTH that DOES display the percentages, he and I are now working again (at least so far).


(Lee Florack) #20

A second day with no issues after modifying the ST GE Bulb DTH. Dimming percent and ramping up/down for on/off actions, it all works well. In addition, the GE Link bulbs now seem to be reporting back and forth with the hub on a regular basis. If I look to see the last time that devices have reported, it’s always less than 0.2 hours - usually even less. Previously, they’d go many hours between reporting and they’d eventually drop off. It seems that’s been fixed now.

Again, good job @rhoffer !