Multiple Issues: Device Health cannot be turned off on my iOS app and zwave switches changing to unavailable at random

Hello all,

Thank you all in advance for any help you can give me with these reoccuring issues. I will do my best to explain the situations.

1st issue explanation: I have the device health setting turned off in the settings menu however the little red icon still pops up randomly on devices at different times (top left of each line) within the “my home” list. The device can always continue to be triggered by the app (it clears the red icon) or I can also go over to the push the physical switch and that will also clear it (and the physical device works perfectly fine)

2nd issue explanation: Hmmm, I guess I explained it all in my fast typing above. So for #2, see #1 :slight_smile:
Thank you all again for helping me out!


I’m sure that’s very frustrating. :disappointed_relieved: Your best bet is to get in touch with support, because there are things that they can see from their side that we as regular customers can’t.

JDRoberts, thank you for always being there to pick me up off the ground when I run into issues. I think going “all in” with this system so quickly is what is causing me to have so many questions and experienced quirkiness in such a short amount of time.

I have been going back and forth with smartthings support and the sad thing is they say everything looks to be running smoothly on their end. I explained both issues to them and haven’t received a good response on either of them, yet.

I will keep the community updated on what transpires.


Just updating everyone on this one. These issues still aren’t going very far with support. Just replace the device etc. (the standard auto answers). Also, they stated they’re not aware of anyone having the device health issue as I am. (Where the settings show the device health to be off but it still shows the red icon on random devices on the “my home” page of the app-- when showing the red icon, the devices functions correctly from both the physical device and the app)

Just another update to this thread: Support did state , after we spoke for quite some time that issues did exist. I will be posting the whole helpdesk ticket conversation soon.

They determined device health was not turning off on my iOS device even if I had the setting set to off. They were able to replicate this on one of their “in house” test devices. They went on to say it could take them up to a week to get back to me in where they were going from there…

It’s been a few days at this point.

As stated shortly, I will post supports determination shortly.

Support essentially stated they were seeing 3 separate issues with device health on my device. (One of which is stated above-- I could never actually turn device health off because even when the setting shows off, it is still displaying the red exclamations within the app)

1 Like

Please see entire correspondance with smartthings support below.

This may help shed some light on all of the issues with the device health setting within the smarthings mobile app environment/ smartthings system in general.

Look down for bold for 3 issues that exist with device health- 1 “may” be specific to iOS devices (unknown currently)


I have device health turned off on the iOS app. However, the app still displays the little red icon with the exclamation point in the top left of a few of my devices? Why is the device health not turning off? Also, I have a few devices (they are ge z wave plus wall switches) going offline? I can also not perform a network repair because of a certain switch. The error always say repair failed due to… and it always points at one specific switch. Hope you all can help me!


Hey Weston,
Thanks for reaching out!
I’m sorry to hear this is happening.
If you completely close out of the Mobile App and reopen it, does it still show the Red Exclamation Mark?
As for the Switch that fails, let’s try the Rejoin Method to get it back:
Tap My Home
Tap Things
Tap Add a Thing
While the Hub says Searching for Devices, perform the inclusion steps for the switch
The Mobile App most likely won’t show any new devices connecting but the Switch should rejoin and work properly again.
Give that a try and let me know how it goes.
Kind regards,
Jake K.
SmartThings Support


Yes. It still shows the red exclamation point. I have even rebooted my
phone and it still does with the device health still set to off in the
settings of the app.
Also, I did the inclusion step you speak of and as you said it took the
exclamation point away but it also takes the exclamation point away if you
just go up and use the switch or if u go deep (2nd layer) of the switch
settings in the my home and turn it on.
But it will come back within a few hours or a dayish.- I have seen this
many times before. This particular switch has been a pain for some reason
though (seems to be a constant/ persistent issue with this particular
switch)- I don’t know if you can see my devices on my network but if you
can, the name of it is “bedroom light”. Maybe you can see something in the
background that I can’t.
Also, as I stated before, I have noticed when doing a z wave repair, the
log that it shows you on the website as it is doing the repair shows the
"bedroom light" fails and I’m not sure but I think that also stops the
repair process when a device fails? (I’m not sure on that one though)

Hey Weston,
Everything seems to be running fairly smooth from what I can tell on my end. Is that correct?
As for the Bedroom Light that continues to fail, when is the last time you’ve removed and re-add the switch?
Kind regards,
Jake K.
SmartThings Support


I would say yes to that. “Fairly” smooth. Not perfect by any means (it gets kind of old seeing things that you know aren’t right, kind of like a beta project).
So is there a bug with the iOS app causing the device health not to be able to be turned off? The reason I ask is it popped up on my inovelli dual plug earlier today-- this is a different device than where it showed up yesterday (the bedroom light)-- (and as I said yesterday, I have device health turned off).
And to your question about removing and then readding the switch I have never done that. So your saying do a zwave exclusion and then readd it? Doesn’t that mess up my smartapps? (As in, I will have to go into all of the smart apps where I have that specific device selected and reselect it since I’m essentially removing the device and adding another one?)
I’m sorry for all of the questions, I am somewhat new with this system and I pretty much went “all in” with it, as in I bought a bunch at once and am trying to get it all running smoothly (error free).
So the last question I had was also asked earlier, what could be causing the zwave repairs to fail at that bedroom light? (I am somewhat concerned that the “mesh” network is not being rebuilt correctly so I may not be getting the strongest zwave network.-- Do you have access to background logging for my network (that I can’t really see)?
Thank you for working with me and responding as you have time. I really do appreciate it.


“Christmas Tree” just went to unavailable with red exclamation point in top left of line.-- I just installed that outlet yesterday…


Hey Weston,
For the Bedroom Light, let’s try the Z-Wave Replace Method. That way you won’t need to redo any SmartApps.
Tap My Home
Tap Things
Tap Bedroom Light
Tap the gear icon
Tap the red Replace button
The Z-Wave protocol will first attempt to communicate with the failed device to confirm unresponsiveness. This process can take several seconds
Once the device is determined to be unresponsive, the Hub will search for the replacement device
When the Hub is searching and indicates the device is ready to be replaced, perform the replacement device’s connection (or “inclusion”) process.
Give that a try and let me know how it goes.
As for the Device Health not turning off, there is not a known issue at this time but I will bring it up with my developers.
As for the Z-Wave Network, if a device is failing, it means it is not responding to the Hub or any devices near it.

Kind regards,
Jake K.
SmartThings Support


Ok, woke up this morning and “bedroom light” as well as “back porch light” both say unavailable on the “my home” page of the app. Of course as soon as any of them are triggered, that’s status will go away and all will be fine for another couple of hours until another one goes to unavailable randomly…
So, I’m not going to trigger either one this time, I’m going to use your replace method- I have done this before and it did not fix anything either but I will do it again and we will see what happens over the next few hours/ days.
As a side note in the last 3 days each of the following have gone unavailable at some point or another:
Back Porch Light
Bedroom Light
Inovelli dual (name is bedroom Lamps)
Christmas Tree
I still say this is inexcusable and there has to be a bug in the system somewhere.-- Also, it should be known that the device health is always a false positive even though I have it turned OFF. These devices always work correctly whether triggered from the app or from the physical device. If the red icon would go away like the settings say and the unavailable would go away, I would never know there was a “malfunction” because everything is still working correctly.
Will those logs help me in any way to figure this out? I’m sure you are very capable with this system and I do appreciate you telling me where those are. (I may use them one day but it is nice to know that there is some logging going on but sad to know it must not be detailed enough to pinpoint the problem in my home)
Last side note is all of those devices are over a 400-600 sqft area- that’s why I can’t believe this is being such a PITA.
I’m sorry, I guess you can see my frustration level rising as my typing goes on. Haha. (I’ve spent close to $600 on all of this smart home stuff in about a month and I really didn’t expect it to be so “temperamental” for lack of a better)
Thank you for all of the hard work you are doing to help me figure this out but I’m really beginning to think this stuff -zwave in general- isn’t ready for “prime time”


When I go into to both of those to do the replace method, it says “device not considered failed.” If I remember correctly, this is the result I get every time I go to do this and probably why the device still functions appropriately minus saying “unavailable” and showing the red icon in the top left. (So I’m kind of back to the false positives situation.)
So I attached 5 photos to help illustrate what is going on (randomly across multiple devices at random also).

  1. Photo of my home screen with offending devices
  2. Clicking the device name on the “my home” screen takes me here.
  3. Click gear icon to take me to replace/ remove functions (clicked replace- result shown on this pic)
  4. Going back to the screen shown on pic 2 and clicking on the “X” at top right above “this device unavailable at the moment” takes me to pic 4
  5. Clicking the “off” turns the light on and clears the unavailable message in all locations and also on the “my home” screen.
  6. Showing device health turned off (I have a few sentences below about the device health, I would like a response on)
    In pic 5, notice how the “bedroom light” shows the same offending red mark. I have just cleared it with the same method.
    So I don’t know, it seems like a bug with the way the unavailable or the “polling” works. Maybe if they get a false reading from the switch, they need to “poll” it again a few minutes later to have it clear the false positive. Or to be honest, the real bug on my end seems to be the device health. If the device health turned off was working correctly, Maybe you can tell me, would I even be seeing these “unavailable” statements and the exclamation marks… I swear, I thought that was the point of device health was so it could help you know when a device is broken but it looks like it is creating more harm than good especially since the toggle in the menu says the feature is off but it is still displaying at random- in my instance it looks like I would be better off with it turned off (if it were accepting being turned off, would that make the exclamation marks etc go away or do I not understand that feature completely?) or with the false positives fixed by a “bug fix”.
    Thank you again for your help and I’m sorry my post are excessively long but I’m just trying to give you every piece of information to help you make informed decision about escalation etc.


Wanted to come back and update you on the situation. So I removed and returned the switch “bedroom Light” to Lowes because of all of the problems I have had out of it.- Maybe it’s possible that it was defective. So I reinstalled the new switch and renamed it “Bedroom Light”.- Holding my breath that it won’t show any errors.
When I woke up this morning, “Couch Lamp” and “Back Porch Light” both showed the red exclamation point. - I am not touching them and am leaving them in their current state-So we’re back to the same things I’ve been griping about for a week now (random exclamations with device health turned off- explained in previous post in detail-). I’m beginning to consider returning everything that I have purchased that is zwave/ smartthings related because this isn’t user error at this point. This is buggy software/ or maybe even buggy hardware (To me, everything points back at the hub/ smartthings app whether hardware or software I don’t know). It just heavily concerns me that no one is seeing any issues on the smartthings side and there’s no way I’m getting stuck with 600$ (switches and hub included) worth of smart home stuff that doesn’t work correctly.
Pic 7 for hub app screenshot from this morning.


Hi there,

Thanks for calling in today!

To summarize, we have a few issues going on here:

Some of your devices are reporting states of being Offline when they are in fact Online (devices respond to commands but do not respond to multiple ping attempts from the Hub). This is something that we’re aware of and working to improve going forward.
We’re currently tracking an issue in which Device Health does not correctly report states of devices as a result of the issues above. The usual recommendation is to disable Device Health (toggle it OFF) as a workaround.
You have turned Device Health OFF in the app, but it appears to still be ON. This is an issue I’m going to be looking into further with our Lead Techs, and I’ll be in touch when we have more info.
Let me know if you have any other questions or concerns!


SmartThings Support


Thank you all again for taking the time to work with me. I am very appreciative of you all listening and working with me to understand the issues I and others are seeing- Donny was also able to recreate the issue (device health not turning off even though the settings show it is off) on one of his iOS devices.
We then recreated the issue on an iOS device-an iPad specifically in which the smartthings app had never been installed on before (so we determined it wasn’t an app caching issue)

Hey Weston,
Since Donny worked with you for a good long while on the phone, I will defer to what he has said and stated. I am in agreement with his statements and will be working on the iOS App for this issue.
Kind regards,
Jake K.
SmartThings Support


Ok, thank you for your response. Will be looking forward to response to the issue once you all have had time to ‘pin’ it down.

Hey Weston,
Sounds good. We’ll let you know the moment we have an answer.
Kind regards,
Jake K.
SmartThings Support

I am confused by the steps that support suggested that you take. For one thing, the “re-join” method which is the very first thing described in your correspondence above is for zigbee devices, not Z wave devices. So that was odd.

In a situation like yours, you should do a general exclude on the device before you do the zwave replace. That way the specific device will be be reported as non-responsive in the first step of the replace, and then will be ready to be added again in the second step of the replace.

If you don’t do the general exclude first, then you would see results like you saw.

Note that in a situation like yours, you should just do a general exclude, don’t do a remove because as you noted the remove expects you to take the device out of all of your smartapps, and we don’t want to do that. The general exclusion can be used to essentially factory reset individual device without taking its identity out of your Z wave network. That’s what allows you to include it back a second time while still retaining the same network ID.

One of your questions is whether an error message will stop the Z wave repair utility. It will not. The repair utility will continue for the other devices on your network.

I don’t know why you were not able to turn off device health from the app. I haven’t heard of that one before.

Also, please do not confuse the Z wave protocol with the SmartThings platform implementation of it. Zwave itself is a solid third-party protocol which provides stable and reliable control of lighting devices all over the world. The “device health” utility is something that SmartThings created for their own platform. Although it’s always possible to get an individual bad device, most of the time if you are seeing weird instabilities, it’s because of something specific to SmartThings, not because of Zwave.

I hope they can find a fix for the problem you are seeing soon.

JDRoberts. Thank you for the response. I will make sure to do my “replaces” The way you explained above.

My whole system works great and has since my install about a month ago, minus this issue with the device health bug on iOS. I am so annoyed seeing the exclamation points all over my app interface even though I have the device health turned off.

Luckily, one of the support agents was able to recreate the issue on his device so hopefully as you say, they’ll be able to figure out the problem.

I’m surprised more people aren’t reporting this issue on the forums.

Thank you again for your always insightful responses here on the forums JDRoberts.

1 Like


Purchased my SmartThings hub two weeks ago and am seriously thinking about returning it. I only have 4 GE 3 Way switches (Z-Wave Plus) at the moment but am having the same exact issues you are. Since you can correct the problem by activating the device via the app indicates that it’s not a communication issue. This leads me to believe it’s a problem with SmartThings polling. I planned to invest a lot more money but so far the system is very intermittent, looks like Best Buy is eliminating this product; been on sale for 50% off, now 30% and very little inventory of accessories. I’m also using two iPhone’s as presence sensors and have mixed results. Had to increase my geo fence to 6K feet and still not reliable.


Hmmm. Yeah, the only problem I am having is the polling issue. Everything works correctly and even when it shows “unavailable”, the device can be communicated with (by alexa or by using the app). So, the false positive on the polling I have learned to live with-- because that would not really even be an issue if the device health could be turned off properly (device health setting isn’t working properly on iOS). Device health setting works properly on Android from what I hear.

The presence sensor issue you speak of… I will start using it tonight and report back if I see similar issues.
You may want to delete everything and start from scratch just to throw out user error. Also, another option is try out Life360 integration… I have been impressed with it, it is a little creepy though I must admit.

Also, on the discounts you are speaking of at Best Buy (if your talking about smartthings itself being discounted), I think this may be due to their “Samsung Connect” system they are investing heavily into as it carries the same home automation features of smartthings a few other features (mesh wifi etc)

I have faith in them but please put in a ticket for the polling issue. The more tickets they have, the more it will move up their list. And you can even reference this forum topic.

Four months later, how we doing Weston? I’m looking forward to learning whether or not your issues were resolved and how or whether you returned everything to Lowes! Same issue here, red exclamations in iOS app, turned health off, thought it was ok, problem returned a couple hours later. Alexa not responding/recognizing two “things”. I have been using z-wave switches and smart dimmers for several months with great success until today. Hopefully this is a temporary issue/problem that ST has identified and addressed. Update me please and great job hanging in there! If you still have??

Hi Chris.

I would say pretty well. On a scale of of 10, a happiness with SmartThings at about a 7-8.

SmartThings is certainly a highly customizable solution for power users, if only the developers could get their solution higher on the reliability.— And yes, the last few days have been a super PITA. From the whole system outage a few days ago to Alexa integration with SmartThings being Less than stellar in that time period also.

With this system, as it has its growing pains, support tickets are going to be your best friend… SmartThings support personnel are very talented and often can work you through most of the system problems… I mostly use them for recording my “gripes” about the system- and luckily almost all of my gripes have been fixed (except a few)—.

Now for the things you mention.

So I ended up returning the idevice outlets that I purchased. I’m and iOS user so the HomeKit support was enticing but since the open source creation of “homebridge”, I have no reason to have HomeKit support on my devices. I can now ask Siri to do my dirty work, or Alexa.

I have most of my home running off of just a few devices:

GE z wave plus toggle switches
Inovelli z wave plus toggle switches
Inovelli z wave plus dual outlet modules (indoor and outdoor)
Iris garage door opener
Iris open/ close sensors (zigbee)
Hue bridge with hue bulbs/ lightstrips (zigbee)

Definitely put in a ticket for your device health situation. This issue was fixed on a grand scale 1-2 months ago. — I highly suggest you verify with support or by figuring it out through the forums what the most current hub firmware and most current app version because the problem you state is supposed to be gone now.

In Alexa app, do the 2 devices have a banner that says “device unable to respond” or something of that nature? I had this issue a few days ago and it resolved itself— I believe it may be outage related— because as I stated earlier I was having some quirkiness out of my Alexa also on a single device…

That’s what blows me away about these integrations, you would think it would be an all or nothing problem… But no, it can literally affect a single device out of 40-60. Mind Blown.

If this system were more locally based (from the hub), this system could be amazing. It is very good as it stands, when it is working properly (minus outages etc). SmartThings has been moving as many device handlers as possible to local control which is a great thing overall however the smart home in general will take years and years (if it ever) becomes a boxed solution- so in my opinion, the cloud based processing will always be the Achilles heal of the smart home— especially when it involves 2 cloud based systems passing information, I.e. Alexa to SmartThings, Alexa to Harmony…

Anyway sorry to be super long winded, but if you have any other questions, I am happy to answer.