Multi-Channel Control App not functioning

I am having an issue with the official Multi-Channel Control App. I have used this before with a dual relay and it works great. However, after installing a new Z-Wave dual relay and installing the Multi-Channel Control App for that - I am not able to select the endpoints for it to control.

Additionally, I can no longer change the endpoints for the previous installation of the App.

Is anyone else having this issue? Any ideas (since this is an official, published app)?


Tagging @slagle

I would recommend uninstalling and re-installing the app. If that doens’t work, can get you sorted out. :slight_smile:

I am afraid to uninstall the app - what if I can not get it to work again and then the existing relay that is working will never work right again :confused:

Ok, so here is the deal. I got it working but I had to move the relay close to the hub and pair it again - then set up the Multi-Channel Control App while it was still close to the hub.

It seems that the App or the Hub will not recognize the endpoints if it has to use another Z-Wave device as relay in the mesh.

1 Like

How is this app supposed to work? I installed it, the relay is close to the hub, but I don’t have any new devices created.

Having the same issue with Enerwave ZWN-RSM2. Still no solution?

That was the problem in my case. Thanks it is working fine now.

I thought I’d resurrect this a bit as I (as well as about 50 others who have emailed me) seem to be having and issue with this SmartApp not detecting endpoints as well.

Full disclosure – I am affiliated with Inovelli, which manufactures a 2-Channel Smart Plug

As referenced above, I currently sell a 2-Channel smart plug on Amazon that worked flawlessly with ST up until two days ago. I’ve sold probably close to 2k units over the past few months with no issues and ST users make up about 65% of my sales.

On 04/20/17, I started to receive multiple emails from people who were trying to set up the 2-Channel device saying that the Multi-Channel Control SmartApp was not detecting the 2 endpoints on my device. Sure enough, when I tried it out on a new device, it did not work.

I called ST the next day and they suggested I reach out to the community for help… hence why I’m here.

What I’ve Tried

  • I’ve uninstalled/re-installed the SmartApp
  • I’ve moved the device directly next to the HUB
  • I’ve looked in IDE to see what communication is happening in my logs, and the SmartApp seems to be polling to the device, but nothing seems to happen.

I’m a bit perplexed because, prior to 04/20, I could install the Multi-Channel Control SmartApp and it would detect the two endpoints and list them under my, “Things” – now all it says is, “Z-Wave Device Multi-Channel” and that’s it.

I haven’t changed any firmware on my devices and all devices that are already in market still work as normal – it’s just new devices.

Any help would be appreciated – I have some engineers working on it from my end, but they can’t find anything wrong with my device.

Thanks all!


1 Like

Tagging @erocm1231 @duncan

Thanks for the tags!

Also, I should mention – I’m happy to provide any IDE log data as well as test units to anyone willing to help with this situation.

I sincerely am thankful and I’m looking forward to hopefully a solution! Thanks all.


1 Like

There is definitely a platform issue that is causing problems. I have had several reports from various users. I haven’t had time to fully troubleshoot, but one thing that seems broken is commands returned with response() are not being processed. For example, I have a multichannel switch that sends a SwitchBinaryReport when either physical switch is toggled. My handler, when receiving this report, sends a switchBinaryGet to each endpoint to find out which one has changed.

def zwaveEvent(physicalgraph.zwave.commands.switchbinaryv1.SwitchBinaryReport cmd)
    logging("SwitchBinaryReport ${cmd}", 2)
    def result = createEvent(name: "switch", value: cmd.value ? "on" : "off", type: "digital")
    def cmds = []
    cmds << encap(zwave.switchBinaryV1.switchBinaryGet(), 1)
    cmds << encap(zwave.switchBinaryV1.switchBinaryGet(), 2)
    return [result, response(commands(cmds))] // returns the result of reponse()

Well, I never get a response. Sending the commands outside of a response() (which is what my refresh() method does), gets a response. This type of behavior is being seen in several different devices that use response(). @duncan @slagle do you know of any issues that may be causing this?


Same problem with my SRT321 device handler as it’s battery operated so the commands have to be returned in a response to a wake-up event.
Broken for us around the 19th.

1 Like


There is now a discussion of the code specifics, including a possible workaround, in the following thread in the developers section of the forum:

1 Like

I was trying to setup one of your NZW37 dual switches this afternoon and seem to have run into this issue.

Hey Kenneth,

Very sorry to hear this!

I wonder if they are having issues again because I just received a couple of other emails stating the same thing.

Good news is there are two device handlers out there now that will allow you to bypass the SmartApps and work extremely well.

I put together some step-by-step video/written instructions on how to install them that should help.

I am on mobile right now, so I don’t have the direct links to the handlers, but they can also be found at the Inovelli URL that is above.

Please keep me posted on if the issue continues or if you need help installing the device handlers.

Happy to help and as always, thank you for your support!


EDIT: 07/22/17 – The Multi-Channel App is no longer required for the Inovelli/Show Home 2-Channel Smart Plug. SmartThings has worked with us to publish an official device handler.

During the pairing process, ST should detect the switch as, “Inovelli 2-Channel Smart Plug”. Click, “Ok” and then once on the, “My Home” screen, click on the plug and you will be taken to the device page where you will see, “Channel 1” and “Channel 2” (those are your individual outlets).

We’re very grateful to ST for helping us publish this and eliminate the need for any SmartApp for our product to work and as always, thanks for everyone’s support!

1 Like

Worked perfect. Thanks!
I didn’t come across the device handler route on the website when I was looking for the smartthings integration instructions. It was much more straightforward and created the child devices. I was able to just update the device type so no pairing again or anything which was nice.


I’ve been using two of Inovelli’s NW37 two-outlet plugs for a couple years, and after Samsung notified me that my account had been migrated to the new SmartThings app from Classic, the NW37s started to malfunction, e.g., neither ST or Alexa app could control the device as a unit or switches individually. I ended up excluding them and reinstalling. I still had the custom device handler installed at that point, and although ST detected the device properly (switch and two child switches), Alexa only sees the main switch. Neither device is reliably controlled by ST or Alexa.

I again excluded the device and deleted the Inovelli device handler. ST now uses a generic device handler, so it sees the device as one outlet and individually. Trouble is, it only works intermittently. Alexa still only sees the device as one outlet and can’t control it reliably either.

Any advice @Eric_Inovelli ? I just bought an EvaLogik ZW39 single dimmer switch, and it works file with the generic device handler installed by ST as well as Alexa.

I don’t want to toss the Inovelli NW37s if I can get them working reliably (even without individual outlet control), but I don’t want to keep bricks hanging around either.


Yeah happy to help. I think what you’ll have to do is delete the old device handler and download the new one located here (search NZW37):

You may also need to install the child device handler:

There is a known problem with child devices and the Alexa integration as noted here (I know this is for GH, but same applies to Alexa to my knowledge):

However, we did create a, “workaround” as our Fan/Light switch uses multichannel technology:

I know that’s a fan/light article, but you can use it for the smart plug.

Yeah the reason why this works is bc it’s not a multi-channel device. I’m not sure if ST has a built in handler like they do for generic dimmers like the ZW39. Our On/Off and Dimmer switches will do the same thing :slight_smile:

Let me know if the above helps!

1 Like

OK, first try, Inovelli still wasn’t responding. Gave up and started over. Now I’ve got both NW37s working with the 2018 device handler and child device handler. With these new device handlers, I can control the switch as a unit as well as each outlet individually. Alexa still only sees the main switch, but that’s OK. I’m wondering what changed when my account was migrated to new ST, as Alexa previously saw both switches and individual outlets separately. (I did have to switch skills from ST Classic to ST.)

I was careful NOT to buy a multichannel plug when I bought the ZW39. Since both NW37s quit when my account was migrated from ST Classic to ST, I figured the problem was NOT the devices. Thanks @Eric_Inovelli